AMDGPU pro failed installation

AMD had release AMD GPU pro drive recently and I was trying to install that on my Leap15.3.
I’m not sure why when I added local downloaded drive to the repo, I got GPG sign warning and as tried to install got this error:

he following 2 NEW packages are going to be installed:
  amdgpu-pro-versionlist amdgpu-versionlist

2 new packages to install.
Overall download size: 14.1 KiB. Already cached: 0 B. After the operation, additional 14.1 KiB will be used.
Continue? [y/n/v/...? shows all options] (y): y
Retrieving package amdgpu-versionlist-21.20-1292798.noarch                  (1/2),   7.1 KiB (  7.1 KiB unpacked)
    Package is not signed!

amdgpu-versionlist-21.20-1292798.noarch (AMDGPU Pro): Signature verification failed [6-File is unsigned]
Abort, retry, ignore? [a/r/i] (a): a
Problem occurred during or after installation or removal of packages:
Installation has been aborted as directed.

How I can fix this issue?

Choose “Ignore”. AMD is too lazy to sign its driver packages.
Maybe you don’t need them at all - Mesa 3D works faster.
You only need them for Navi2 RT or OpenCL.

If you’re asking in Hardware sub-forum then provide info about hardware.

Thanks for the reply.
I have followed that procedure, but never came to :

Accept the repository GPG key.

amdgpu-versionlist-21.20-1292798.noarch (AMDGPU Pro): Signature verification failed [6-File is unsigned]
Abort, retry, ignore? [a/r/i] (a): a


@ neocurve : are you aware, that there is a driver amdgpu (not: pro), which also delivers very good functionality and - as it is oss, it is delivered out of the box from suse:good:
i recently installed it, while radeon had nu vulkan and everything worked very well…
read this

and that

or in brief: deinstall what you have and than:

  1. zypper in vulkan libvulkan1 vulkan-tools mesa-vulkan-drivers
  2. sudo zypper install xf86-video-amdgpu
  3. add to bootloader-options
    amdgpu.si_support=1 radeon.si_support=0


Thanks for your contribution.

It is doing automatically! I did not select a!

What about opencl?

The other things is that in the same time ROCm is released with support of SP13 , and was wondering what is really different between using proper GPU driver from AMD pro diver ,or ROCm ?

1 Like

SLE SP13 is not released and is not planned yet.
ROCm is for computations. Limited to GCN5/CDNA, unofficial GCN4, headless.

Try to search on forum:

No need to install Vulkan drivers manually for different setups.
“amdgpu.si_support=1 radeon.si_support=0” is needed only for GCN1.

and this one: should work

It will not work for newer chips because command

./amdgpu-install --opencl=legacy --headless --no-dkms 

installs only legacy = old drivers.
And that instruction is for Ubuntu with another names of packages.


You’re making too much mistakes. Please read manuals before postings.

neither posts, nor manuals can be 100pct relyable without knowing what the exact situation is. so one is always in task of reading and translating those words. I only wrote, what worked for me - i do have cng1, no opencl, that worked exactly as i wrote. te did not say which card he uses, and for opencl i wrote it “should” work - not that it will work as precisly as written. i am able to translate to suse, if its ubuntu… but i like your clear words, thanks :slight_smile:

After reading all manuals and testing, at least i don’t have the impression, that opencl works on amdgpu. It could be related to my hardware - but i rather guess its not compatible with amdgpu (non pro) standalone.
As i am not interested in opencl, as vulkan is fine for me, which works like this, so this is only info * that it might not work even on old chips with amdgpu *:

Downloading this:

and extracting + doing the headless-mode only

>amdgpu-pro-21.30-1286092-sle-15.3 # ./amdgpu-install --opencl=legacy,rocr --headless --no-dkms

(does not matter, if rocr or pal is included - same result)

does install and implements opencl, but devices are not detected:

~> clinfo
Number of platforms                               1
  Platform Name                                   AMD Accelerated Parallel Processing
  Platform Vendor                                 Advanced Micro Devices, Inc.
  Platform Version                                OpenCL 2.0 AMD-APP (3314.0)
  Platform Profile                                FULL_PROFILE
  Platform Extensions                             cl_khr_icd cl_amd_event_callback 
  Platform Extensions function suffix             AMD

  Platform Name                                   AMD Accelerated Parallel Processing
Number of devices                                 0

NULL platform behavior
  clGetPlatformInfo(NULL, CL_PLATFORM_NAME, ...)  No platform
  clGetDeviceIDs(NULL, CL_DEVICE_TYPE_ALL, ...)   No platform
  clCreateContext(NULL, ...) [default]            No platform
  clCreateContext(NULL, ...) [other]              No platform
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_DEFAULT)  No devices found in platform
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_CPU)  No devices found in platform
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_GPU)  No devices found in platform
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_ACCELERATOR)  No devices found in platform
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_CUSTOM)  No devices found in platform
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_ALL)  No devices found in platform

>~ # lshw -c video | grep driver
  configuration: depth=32 driver=amdgpu latency=0 resolution=1280,1024

~ # lspci | grep Radeon
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn PRO [Radeon HD 7850 / R7 265 / R9 270 1024SP]

maybe there is some env missing and it would work, you may know…
video group is needed, render group - for Ubuntu, not for SLE/openSUSE.

I have no available GCN1 right now, so cannot test.
Latest AMD drivers for GCN1: Radeon™ Software for Linux® 20.10

I’m using Leap 15.2 + Ryzen APU. AFAIU OpenCL works in my case.
OpenCL from Mesa 3D may work with GCN1, but only v. 1.1 (1.2?), and no image support right now.