AMD Radeon HD 6290

I just got a new laptop, it has the AMD Radeon HD 6290 graphics card. I
have been looking, and I cannot find this listed as supported by the
radeon, radeonHD, or fglrx drivers. Does anyone have an idea which video
driver I need to use for this card, and how to install it? I read
through the tutorial at the front of this forum, and that is how I
figured out that this card isn’t listed as being supported.

I also was trying to figure out what driver my system installed as the
generic one, and the xorg.0.log file lists the system as having tried
everything. I am not good at reading that file, so I am not sure which
one I am using right now.

However, I do know one thing - my system was totally unstable and would
completely hang up whenever I booted up until I disabled desktop
effects. I guessed it might be that because I have had desktop effects
make my other systems unstable when I had the generic graphics driver

This laptop is for a kid that I am teaching how to use linux, so any
help would really be appreciated.


laptop used: ACER Aspire one 722, AMD Dual Core Processor C60, 4 GB Ram,
OpenSUSE 12.1, KDE 4.7.2 (new installation, dual boot with Windows 7)

Installing and running atiupgrade should be all you need - unless there are other issues with this laptop (such as hybrid graphics) .
The version of atiupgrade in my repo should still work with HD Radeon series >= 5000.
ATI driver with atiupgrade (new version)

This new version should (hopefully) work too, but I haven’t tested it myself yet:
Upgrading ATI driver with atiupgrade

This version works with models < 5000 but is intended to work with all models.

Sorry for taking so long to respond - our internet was down the whole day and I am only working on this laptop in the evenings. In any case, thank you for writing that script - it did install ok in the sense that I have a working desktop. There were some quirks, though.

I installed atiupgrade from the repo you provided. When I first ran the script, it said that it “failed to detect ATI hardware.” I noticed on the thread you directed me to in your link the person in that thread had a similar problem. In any case, after running atiupgrade, I rebooted, and now I am on the new ati driver. However, I have a watermark in the bottom right corner of my desktop that says “AMD Unsupported hardware.”

Here is some more information that I am posting that I hope will be helpful in troubleshooting this. I ran some commands and got the following information:

 # lspci | grep -i vga
00:01.0 VGA compatible controller: ATI Technologies Inc Device 9807

abby@linux-wu90:~> aticonfig --query-monitor
aticonfig: No supported adapters detected
#> fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 6290 Graphics
OpenGL version string: 4.2.11733 Compatibility Profile Context

# hwinfo --gfxcard
09: PCI 01.0: 0300 VGA compatible controller (VGA)              
  [Created at pci.319]
  Unique ID: vSkL.oTl+pcksma1
  SysFS ID: /devices/pci0000:00/0000:00:01.0
  SysFS BusID: 0000:00:01.0
  Hardware Class: graphics card
  Model: "ATI VGA compatible controller"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x9807 
  SubVendor: pci 0x1025 "Acer Incorporated [ALI]"
  SubDevice: pci 0x0598 
  Driver: "fglrx_pci"
  Driver Modules: "fglrx"
  Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
  I/O Ports: 0x4000-0x40ff (rw)
  Memory Range: 0xf0400000-0xf043ffff (rw,non-prefetchable)
  IRQ: 42 (5076 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00001002d00009807sv00001025sd00000598bc03sc00i00"
  Driver Info #0:
    Driver Status: radeon is not active
    Driver Activation Cmd: "modprobe radeon"
  Driver Info #1:
    Driver Status: fglrx is active
    Driver Activation Cmd: "modprobe fglrx"
  Config Status: cfg=no, avail=yes, need=no, active=unknown

Primary display adapter: #9

# rpm -qa | grep fglrx

thanks for your patience and help,

It might have been a totally diferent problem. Some hardware is really unsupported. Some hardware is still supported but not as well it used to be. Some hardware is supported but undetected. Some hardware is detected but claims not to be supported. Welcome to AMD’s world!

Here’s how you can remove this watermark: Post #8 of this thread:

If the problem becomes recurrent, I might end up adding this code in atiupgrade.

  • It works on 12.1 too.

On Sun, 22 Jul 2012 10:56:04 GMT, please try again
<> wrote:
> Here’s how you can remove this watermark: Post #8 of this thread:

> If the problem becomes recurrent, I might end up adding this code in
> atiupgrade.

Great, thanks for your ezcellent work! No more watermark!