amd graphics problem

whenever i launch any steam game the game fails to load untill the second launch then my dedicated graphics card just disappears from my system it wont show up in dolphin-emu or ppsspp as a device and running this command i get this

inxi -Fx
**Device-1:** Advanced Micro Devices [AMD/ATI] Navi 22 [Radeon RX 6700/6700 XT / 6800M] **vendor:** ASUSTeK **driver:** amdgpu  
           **v:** kernel **bus-ID:** 03:00.0  
           **Device-2:** Advanced Micro Devices [AMD/ATI] Cezanne **vendor:** ASUSTeK **driver:** amdgpu **v:** kernel **bus-ID:** 07:00.0  
           **Display:** **server:** 1.20.11 **driver:** **loaded:** amdgpu,ati **unloaded:** fbdev,modesetting,radeon,vesa **tty:** 129x39  
           **Message:** Advanced graphics data unavailable in console for root. 

this only happened recently after an update is this bad and how can i fix it

Are you using the default amdgpu driver (not the amdgpu-pro package)?

Are you using DRI_PRIME=1 to launch on the device?

As your user, what is the output from;

xrandr --listproviders

note the problem started again

Providers: number : 2 
Provider 0: id: 0x55; cap: 0xf (Source Output, Sink Output, Source Offload, Sink Offload); crtcs: 4; outputs: 2; associated provi
ders: 1; name: Unknown AMD Radeon GPU @ pci:0000:07:00.0 
    output eDP 
    output HDMI-A-0 
Provider 1: id: 0x86; cap: 0xf (Source Output, Sink Output, Source Offload, Sink Offload); crtcs: 6; outputs: 1; associated provi
ders: 1; name: Unknown AMD Radeon GPU @ pci:0000:03:00.0 
    output DisplayPort-1-0

Working with graphics as a root? :sarcastic:

i try it as root or well the command and it says

Can’t open display

For what it’s worth on my dual AMD gpu laptop I use switheroo-control and enabling the associated service, use the same on this desktop.

No additional settings in the grub boot options?

xrandr --listproviders

Providers: number : 2
Provider 0: id: 0x58; cap: 0xf (Source Output, Sink Output, Source Offload, Sink Offload); crtcs: 5; outputs: 4; associated providers: 1; name: Radeon RX550/550 Series @ pci:0000:02:00.0
    output HDMI-A-0
    output HDMI-A-1
    output HDMI-A-2
    output HDMI-A-3
Provider 1: id: 0x211; cap: 0x2 (Sink Output); crtcs: 2; outputs: 2; associated providers: 1; name: NVIDIA-G0
    output DVI-D-1-0
    output HDMI-1-0


Device: 0
  Name:        Advanced Micro Devices, Inc. [AMD®/ATI] Lexa PRO [Radeon 540/540X/550/550X / RX 540X/550/550X]
  Default:     yes
  Environment: DRI_PRIME=pci-0000_02_00_0

Device: 1
  Name:        NVIDIA Corporation GP108 [GeForce GT 1030]
  Default:     no

nothing extre this is the default boot options

splash=silent quiet

should i change it or try switcharoo

I would install switcheroo-control, start the service and test as above.

well i installed switcharoo and well it works fine works as intended except when i get done playing any steam game even once it then still makes my second or main graphics card disappears ad no longer shows up in dolphin-eu or ppsspp and steam wont even pick it up untill i reboot my laptop

So your using for example;

switcherooctl launch -g 1 <full patch to app/app_name>

Are you running wayland by chance?

ive tried that and no im not usnig wayland im going to see if this has anything to do with proton ge since it dose not do this with my emulaitors

ok changed nothing still is not working right and still doing the same thing im out of ideas
i have a ryzen 9 5900HX and a AMD radeon rx6800m

Maybe another forum user has some ideas… I’m a GNOME/Xorg user unfortunately.

i think one time i got an update to Xorg server and this problem went away untill i got more updates for amd-gpu kernel drivers maybe i need to force rebuild X idk and even so i may just wait for updates

Are you running amdgpu-pro driver?

no just the standard one that came with opensuse

so any way to fix this yet jw

so through trial and error i have discovered that my second graphics card disappears from my entire os until i reboot only when i run something with dxvk or vulkan i can run any emulator just fine in opengl but te second i even set up like dolphin-emu or ppsspp to run in vulkan bam my second graphics card disappears should i make a bug report