AMD.ATI Mobility X1600 - video and flash playback flickering

Hello from Bulgaria, this is my first post. I’ve a serious problem, that can’t be solved at all.
There is a lot of flickering, while i’m playing video files or flash clips in firefox ("

Section “DRI”
Group “video”
Mode 0660

Section “Extensions”

I’ve also tried some tweaking in the ‘xorg.file’ like:
Option “TexturedVideo” “off”
Option “VideoOverlay” “on/off”
Option “OpenGLOverlay” “off”
Option “XvmcUsesTextures” “True”

No difference !

Any suggestions !?!
Or it’s an ATI driver issue.

I have the X1400. I haven’t noticed a problem playing back video. Do you have Desktop Effects turned on? I got a grey screen when I turned them on. I would make sure these are off for a start. The ATI drivers seem to be causing problems going by other postings.

ATI Driver Problem - openSUSE Forums

No, I don’t have 3D Desktop effects turned on. But it doesn’t matter if it (Compiz Fusion Manager) is turned on or off. There is bad flickering.

I’ve also tried ‘vesa’ and ‘fbdev’ driver. The problem persists again, but there’s less flickering. I should specify that there’s flickering when the objects move on the video, if they are motionless - no flickering at all.
Under WinXP - i’ve never noticed ANY flickering. The card is ok, the monitor is LCD Widescreen, 17 ", 1680x1050. The computer is a HP nx9420 rh450ea laptop.

I have the X700, no problems with flash either. You may want to try the opensuse-specific fglrx driver for this issue. In yast repository manager, you can find the ati repo under community repositories. Install the driver from there. That’s what I’m using and it works fine on my laptop… for flash videos anyway.

That was the first thing i’ve tried !
Thanks for the help, I appreciate it :wink:

Anybody else ? I’ll be VERY glad, if we solve this annoying drawback !

No solution yet …

Have you tried xshm as an output video device in Xine or X11 in VLC?

Both can be configured through the options although in VLC you might have to push the Advanced button to see the video output device. You can experiment with different output plugins to see if any of them work for you.

Kaffeine it’s Settings / xine Engine Parameters / Video ->
MPlayer -> mplayer -gui -> Right Mouse -> Preferences -> Video
VLC -> Settings -> Preferences -> Video -> Output Modules

mmm no xshm as an output video device in neither players under my SuSE…

Try the different ones such as X11 etc. Try them all out :slight_smile:

I’ve tried them all, but all of them result in lots of flickering…
pfff, I’ve digged out so many forums and similar threads and no solution…

i have a similiar problem when i play video there are… see the screenshot :slight_smile:

i tryed different drivers/codec in mplayer but nothing helps

i have ati radeon 2600 HD mobility (MSI gx610px notebook)

i also tryed installing / uninstalling codec but nothing so i think it has something to do with the drivers but no idea how to fix it :frowning:

I begin to think it’s the X server, because there is no sense the problem to persist in all drivers i’ve tested, video driver outputs of the many players, all the distributions (not only openSuSE (since 9.0), but also Fedora (all versions from 6 to 9), Ubuntu (from 7.04 to the third alpha release of Ubuntu 8.10, code name “Intrepid Ibex”), Mandriva, Debian, Slackware, PCLinuxOS, Simply Mepis).

It’s common issue in Linux for me. No flickering in Windows.

The ATI cards are really buggy in Linux. That’s the obvious truth.


What’s your opinion ? Which is the best (fglrx) driver version (the fastest) for amd.ati cards so far ?

Best Regards.

I found a solution to this problem in the ubuntu forums.

The xorg.conf file has to be edited.

[SOLVED] [FIX] Video Flicker with Compiz on ATI Radeon M285 (may help others) - Ubuntu Forums](

Substitute gedit with your favorite text editor. I suggest installing the nano text editor in yast.

SUSE configured my xorg.conf with 2 device sections. I put the options in the second section and it worked.

Here’s what my device section looks like:

Section “Device”

#BusID “1:0:0”
Identifier “Device[0]”
Driver “radeonhd”
VendorName “ATI”
BoardName “Mobility Radeon X1600”

Section “Device”
Identifier “aticonfig-Device[0]-0”
Driver “fglrx”
BusID “PCI:1:0:0”
Option “VideoOverlay” “off”
Option “OpenGLOverlay” “on”
Option “TexturedVideo” “off”

Hi eXTIgyro,

Many thanks for that last post, I too have had this problem for the last wee while and have simply put up with having tried any number of things. The behaviour is consistent over multiple players, but strangely flash video (like the likes of u-tube) shows fine in the browser…

I have just changed my xorg.conf, by default ati-configure set video-overlay to on, opengloverlay to off and no mention of textured video whatsoever!

I have a Radeon HD3100, I changed it around so now opengloverlay is on and video overlay is off, this has stabalised the playback considerably, but I do still get flickers, sometimes one every one-two seconds, sometimes several per second. What’s really strange and I don’t know if its enlightening or not, but the “shape” of the flickering seems to be always like _/-, or there abouts. i.e. to straight lines one higher than the other, either side of a slanted line, its quite distinct.

Does anybody know, generally what options are/aren’t a good idea to try together, i.e. should I try switching all off, and switch one on at a time to see which makes a difference or vice versa?

Any help would be very much appreciated…


Not sure if this is useful or not i.e. I’m not sure if this is the “expected” behaviour or not, but when playing a video in a window, the flickery video is ALWAYS on top, I can see the window behind the video as it is flickering, the window that “should” be on top responds normally when activity occurs in the area overlapped by the video.

You guys might want to consider just using the stock radeon driver for the time being. I have no problems at all with video playback using the radeon driver on my notebook.

Plus the ATI driver causes my system to lock up several times a day, which is a pain. Nice 3d acceleration, but not worth all the trouble, at least for me.

Hi foresthill,

Thanks for the feedback. If I wanted to try out your suggestion I would do …?

  1. blacklist the fglrx driver so it doesn’t load at boot up
  2. change the driver for the relevant device in xorg.conf (after backing it up, of course…)

anything else required?

Thx in advance…

Your way may work, but I would just uninstall the ATI driver and reboot. If you used the installer, the command (in superuser mode) is:


If you used the one click method, just go to Yast / Software Management and search for “fglrx”. Two fglrx files should come up in the search. Then just uninstall and reboot.

Should you get a blank screen on reboot, run this command:

sax2 -r -m 0=radeon


Thanks for the info. It actually took me a couple of attempts to get the drivers installed in the first place so I was reluctant to uninstall them in case things went belly-up again!

I blacklisted the fglrx driver and set the device driver to use “radeon”. X completely failed to boot saying it couldn’t find a device. I tried radeonhd with the same problem.

I’m also having problems resizing windows on kde4 (a known problem with fglrx too) so thought the above worth a try.

If anybody knows of any other native drivers that will support a radeon HD3100 I’d be grateful for any suggestions!

I’m not particularly bothered about the 3d support, as good video playback and ability to resize windows without waiting ~30 seconds would far overcome the 3d support…

Thanks in advance!

Just thought I’d tag on some extra relevant info…

lspci gives :
01:05.0 VGA compatible controller: ATI Technologies Inc RS780MC [Radeon HD 3100 Graphics]

as the card and the actual error when attempting to use either radeon or radeonhd as the device driver is :

(II) RADEONHD: version 1.2.1, built from dist of git branch master, commit 566ba690

(II) Primary Device is: PCI 01:05:0
(--) Assigning device section with no busID to primary device
(EE) No devices detected.

Fatal server error:
no screens found