always root terminal

I noticed that if you do Settings / Save as Default after doing su in a KDE3 Konsole, then afterward every time you open Konsole it tries to log you in as root, asking for a password. Does anyone know how to undo this change? I can’t access non-superuser Konsole any more!!


Have you tried typing ‘exit’ or ‘su [normal user name]’ in said terminal then choosing save as default again?

Thank you for the reply! Yes, when I do that, the Konsole just disappears. BTW: this happens whenever starting Konsole from the SuSE menu (Konsole) or Konqueror right-click/Actions/OpenTerminalHere…

Open this konsole, login as root, then do:
rm -rf /home/YOURUSERNAMEHERE/.kde/share/apps/konsole
Close konsole
Now the default profile has been deleted.
Start konsole and you’ll be back to normal

Didn’t work!!! :frowning: I ran Konsole in the “run” dialog and:

TYAN-2:~ # rm -rf /home/patti/.kde/share/apps/konsole
TYAN-2:~ # exit

…then when I restarted I still get the “Password” prompt! Then I tried deleting the same place from the “root” dir - same result - I still always get prompted for root Password when I open Konsole!

I noticed that if I do “session/ New Shell” in the menu of the root Konsole, it opens a non-root konsole. I tried saving settings there, then exiting, but I still get a root konsole whenever I try to start a user Konsole.

PattiMichelle wrote:
> Didn’t work!!! :frowning: I ran Konsole in the “run” dialog and:
> Password: TYAN-2:~ # rm -rf /home/patti/.kde/share/apps/konsole
> TYAN-2:~ # exit

change “rm -rf” part to “rm -riv” and if/when it asks if it is ok to
delete, type yes

then, please copy and & the output back to here…

oh, and tell me which of these you have:


and, are you currently booting to KDE3 or 4??


TYAN-2:~ # rm -riv /home/patti/.kde/share/apps/konsole
rm: descend into directory /home/patti/.kde/share/apps/konsole'? yes rm: remove regular file /home/patti/.kde/share/apps/konsole/BlackOnLightYellow.schema’? yes
removed /home/patti/.kde/share/apps/konsole/BlackOnLightYellow.schema' rm: remove regular file /home/patti/.kde/share/apps/konsole/Transparent_darkbg.schema’? yes
removed /home/patti/.kde/share/apps/konsole/Transparent_darkbg.schema' rm: remove directory /home/patti/.kde/share/apps/konsole’? yes
removed directory: `/home/patti/.kde/share/apps/konsole’
TYAN-2:~ #

The terminal colors changes afterward, but it still asks for a password at startup of the Konsole. I have both the .kde and .kde4 directories, and I always boot kde3. There doesn’t seem to be a Konsole directory in the .kde4 directory tree.

Out of curiosity what exactly is the command in the menu launching it, i.e if you launch Konsole from another konsole after getting back to normal user, su user, do you still get kdesu.

If no to Konsole launch, then look at, edit menu and post the command it is using. If it does it whilst launching from konsole we’ll tackle that then.

Also to just rule out/in user config do new accs have the problem?

Actually, I don’t know how to get back to normal user after konsole starts as su… if I do ‘exit’ it just quits. Any way that I open the Konsole brings up the super user mode, either from the KDE menu, from the Konqueror right-click/actions/open terminal here or from the run dialog “konsole” I did check the edit-menu in the KDE menu to see if it was doing something like “su konsole” or something, but it was just the normal command line (I’m not booted in suse right now). I haven’t tried creating a new account to see if it still happens. I do remember that if I select “open a new terminal” from the menu in the konsole windo decoration, then the new terminal does not open in su mode. Does that help?

I had this happen once before in 10.3 on my laptop and thought it was a bug in my installation, but here it is again, this time at work. Since I’m not really the command line type, it’s very handy to be able to navigate konqueror to a desired directory, then right-click and “open a terminal here” - not being able to do that is the main frustration. If I open a second terminal in the su terminal that pops up, it’s sent back to my home directory.

PattiMichelle wrote:
> Actually, I don’t know how to get back to normal user after konsole
> starts as su… if I do ‘exit’ it just quits.

simple since “su” alone ASSUMES you wanna become root, use:

su [your user name]

if there are more than one user on the system, you can use su to
become any of them (AND assume their operating environment)

for details, see man su


Think you’ve got something be intrigued if it is solved in a new users acc.

But the bit that stood out

run dialog “konsole” does it but open new from konsole menubar doesn’t. This suggests that global works, and isn’t picking up su along the way.

lets see what
ls -ll $(which konsole)

One other thing when this happens have a look at about in konsole. Time ago I used to get kde4’s kate in kde3 but only when I su’d(wondering whether though kde3 is the base the problem is kde4).

Also perhaps try to launch the separate bins in the opposite environment. Really can’t remember where/how they split the 2 envs. So need to find the 2 separate bins, think /var/opt/kde(4)/bin or the search tool of your liking. Once you have the whole path launch it with the whole path. So if in in kde4 something like…


Check the paths which konsole should give you the whole path, but only in one env, but the difference is likely to be only kde/kde4

Do a lot of this after su - user, note the - iirc this is needed so we can check the users env the - will treat it like you logged in and give you the correct paths and envs related to the user.

Sorry this took so long - it was a few days before I could boot the SuSE machine…

TYAN-2:~ # ls -ll $(which konsole)
-rwxr-xr-x 1 root root 6960 Jul 8 2008 /usr/bin/konsole
TYAN-2:~ #

The SuSE Menu file manager (konqueror) has
“kfmclient openProfile filemanagement”
… as the argument. When I do the SuSE Menu/ Run Command/ konsole, I also get a root konsole.

From the root konsole, I do Session/New Shell or New Linux Konsole - then I get logged in as myself, but in my personal root directory.