All kinds of problems with Lenovo Ideapad

I just installed openSUSE Leap 15.3 on a brand new Lenovo Ideapad Slim 7, and I’ve run up against a slew of problems:

  • The touchpad doesn’t work, period. (I’m using a USB trackball.)
  • Facebook videos never work, period. Usually FB reports “This video file cannot be played Error Code 102630”; sometimes it just says it cannot play the video.
  • YouTube livestreams don’t work.
  • Bluetooth headphones are always an ordeal. They often fail during use, sometimes fail to connect, and often fail to work even when KDE reports that they are connected.
  • The Bluetooth microphone never works.
  • Restart never works. The computer hangs after the shutdown sequence, and requires a cold shutoff to regain control.
  • Windows 10 appears to be upset with Grub 2; it sometimes demands the 48-digit BitLocker key in order to boot.
  • I cannot mount the Windows partition from openSUSE; it responds with “unknown filesystem type BitLocker”

Investigating the touchpad problem, I found out that Lenovo has not certified my model as Linux compatible. I did not know this was a thing. Elsewhere, someone posted that it doesn’t mean it’s not compatible, only that Lenovo hasn’t tested it.

Trying to investigate the FB video problem, I ran across a video about Linux compatibility. The narrator wonders why people just assume that all PCs are Linux compatible.

I dunno… maybe because in more than 2 decades of hearing about Linux, and nearly 10 years of using it, I’ve never seen a single mention of Linux compatibility? No distro plugs, no installation instructions, no advice I’ve seen prior to this very month have ever mentioned the possibility that a Wintel PC might not be Linux compatible.

Peripherals only reinforce this. No peripheral I have seen over the past 10 years so much as acknowledges the existence of GNU/Linux. I look all over the package labels, pore through the instruction manuals, and there is never, ever, ever any mention of Linux. They ironically tout Android and Chrome OS compatibility, but there is never any mention of GNU/Linux. Yet they all worked, no problem other than the odd Bluetooth glitch, on my past 2 dual-boot machines. This added to the illusion that compatibility was not an issue.

Are there solutions to my problems? Or did I just buy a $1000 white elephant?

Did you follow any instructions on http://opensuse-guide.org/codecs.php ?

Run from Konsole or other GUI terminal, please provide output from

**inxi -SGa**
	or
**inxi -SGxxx**

Give Tumbleweed a try, you can just try booting an image from USB stick. For brand new hardware often new drivers are needed.

Or did I just buy a $1000 white elephant?

I did once build a brand new laptop but found out it did have some Intel SDD hardware (Octane?) that was not supported so I did return it and bought a good second hand Lenovo laptop.

According to ArchLinux wiki on this device:

The touchpad does not work to begin with. It may work initially with libinput or synaptics, but only sometimes. The touchpad can be seen registered either as Elan Touchpad or ELAN0634:00 04F3:3124 in the Xorg logs. Since the touchpad only works, when it is seen registered as ELAN0634:00 04F3:3124 in the Xorg logs, the touchpad works quite randomly, but not consistently. To circumvent this, one has to blacklist the elan_i2c kernel module.

elants_i2c would need to be blacklisted instead for the Intel version of the Lenovo Yoga Slim 7.

Try the recommended blacklist.

Any chance that this is because Windows10 was NOT shutdown fully but placed insort of a suspend mode, so to allow a quicker reboot of Windows10?

Which browser are you using? Firefox?

If firefox,take a look at this article: https://droidtheory.com/fix-error-code-102630/

Which browser? Did you try more than one browser?

User needs to disable fast boot to use dual boot with Linux: https://www.asus.com/support/FAQ/1045548

No, thanks for pointing that out.

From the install stage, YaST gave the following message:

Software installation
Installation was only partially successful.
The following packages could not be installed

  • vlc-codecs

When setting the Packman Repository, I got these messages:

the installed vlc-3.0.13-bp153.1.1.x86_64 requires ‘vlc-noX = 3.0.13-bp153.1.1’, but this requirement cannot be provided
Conflict Resolution:

  1. Following actions will be done:
    keep obsolete vlc-noX-3.0.13-bp153.1.1.x86_64
    keep obsolete vlc-qt-3.0.13-bp153.1.1.x86_64
  2. deinstallation of vlc-3.0.13-bp153.1.1.x86_64
  3. break vlc-3.0.13-bp153.1.1.x86_64 by ignoring some of its dependencies

the installed vlc-noX-3.0.13-bp153.1.1.x86_64 conflicts with ‘vlc-beta-noX’ provided by the to be installed vlc-beta-20210910.ac3b597871-pm153.2.1.x86_64
Conflict Resolution:

  1. deinstallation of vlc-codec-gstreamer-3.0.13-bp153.1.1.x86_64
  2. keep obsolete vlc-codec-gstreamer-3.0.13-bp153.1.1.x86_64
  3. remove lock to allow removal of vlc-noX-3.0.13-bp153.1.1.x86_64

the to be installed vlc-beta-20210910.ac3b597871-pm153.2.1.x86_64 obsoletes ‘vlc-qt < 20210910.ac3b597871-pm153.2.1’ provided by the installed vlc-3.0.13-bp153.1.1.x86_64
Conflict Resolution:

  1. deinstallation of vlc-lang-3.0.13-bp153.1.1.noarch
  2. keep obsolete vlc-lang-3.0.13-bp153.1.1.noarch
  3. remove lock to allow removal of vlc-qt-3.0.13-bp153.1.1.x86_64

the to be installed vlc-beta-20210910.ac3b597871-pm153.2.1.x86_64 conflicts with the ‘vlc’ provided by the installed vlc-3.0.13-bp153.1.1.x86_64
Conflict Resolution:
Conflict Resolution:

  1. deinstallation of vlc-3.0.13-bp153.1.1.x86_64
  2. deinstallation of vlc-vdpau-3.0.13-bp153.1.1.x86_64
  3. keep obsolete vlc-vdpau-3.0.13-bp153.1.1.x86_64

I selected “keep obsolete…” each time. But Facebook videos are playing now. I’ll have to wait for my next YouTube livestream to see if that works, but that may be a while. Note: YaST would not allow me to copy these messages, so there may be typos.

ricky@localhost:~/bin> inxi -SGa
System:
  Host: localhost Kernel: 5.3.18-59.19-default x86_64 bits: 64 compiler: gcc 
  v: 7.5.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.3.18-59.19-default 
  root=UUID=fdff2473-abc1-411a-a85c-5abeb1a67907 splash=silent 
  mitigations=auto quiet 
  Desktop: KDE Plasma 5.18.6 tk: Qt 5.12.7 wm: kwin_x11 dm: SDDM 
  Distro: openSUSE Leap 15.3 
Graphics:
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Lenovo 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:9a49 
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo 
  bus ID: 3-6:4 chip ID: 04f2:b6cb serial: 0001 
  Display: x11 server: X.org 1.20.3 compositor: kwin_x11 driver: modesetting 
  unloaded: fbdev,vesa alternate: intel resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 20.2.4 
  direct render: Yes 

When I see new version to install matching old version to remove, I usually proceed by selecting remove, but when that tries to compound the problem, I force remove with rpm (rpm -e --nodeps), then install the “conflicting” package(s) with zypper.

<xdpyinfo missing> 

Please install xdpyinfo and run sudo inxi -U before using inxi with G again.