Aktualizacja Tumbleweed - konflikty pakietów

Witam
Podczas aktualizacji całego systemu Tumbleweed :
***zypper refresh
***zypper update

  • pojawił się problem:

Wykryto konflikty między plikami (2):

File /usr/etc/login.defs
*** from install of***
*** login_defs-4.11.1-1.3.noarch (Repozytorium główne (OSS))***
*** conflicts with file from package***
*** shadow-4.8.1-5.3.x86_64 (@System)***

File /usr/share/man/man5/login.defs.5.gz
*** from install of***
*** login_defs-4.11.1-1.3.noarch (Repozytorium główne (OSS))***
*** conflicts with file from package***
*** shadow-4.8.1-5.3.x86_64 (@System)***

Pakiet shadow też ma konflikt podczas próby aktualizacji:
***the to be installed shadow-4.11.1-1.3.x86_64 requires ‘libsemanage.so.2.()(64bit)’, but this cannot be provided.


https://www.yml.pl/wp-content/uploads/2022/04/shadow_aktualizacja-1024x531.png
https://www.yml.pl/wp-content/uploads/2022/04/shadow_aktualizacja-1024x531.png
https://www.yml.pl/wp-content/uploads/2022/04/shadow_aktualizacja-1024x531.png

Cześć
Komenda zypper update działa prawidłowo w Leap, jednak w Tumbleweed z tego co słyszałem, do aktualizacji zalecana jest komenda zypper dist-upgrade lub zypper dup lub po prostu aktualizuj z poziomu YAST.
Szczegóły → https://itsfoss.com/update-opensuse/
Powodzenia !

@StargatePL,

poproszę o:

 zypper lr -e myRepos.repo

I wklej, proszę, na:
https://paste.opensuse.org

Bardzo dziękuję za porady, zaktualizowałem system - poleceniem “zypper dup”.

To świetnie! A my wciąż nie wiemy, jak wyglądają Twoje źródła dla zyppera:
https://forums.opensuse.org/showthread.php/568720-Aktualizacja-Tumbleweed-konflikty-pakietów?p=3120430#post3120430