Akonadi won't start

I use kmail and kontact on an almost daily basis but sometime over the past week whenever I try to open either I get the ‘Akonadi server is starting’ box that just doesn’t go away

Unless I crash it with ctrl-alt-esc it will just stay there doing nothing, yesterday I left it attempting to start for over two hours

I tried deleting the folder.config/akonadi as was suggested as a fix that worked for someone during my googling on the subject without success, and I’ve looked for anything akonadi related in /var/log/messages but nothing there

Any suggestions on what I should be trying to fix this?

Akonadi must be logging it’s activity (and start failures) somewhere, but as I’ve no idea where it does that I can’t really look into what’s causing it to fail

It’s suse 11.3 64 bit and other than what the update applet’s done there have been no changes made to the system for quite some time, well before this behaviour started

Forgot to mention, it’s using nfs exported homes and nis logins

The nfs/nis server is the same OS and again no changes other than the recommended updates

Some of us might consider that a desirable feature.

Check whether there is anything in $HOME/.xsession-errors
Most user level processes just report errors to stderr, and that is normally redirected to .xsession-errors (and overwritten if you restart you Xwindows session).

I agree with you mate! If I knew how to use kontact/kmail without it I would

The contents of .xsession-errors is pretty much a mirror image of what I get if I run akonadictl start:

Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
Starting Akonadi Server...
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
ecky@beastie:~> [akonadiserver] search paths:  ("/usr/lib64/mpi/gcc/openmpi/bin", "/home/ecky/bin", "/usr/local/bin", "/usr/bin", "/bin", "/usr/bin/X11", "/usr/X11R6/bin", "/usr/games", "/opt/kde3/bin", "/usr/lib64/jvm/jre/bin", "/usr/lib/mit/bin", "/usr/NX/bin", ".", "/usr/sbin", "/usr/local/sbin", "/usr/local/libexec", "/usr/libexec", "/opt/mysql/libexec", "/opt/local/lib/mysql5/bin")
[akonadiserver] Found mysql_install_db:  "/usr/bin/mysql_install_db"
[akonadiserver] Found mysqlcheck:  "/usr/bin/mysqlcheck"
[akonadiserver] Database process exited unexpectedly during initial connection!
[akonadiserver] executable: "/usr/sbin/mysqld"
[akonadiserver] arguments: ("--defaults-file=/home/ecky/.local/share/akonadi//mysql.conf", "--datadir=/home/ecky/.local/share/akonadi/db_data/", "--socket=/home/ecky/.local/share/akonadi/db_misc/mysql.socket")
[akonadiserver] stdout: ""
[akonadiserver] stderr: ""
[akonadiserver] exit code: 1
[akonadiserver] process error: "Unknown error"
[akonadiserver] "
[akonadiserver] 0: akonadiserver(_Z11akBacktracev+0x39) [0x40c5d9]
[akonadiserver] 1: akonadiserver() [0x40cb42]
[akonadiserver] 2: /lib64/libc.so.6(+0x32a60) [0x7f4151269a60]
[akonadiserver] 3: /lib64/libc.so.6(gsignal+0x35) [0x7f41512699e5]
[akonadiserver] 4: /lib64/libc.so.6(abort+0x186) [0x7f415126aee6]
[akonadiserver] 5: /usr/lib64/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0x74) [0x7f4152447984]
[akonadiserver] 6: akonadiserver(_ZN15FileDebugStream9writeDataEPKcx+0xab) [0x40e45b]
[akonadiserver] 7: /usr/lib64/libQtCore.so.4(_ZN9QIODevice5writeEPKcx+0x77) [0x7f41524d2c37]
[akonadiserver] 8: /usr/lib64/libQtCore.so.4(+0x103026) [0x7f41524db026]
[akonadiserver] 9: /usr/lib64/libQtCore.so.4(_ZN11QTextStreamD1Ev+0x3b) [0x7f41524e3efb]
[akonadiserver] 10: /usr/lib64/libakonadiprivate.so.1(_ZN6QDebugD1Ev+0x4b) [0x7f415289a47b]
[akonadiserver] 11: /usr/lib64/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer25startMysqlDatabaseProcessEv+0x1c3a) [0x7f41528a379a]
[akonadiserver] 12: /usr/lib64/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer20startDatabaseProcessEv+0x2e8) [0x7f41528a96f8]
[akonadiserver] 13: /usr/lib64/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServerC1EP7QObject+0x76) [0x7f41528a9b26]
[akonadiserver] 14: /usr/lib64/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer8instanceEv+0x4a) [0x7f41528ab22a]
[akonadiserver] 15: akonadiserver(main+0x217) [0x406767]
[akonadiserver] 16: /lib64/libc.so.6(__libc_start_main+0xfd) [0x7f4151255b7d]
[akonadiserver] 17: akonadiserver() [0x406459]
[akonadiserver] ]
[akonadiserver] "
ProcessControl: Application 'akonadiserver' returned with exit code 255 (Unknown error)
[akonadiserver] search paths:  ("/usr/lib64/mpi/gcc/openmpi/bin", "/home/ecky/bin", "/usr/local/bin", "/usr/bin", "/bin", "/usr/bin/X11", "/usr/X11R6/bin", "/usr/games", "/opt/kde3/bin", "/usr/lib64/jvm/jre/bin", "/usr/lib/mit/bin", "/usr/NX/bin", ".", "/usr/sbin", "/usr/local/sbin", "/usr/local/libexec", "/usr/libexec", "/opt/mysql/libexec", "/opt/local/lib/mysql5/bin")                                                                                                                                                              
[akonadiserver] Found mysql_install_db:  "/usr/bin/mysql_install_db"                                                                                                             
[akonadiserver] Found mysqlcheck:  "/usr/bin/mysqlcheck"                                                                                                                         
[akonadiserver] Database process exited unexpectedly during initial connection!

With regards to making sense of all that the best I can do is that it seems to fail on connecting to mysql for some reason, then goes into a loop through constant retries

The output I posted isn’t the complete output, it gets endlessly repeated, I just posted as far as the second ‘[akonadiserver] Database process exited unexpectedly during initial connection!’ entry to show it retrying


If I run mysqlcheck with the parameters given in the output I find the following

("–defaults-file=/home/ecky/.local/share/akonadi//mysql.conf", “–datadir=/home/ecky/.local/share/akonadi/db_data/”, “–socket=/home/ecky/.local/share/akonadi/db_misc/mysql.socket”)

Cannot open the file /home/ecky/.local/share/akonadi//mysql.conf, it does exists so permissions perhaps?

mysqlcheck reports that --datadir is an unknown parameter

If I replace --datadir with -A (all databases) it says ‘/usr/bin/mysqlcheck: Got error: 2002: Can’t connect to local MySQL server through socket ‘/home/ecky/.local/share/akonadi/db_misc/mysql.socket’ (111) when trying to connect’

mysql.socket also exists

I am avoiding kmail, partly because I am not doing anything that should require akonadi. I mostly use webmail, but I also use claws-mail when I need a local mail gui application.

Yesterday, I started kmail, just to check something. Looking through .xsession-errors, I see that it is telling me how to start the mysql server. Since kmail did run, I think it can work without a mysql server other than an instance that akonadi starts itself. In your case, it could be that akonadi attempted to start mysql, but it failed to start.

(After stopping kmail, I killed akonadi and then removed “.local/share/akonadi”)

kmail isn’t quite so crucial, I use thunderbird for personal mails and kmail for work addresses, I could always use another client, it’s not like there’s a shortage of them

But kontact’s another story, firstly I don’t really know of anoher kde app that does the same stuff, and secondly, if I did know of one it would take a lot of time and effort to migrate to it

As I plan on installing 11.4 when it’s available in a few days time anyway, I thought I’d see what would happen if akonadi was removed

Yast wanted to uninstall kmail and some other stuff along with it, what the hell I thought, let’s see what happens, so I let it do it’s thing

Now I have a lovely icewm desktop

No more kde or xfce

Well, they’re obviously still there, just can’t get into either of them

So now I know what happens if I remove akonadi

Interesting. Thanks.

KDE works fine without akonadi running. But the dependency chains are about libraries, and there are probably akonadi library links in a bunch of KDE applications. I know that I have accidently started akonadi on several occasions. Perhaps I should try going back to fvwm, which is what I used for my first few years with linux. There’s actually very little of KDE that is important to me. I mostly need X of some sort so that I can run a browser. And I need to be able to start a file manager (I use the unix shell for that, so xterm works fine for starting it).

Turning of “tracker” was my other annoyance. I installed XFCE, KDE, gnome on this system. I had to disable tracker in all of those, to stop tracker from automatically running.

Yes, I’m planning to go to 11.4 soon. I haven’t yet decided what to install. I’ll probably stay with KDE so that I can run NetworkManager on my laptop. But I don’t much care for the bloat (or “feeping creaturism”). I have to admit that the massive bloat of Windows is what allows us to have the high speed processors and multi-gigabyte memories of today’s computers at relatively low prices.

I’ve installed the RC2 in a vm just for a look, and akonadi fails to start, citing a missing qtsql driver qmysql as being the problem, something I remember coming across looking through the errors I was getting on 11.3 and a quick google shows it to be a common problem

What this page has to say sounds about right to me: Linux / Akonadi: The QtSQL driver ‘QMYSQL’ is required by your current Akonadi server configuration.

I did think about looking into the merits/possibilities of and how one would go about running kontact/kmail without akonadi, but then I thought why should it be necessary, seems to have been a lot of complaints/negative comments about akonadi so I can’t help thinking that if it’s gonna continue to be included that this stuff would be ironed out

Usually I stick with kde apps but if this is still the same in the final 11.4 release, which looks like being the case I’m thinking of trying evolution for a while instead, they do say a change is as good as a rest … and I could do with a rest from akonadi in it’s present state :\

Before giving up, I would try with a newly created user. If it works there, then it might be a problem in your personal settings.