after upgrading opensuse with tbird & enigmail issues

dear linux experts,

i have upgrade opensuse from 12.3 to 13.1 - all went nice and i thougth that i can use Thunderbird as i did before.
note - have tbird with enigmail. and all of the things was workin perfectly - untill the update to the new Version of opensuse.

well - if i try to start tbird now - i get the following message:

Could not initialize the application’s security component. The most likely cause is problems with files in your application’s profile directory. Please check that this directory has no read/write restrictions and your hard disk is not full or close to full. It is recommended that you exit the application and fix the problem. If you continue to use this session, you might see incorrect application behaviour when accessing security features.

note: i can see the keys in the KGpg programe.

i do not know why the tbird does not start!?

any idea how i can go any step further - how to investigate the issues and problems?

update; **
note - now the tbird starts but i

cannot send the mails
cannot save the drafts to a folder - the system denies that!

how to check further options and possibilities to fix the system!? What can i do now!?

Look forward to hear from you


while i have serious issues with the usage of tBird and enigmail after upgrading form opensuse version 12.2 to verison 13.1

i check for the issues that may cause this behaviour

well - the fact that i cannot store drafts makes me thinking that the paths may be wrong or just unusable.
i guess that i am not able to use the “old” paths.

if i look to an user-profile then i have a closer look at the paths - eg. the server settings:

if we take this one - message storage in

Local directory:


well if i try to “browse” (note there is a button that allows me to browse) then i see funny things

The Local Directory path “/home/martin” is not suitable for message storage. Please choose another directory.

well - is it true that i cannot use the directory.

why ?*

Some of my nasty problems seem to be that the OpenSuse version of Thunderbird has the code to check for dangerous directories, but
doesn’t have the bug fixes to turn that just into warnings. Well this makes me sad. What a pity. Well hmm in my humble opinion this behaviour is probably based on TB 24.0, well but not on version 24.2.0. That is one of the risks of using a build provided by my distro rather than using the latest version from Mozilla.

Well its possible my enigmail problems are also due to a bug fix i don’t have, but I don’t track engimail’s status enough to know that. Hmm - some friends suggested me to consider installing a Linux build of Thunderbird from the Mozilla web site. That will give you more frequent bug fixes (if you don’t disable it checking for new versions) and hopefully avoid some problems because then we would be much much more mainstream.

Well it could also have to do with the specific builds use a different profiles.ini file,

I for one don’t know very much about OpenSuse.

Well considering the upgrade i would have to move the profile per
-_Thunderbird .

Hmm - well i will investigate further - but on a first step i had a quick view on the versions i run on opensuse 13.1

KGpg Version 2.10.1
Unter** KDE 4.11.3**

Thunderbird 24.2.0

how to check **enigmail verison ** via console?

love to hear from you


i have more infos - probbly they are important . see them

on my investigatiions i have followed vriouse things - i looked for the user-profiles

While i ve read that it is very very important to have a look at the user-profiles - see this threads

These instructions will seem strange since there is no “move profile” or “register profile” button in the profile manager, but this isn’t a mistake. When you press the “Create Profile” button and then browse to your profile’s location, this does not do anything to your profile; it merely updates profiles.ini to point to that profile so that Thunderbird can find and use that profile. You could do the same thing by editing profiles.ini yourself, but it is very easy to make a mistake doing that. Image:Profilemanager1.png

i tried to start the thunderbird user profile:

linux-70ce:/home/martin # thunderbird -P
(process:9155): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
linux-70ce:/home/martin # 

This looks very very weird
well you see it failed.

well what can i do now!?

On 2014-01-11 23:06, dilbertone wrote:
> dear linux experts,
> i have upgrade opensuse from 12.3 to 13.1

How exactly?

Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

hello dear Robin

many many thanks for the quick reply - great to hear from you

well - as mentioned at some places. i ve got two notebooks

  • one on which i did a fresh installation of opensuse 13.1 - on that i have tbird running fine with all
  • the posts
  • the full access to every account and all works ince

-besides this noteboook i have a second one - where i runned a upgrade fom opensuse 12.3 to version 13.1 with the upgrad-script which is uses by thousands.

see (unfortunatley it is in German - see and have a closer look;

love to hear from you


On 2014-01-12 23:06, dilbertone wrote:
> hello dear Robin
> many many thanks for the quick reply - great to hear from you
> well - as mentioned at some places. i ve got two notebooks

Please, I just need to know how you did the upgrade from 12.3 to 13.1 in
this current machine on which you have the problem in this thread. Do
not send me chasing threads or reading explanations on sites on
languages I can not read.

I just need that quick answer to know if I can be of help or not. If you
do not wish to answer then I can’t help, sorry.

Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)