After upgrading from leap to Tumbleweed I don't have GUI but only have tty1 and lochalhost login

I upgraded from openSuse Leap to Tumbleweed and now I don’t have GUI ,instead there is tty1 with localhost login asking me for username and password ,after I correctly log in ,I’m still in tty1 !?
I also tried ctrl+alt+f7 with startx ,but startx cant start .This only happens on latest kernel 51051 default , on previous kernels I can normally log in in now for me new Kde Tumbleweed
I’m pretty new to Linux in general so if someone can help me with this ?

  1. Post the method you used to upgrade, or the steps you did and preferably any guide you’re following.
  2. Instead of logging in at the command prompt, did you wait a long time, possibly up to a full 120 seconds? Sometimes, especially on a new install there can be a very long delay at the login prompt and the graphical interface is still struggling to load. If this happens, should go away after a few reboots.


I used instructions from here for online upgrade ,I also done it as a root user with sudo -i : openSUSE:Migrate Leap to Tumbleweed - openSUSE Wiki
, as I say , upgrade worked partially , I can log in to previous kernels ,and yes , I waited quite a lot , probably more than 10 minutes , because I notice that I have to wait a bit on other kernels too ,I shell try it once again , with a bit longer wait time now , so Ill report back ,and thank you so much

Unfortunately no changes , just hangs out on that localhost login , I’m happy that I can still use it from older kernels ,also tried to set [Autologin] as well as systemctl start display-manager and from root pam-confing --add --systemd ,no luck

Download the latest Tumbleweed DVD and perform an offline upgrade,
You shouldn’t have to rollback first, should work no matter the state of your system.
I’ve only run into a problem doing the online upgrade a couple times over the years, and the DVD fixed both problems.


Did you try Alt-F3 or 2 or 4 instead of Ctrl-Alt-F7? Does this quickly show a login prompt?

No , I didn’t know about that , I will definitely try it now

Thanks , I will try that

Today I successfully upgraded again, but this time from the download distro,and everything works perfectly, just like you said, the only thing I got during the installation was an error in the libre office, that the checksum did not match, that’s all , thank you very much
Now I have perfectly happy KDE Tumbleweed ,you can mark as solved ,
Thank you all once more ,means a lot and I definitively learned my fair share with all this