After update, monitor goes into standby (res/refresh prob?)

Hi,

I’ve installed opensuse 11.1 successfully and everything was working fine. I then added the community repositories to YAST and was prompted to update a few things. Now, although the system boots up ok, whenever it tries to startx I just get a blank screen and my monitor goes into standby.

It looks like it’s a symptom of a bad refresh rate, screen resolution, bit depth etc issue. So I went into failsafe mode and checked /etc/X11/xorg.conf - sure enough this update has reset its contents.

I took a backup of xorg.conf straight after my good install, so I copied this back, but it didn’t fix the problem.

So I’m left with a system that I can’t startx on. My card is a Radeon 9700 (desktop, not mobility) and the monitor is a Compaq V75. The SuSE install correctly detects and configures these but, now that I’ve got this problem, even using sax2 I can’t repair the issue.

When I run sax2 in failsafe mode I first see a message saying “your current configuration will not be read in”. Then sax2 does something for 10 seconds (spinning cursor), then says “could not start configuration server”.

When I check /var/log/SaX.log I see:

(EE) fglrx(0): Invalid video BIOS signature!
<some other errors and unload info>
(EE) Screen(s) found, but none have a usable configuration.

I’ve posted my xorg.conf below - this is the good one that worked fine straight after install, but doesn’t work now.

All help appreciated, this is the second time opensuse 11.1 has done this to me and it’s getting extremely frustrating. I had to reinstall it the first time.

Thanks.

# /.../
# SaX generated X11 config file
# Created on: 2009-04-07T13:34:51+0100.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
  Option       "ZapWarning" "on"
EndSection

Section "Module"
  Load         "dri"
  Load         "dbe"
  Load         "freetype"
  Load         "extmod"
  Load         "glx"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "gb"
  Option       "XkbModel" "microsoftpro"
  Option       "XkbRules" "xfree86"
EndSection


Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "5"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "ImPS/2 Generic Wheel Mouse"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
  DisplaySize  306 230
  HorizSync    31-69
  Identifier   "Monitor[0]"
  ModelName    "V75 COLOR MONITOR"
  Option       "DPMS"
  Option       "PreferredMode" "1280x1024"
  VendorName   "COMPAQ"
  VertRefresh  50-100
  UseModes     "Modes[0]"
EndSection


Section "Modes"
  Identifier   "Modes[0]"
  Modeline 	"1280x1024" 117.45 1280 1368 1504 1728 1024 1025 1028 1062
  Modeline 	"1024x768" 94.39 1024 1088 1200 1376 768 769 772 807
  Modeline 	"1024x768" 83.73 1024 1080 1192 1360 768 769 772 803
  Modeline 	"1024x768" 74.25 1024 1080 1192 1360 768 769 772 799
  Modeline 	"1024x768" 64.11 1024 1080 1184 1344 768 769 772 795
  Modeline 	"800x600" 60.07 800 840 928 1056 600 601 604 632
  Modeline 	"800x600" 53.14 800 840 928 1056 600 601 604 629
  Modeline 	"800x600" 45.50 800 840 920 1040 600 601 604 625
  Modeline 	"800x600" 38.22 800 832 912 1024 600 601 604 622
EndSection


Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1280x1024" "1024x768" "800x600" 
    Virtual    3840 1200
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1280x1024" "1024x768" "800x600" 
    Virtual    3840 1200
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1280x1024" "1024x768" "800x600" 
    Virtual    3840 1200
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1280x1024" "1024x768" "800x600" 
    Virtual    3840 1200
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection


Section "Device"
  BoardName    "R300 NE"
  Driver       "radeon"
  Identifier   "Device[0]"
  Option       "monitor-VGA-0" "Monitor[0]"
  VendorName   "ATI"
EndSection



Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection


Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
EndSection

Hi,

I’ve not any experience with ATI cards, but I do remember there was an update to the kernel just recently (I think it happened this morning or last night). If you pulled that update in you’ll need to reinstall or recompile your ATI driver for the new kernel.

Ian

Thanks, but how do I do that?

I followed the instructions here:
Latest ATI Driver leads to a black screen - openSUSE Forums

but it’s still not working.

Have you tried doing all this

zypper in gcc make kernel-source compat-libstdc++ patch
wget https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/64bit/ati-driver-installer-8-12-x86.x86_64.run
sh ati-driver-installer-8-2-x86.x86_64.run
Ran Through All the Automatic Steps
aticonfig --initial -f
sax2 -r -m 0=fglrx
Saved all Settings
Logged Out
Restarted X
Logged back in
fglrxinfo

After you couldn’t start x?

Correct. I uninstalled the ati driver first, downloaded the latest driver from the ATi site (version 9.3 rather than 8.12, and the 32bit version rather than the 64bit version), then did all the steps in that post.

I still can’t startx, and the sax2 log still tells me it finds an invalid video BIOS.

Help, I’m desparate!

Okay, something new. I tried the driver specified in the post (the 8.12) rather than the latest from ATi.

Now when I run:

sh ati-driver-installer-8-2-x86.x86_64.run

The install fails part-way through, and the log file tells me to:

You must change your working directory to /lib/modules/fglrx and then call ./make_install.sh in order to install the built module

It also says “Precompiled kernel module version mismatched” at the very top, but I think that’s ok as it goes on to generate a new module.

So I cd into /lib/modules/fglrx and run make_install.sh, which then gives me:

- recreating module dependency list
- trying a sample load of the kernel modules
FATAL: Error inserting fglrx (<path to it>): Cannot allocate memory
failed.

Not sure what to do next!

Right, the problem is clearly this update that got pushed to my machine today.

I’m now stuck with the Invalid video BIOS signature error, and can’t startx no matter what.

Frustrating, this really shouldn’t happen.

So does anyone have any ideas how I can fix this?

My machine is totally unusable in this state and I can’t recover it, I may as well just wipe and reinstall Windows XP if it can’t be fixed. OpenSuSe really need to fix or QA these problems much better.

Right, I’ve solved it by going back to the oss radeon driver that’s hidden somewhere in suse 11.1. If anyone else has this problem, here’s what I did:

  1. Boot into failsafe mode
  2. cd /usr/share/ati
  3. sh ./fglrx-uninstall.sh
  4. Run yast2 (still from console)
  5. Go into the software management option
  6. Search for fglrx
  7. Uninstall the ati-fglrx package
  8. You might get a conflict warning about a related kernel package (-default or -pae etc). Tell yast to uninstall the conflict
  9. Reboot after
  10. It may work at this point!
  11. If not, console mode again
  12. cd /etc/X11
  13. vi xorg.conf
  14. In the “Device” section, delete the Option lines one by one (starting with AGP options).
  15. Delete the ATI repositories from Yast

Utterly, utterly broken.

So, does anyone know why I can’t use any of the ATI drivers with my Radeon 9700?