After upate KDE screen no longer fits in monitor screen

This morning I installed kde-5.39 and after that my kde desktop no longer fits in my monitor screen.

Is there a way to make the screen / desktop smaller so it fits again in the area that is shown by the monitor?

It seems a KDE issue, as I logged into for example gnome and icewm, and there the probem is not shown. The gnome and icewm desktop are nicely presented in the monitor.

At the moment, in KDE / plasma, I don’t see the KDE taskbar/ systembar, etc that is normally displayed at the bottom of the desktop. When I scroll with my mouse to the bottom of the desktop the desktop starts to move and the KDE taskbar / systembar / etc becomes visible.

Same with the left and right side and with the top. The desktop is moving all the time when I move my mouse. Everything working as expected.

I really hope that anyone have a idea what is causing this, and have a suggestion what can be altered to get a nice KDE desktop back.

Try deleting ~/.local/share/kscreen/ perhaps…

rm rf ~/.local/share/kscreen/

Then log out and back in again. Any different?

Does not help. The same file is created again.

The screen change happened when I pressed <right windows key><y>. At exact that moment.
Is there some magic window key combination, that causes this behavior?
Is there another key combination that can undo this?

I logged into another user with KDE, there the problem does not exist. Hence, it looks like setting …


See if this helps…

Panning and ZoomingNeed to get a closer look? The KDE Plasma Workspaces™ allow you to zoom in and out and move your entire desktop around, so you can zoom in even when the application you are using doesn’t support it.
|Meta+=|Zoom In|
|Meta+-|Zoom Out|
|Meta+0|Zoom Normal|
|Meta+Up|Pan Up|
|Meta+Down|Pan Down|
|Meta+Left|Pan left|
|Meta+Right|Pan Right|

[QUOTE=deano_ferrari;2843256]See if this helps…

That’s it indeed.

It was cause by meta+=

Meta+= Zoom In
Meta+- Zoom Out

I found it by moving away quite some files, put them back, login out and login in again and see what happens.

In the end it appeared that the ~/.config/kwinrc contained the culprit.

The setting InitialZoom was set to 1.2

After I set it back to “1” and logged in again, all was fine.

But indeed using the meta compose combination works as well.

This was really annoying, as it is just hard find how to correct it.


Thought so. Now you know about desktop zooming and panning. Glad you got it sorted. :wink:


Thanks for your support, but

I consider the current behavior a grave bug! As such I opened a bug report with kde

The intention is OK, the feature as well, but I needed my backup to restore it (as I did not know about the meta key cmbination, and could not find the information about it). That (needing a backup, after a inputting a key combination) should not be necessary at all.

I was able to restore it, but others might not. What should they do in that case???

I really hope the feature / bug report is solved and users will be warned when they activate these kind of key combinations.

The KDE bug is not honored. Not worth the effort :frowning:

To prevent this from happening again, I removed the meta key combination; (kde) system settings -> accelerator keys -> global keys -> system settings -> zoom in
Remove it from there.

Not honored by the KDE devs??? Could this be a packaging issue, delivering a wrong default? Then it should be reported at bugzilla,.opensuse,.org
Why? Because you’'re not the first one experiencing this phenomenon.

Hi Knurpht!

According the bugreport

While I understand your concern, I don’t think this is necessary. We have this shortcut by default for now almost 10 years and you are the first one to report this as a bug. To me this means that it is not worth the effort.

As stated I removed the key assignment in my environment, I don’t want this to happen to me again.

Ha Richard,

Key assignment doesn’t even work on my laptop … This on a 15 year old homedir :D.

Mine is not much younger :wink:

Do you’ve examples of users running into the same issue?

When it happens again, let the unfortunate user open again a KDE bug report, it’s the only way to get it improved.