After trying ICS, DNS resolution doesn't work..

I have two NICs in my mainboard so I thought I would try it out with a crossover cable to another computer. The connection went fine so I went forward and tried ICS(Internet Connection Sharing) and followed the guide on ICS - openSUSE
or at least the “IP Forwarding” section and using a DHCP server.
So I installed the dhcp server components and the Yast module. That worked on the other PC as I did automatic config on LAN. Then I did the ip forwarding and it was able to connect to google(by ip anyway…) so then I installed DNS server components and the Yast module for it. This is where I think things broke down on my desktop(the one running OpenSuse which now cannot resolve any nameservers) The other computer which I was trying ICS with still couldn’t resolve any names so I gave up on that and at that time is when I noticed that pages stopped loading. I tried then to put in manual DNS servers from my router into the network config. No luck. I tried uninstalling the DNS server components. No luck again. I have some forwarding services that run on this machine that requires DNS resolution so I do not want to reinstall with all the work that I have done on setting it up…

EDIT: I figured out that all I had to do was remove “bind” and the Yast module for the DNS server… Anyone know why it wanted to change everything’s ability to connect instead of simply forwarding things?

I got the DHCP server installed again, which apparently installs the Yast module for the DNS but not the “bind” part that the DNS server requires… I got the DHCP working on the other end but the other computer still can’t do address resolution. Also on a side note, I cannot do the Firewall Masquerading that the ICS guide talks about as the checkbox doesn’t have the ability to change… So I put both parts on demilitarized a test, nothing changed so that isn’t it…

So… How can I safely get this other computer to connect and do DNS resolution without hindering my ability to resolve DNSs?