after server upgrade from 13.1 to 13.2, old client cannot mount NFS share any more

Hello everybody!

Some days after release of OS 13.2, I updated a server from OS 13.1 to 13.2 without any (obvius) problems.

I have a client here, running a very old kernel (2.6.17). Since this is some kind of embedded system, it would be very complicated to upgrade the client-kernel.

Now, that client mounts a nfs-share from the server, which worked without any problems for years now. But since the server upgrade from OS 13.1 to 13.2, that mount fails with error “Protocol not supported”.

Has anybody heard of nfs problems with kernel 3.16.6 ?

There was a kernel update in the meantime and the server runs now 3.16.7-7-default. But the problem persists.

Check /etc/sysconfig/nfs on the server and make sure NFS3_SERVER_SUPPORT=“yes” enabled and NFS4_SUPPORT=“no” and systemctl restart nfsserver.

Check journalctl -l for nfs errors. Can you also post the logs from the client if you try to manually mount it with mount -v (for verbose output)

These are already set like you suggested

ok, 3 different tries:

root@asterina:/var/spool# mount -v -t nfs /var/spool/rincewind -o proto=tcp,nfsvers=3
mount: failed with nfs mount version 4, trying 3…
NFSv3 not supported!
mount: wrong fs type, bad option, bad superblock on,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

root@asterina:/var/spool# mount -v -t nfs /var/spool/rincewind -o proto=tcp,nfsvers=2
mount: failed with nfs mount version 4, trying 3…
mount: Protocol not supported

root@asterina:/var/spool# mount -v /var/spool/rincewind
mount: failed with nfs mount version 4, trying 3…
mount: Protocol not supported


The corresponding fstab entry on the client (which has worked for years now): /var/spool/rincewind nfs auto,intr,tcp,soft,sync,nfsvers=2


NFS server does not enable NFSv2 by default anymore. You would need to manually enable it, add “–nfs-version 2” to NFSD_OPTIONS in /etc/sysconfig/nfs and restart NFS server or simply use NFSv3 on client :slight_smile:

Many thanks !! Adding --nfs-version 2 to NFSD_OPTIONS saolved that problem.

Everything’s fine again. Thanks!

Hello to all NFS-Users with Suse 13.2 or even sooner
Hallo an alle NFS Nutzer mit Suse 13.2

if nfs server is setup with yast the resulting textfile
wenn der NFS-server mit yast aufgesetzt wird

/etc/exports is made up faulty !!
wird /etc/exports fehlerhaft

for each line insert a space right before the opening bracket for the options
bei jeder zeile muss eine Leerstelle vor der Klammer eingefügt werden

and you will be happy ever after with your nfs-clients
und man freut sich das die nfs-clients wieder etwas finden

Have Fun
Danach bestimmt

I have no idea what the above post is about because there is no issue with the built-in yast2/nfs-server configuration tool, it works just fine.