after install can't boo

Have Acer Aspire m1470.
Installed OpenSuse Leap 42.1 on sda

on install make partitions
efi boot -> /boot/efi ~ 1GB
swap -> swap 11 GB
ext4 -> / ~ 480+ GB

after reboot have message
“no boot disk has been detected or the disk has failed”
and can’t procced.

hope for help.


what is selected in the BIOS
legacy enabled?
kernel security enabled?
BIOS encrypted?

btw 1GB for the uefi loader looks very large (but should not be a problem, have not seen a size limit?)


Thanks for answer.

I can’t find nothing about legacy/uefi in BIOS ( i have notebook acer also, there are combobox to choose).
about kernel security , did you mean boot security, btw i can’t find not kernel not boot security in BIOS. i think to update it, but i don’t know how to do it from linux live (.
BIOS Encrypted i have not seen this option also, but didn’t search it, i do it later when i get home.

How old is the hardware. It may be a legacy BIOS and not a UEFI machine in which case you do not want or need a EFI boot partition you wnat to install grub2 into the MBR or generic code into the mbr and grub2 into the boot partition

Pretty much all systems have been UEFI since Windows 8.0 was released.

I also tried to install fedora using default partitions. result the same. When i buyed hardware there are windows 8 installed.

hardware is about 2-3 years old.

Are you trying to preserve your Windows and install a multi-boot, or did you wipe your disk clean so the Windows is gone and then try to install a Linux?


Then it is a EFI system almost certainly.

And Window no doubt is installed in EFI mode and so Linux should also be installed in EFI mode

I quick way to know if you booted the installer in EFI mode is to note if there are options along the bottom of the menu screen if there are it is booted in legacy if not it is booted in EFI

How to boot into EFI mode is hardware dependent only the documents for you machine will give you proper procedures. It is often F12 by may be other keys at the machines splash screen. Also the splash screen may list the options keys

The strange nominclature for the drive/partitions is confusing and what ever causes it may be the source of your problems. May check in the UEFI (BIOS) and see if RAID is turned on

hi loggonlink,

If there is nothing in the BIOS about “Legacy Support” then its assumed your machine in not UEFI enabled.
Hence when installing the OS make sure no to select a UEFI enabled install

The “Secure boot” is only relevant on UEFI enabled machines

Enabling “Encrypted BIOS” can be selected via yast-boot-loader (suggest this is ignored)

Something to try

If the e is pressed on the keyboard as soon as the machine starts up, and if grub is stalled,
the grub editor is invoked

if the grub script is now shown on the screen, scroll down to the line which looks something like,
resume=/dev/disk/by-uuid/<xxxxxxxxxxxxx hdd-id xxxxxxxxxxxxx> splash=silent quiet showopts

if you can get this far put a 3 at the end of the line so it looks like ,
resume=/dev/disk/by-uuid/<xxxxxxxxxxxxxx hdd-id xxxxxxxxxxxxx> splash=silent quiet showopts 3
(this change is not saved so will not survive a reboot)

and then press F10 to continue booting

if successful this will take you to a command prompt in a terminal at run level 3, user name and password will be expected

after logon run the following command to rebuild the grub start script

grub2-mkconfig -o /boot/grub2/grub.cfg

then try rebooting


i recreate particions where windows was -> wipe windows and try to clean install opensuse.

i can’t see grub menu on boot.

on boot i have not legacy note on boot and have some options in bios about EFI device. so i think you right about EFI. now try to google how to install opensuse on EFI.
on start i have only 3 options
F12 -> select boot device( not help if i specify implicit every option there)
del -> bios
ctrl + f -> Raid options
in raid options i have my hdd -> single so i suppose that RAID is not configured

Select F12 and then your install media, cd/dvd/… Then follow the onscreen directions as you did before,
only this time select the UEFI option,

I have not much time, decide to install win10.
Sorry for bothering.
How to close thread?