After getting nvidia drivers working on opensuse MicroOS, plasma desktop After shutdown or reboot comes login screen on the display?

on my older pc, I used openSUSE-MicroOS-DVD-x86_64-Snapshot20230728-Media with rufus to put it in USB drive for installing, when I got the nvidia drivers up and running, I noticed a problem while I turn off the pc, its showing a image of the login screen prompt at shutdown, I don’t know if any other settings, would effect this , I have gnome desktop with the same iso on my laptop, but the problem seems to only be effect the plasma kde desktop in MicroOS, also I used fedora 38 Silverblue and on laptop and fedora 38 kionite on desktop , seems to have less problems but its version does have an outdated firefox with it, I was able to make the nvidia drivers work on that linux without it doing that whole bug with the shutdown screen displaying the login screen, text prompt type. the instrustions for getting nvidia working is a little bit different on fedora but its almost the same type of process.

Micro OS with Nvidia drivers

info for this page, on reddit not correct, and I am not sure since user is not using current drivers in it, plus I don’t know if they needed secure boot info from opensuse page, but its not in there comments if it was needed for them.

www reddit com/r/openSUSE/comments/sks9ds/micro_os_with_nvidia_drivers edited this too, since it counts as a web page link, its a example, since some of the info on it is not correct for my desktop or laptop nvidia drivers mainly used the info from openSUSE Wiki, and on fedora 38 I used their website page on Howto/NVIDIA - RPM Fusion

SDB:NVIDIA drivers - openSUSE Wiki

Thats what I did:

`sudo zypper addrepo --refresh download nvidia com opensuse tumbleweed NVIDIA – I edited out this line since it counts as a webpage, and I am a new user here.

sudo tukit --continue execute bash

zypper ref && zypper dup
I changed the G05 to G06 for my nvidia rtx 2070 3D card.

zypper install x11-video-nvidiaG06 nvidia-glG06 nvidia-computeG06 nvidia-gfxG06-kmp-default

and/or with this
transactional-update -i pkg in nvidia-driver-G06-kmp-default nvidia-video-G06 nvidia-gl-G06 nvidia-compute-G06

I did use this below,
mokutil --import .der --root-pw
changed it to match the file in that director, this step is different with Fedora 38 as there is no file there, and you have to create one with the github settings infomation from that page , that link to it is in the docs from its page, otherwise the nvidia drivers would not work on fedora 38 silverblue or kde version.

sudo mokutil --disable-validation


sudo reboot

and below was how I got the drivers working on fedora’s inmutable versions with OSTree

Howto/NVIDIA - RPM Fusion

GitHub - CheariX/silverblue-akmods-keys: Fedora Silverblue with SecureBoot enabled and working akmods such as akmod-nvidia or akmod-VirtualBoxgithub com CheariX silverblue-akmods-keys

this Github info is needed I think for getting it working under fedora 38 again that problem with the shutdown screen seems to only be affecting my old gigabyte desktop on opensuse MicroOS.

my old pc running linux is G1.Assassin 2 (rev. 1.0) and I have an intel i7 processor in it, with secure boot on, and no TPM device in it, I dont know if it ever had one in the box it was shipped in,

[G1.Assassin 2 (rev. 1.0) Overview | Motherboard - GIGABYTE Global](www gigabyte com/Motherboard/G1Assassin-2-rev-10#ov)

and laptop is ASUS Republic of Gamer laptop, and it did have windows 10 on it, but I put linux on it, the only problem I noticed on laptop there is a breef screen with some text about it not being able to detect all its blutooth hardware features, I will have to snap a tablet photo of that at some point to see if there’s any driver fix or just to report the bug in the linux kernel startup on it, otherwise its able to run linux and that laptop has an nvidia rtx 1070 3D card in it, that laptop can run Windows 11 but its login is slow for that OS, and the processor in that laptop is not fully supported by Windows 11.