After clean install windows 10 machine can't see SAMBA

I recently updated to Tumbleweed (clean install) leaving the home directory intact and checked on smb.conf and it appears to be the same. Good. However the Windows 10 machine can’t see the Linux machine’s SAMBA. I can ping the Linux machine from Windows 10. On the Linux machine and using the file manager everything seems fine. Any ideas?

Ports open in the firewall? Maybe the changes to version 4.4.2 of samba?

The client is at 3.1.16-1.2 and the server is at 3.1.14-1.2 (3.1.15-1.1).

As for the firewall I had it disabled for trying out.

You may need to do

sudo smbpasswd -a your_username

to add the samba user.

Did that. Still can’t see the Linux machine from the Windows 10.

How are you trying to see the Linux machine?
If I use Windows 10 File Explorer’s Network item, it lists only the local machine, not any Linux or Win10 machines in the Workgroup. If I put \192.168.1.Linux_machine_IPaddress_last3numbers in the address bar, it does correctly access the Linux box.