Adjust volume increment


Distro: openSUSE Leap 15
DE: Xfce
Volume control: pulseaudio

In distros past, I’ve been able to change the volume increment from the default 5% down to 2% or 3% in Xfce’s “Settings Editor” (the volume hot key was listed with “amixer ~~~ 5%” as the value). Changing the value changed the increments.

The Xfce Settings Editor is not showing the hot keys in this fresh install, so I tried to manually add the hot key (“XF86AudioLowerVolume”) as a custom configuration under “xfce4-keyboard-shortcuts”, but I can’t seem to find the right argument configuration that will affect volume increments.

Has anyone run into this same issue on this or previous versions of openSUSE with Xfce?

Any ideas on what exactly I need to input as the value?

Or, is there any other config file in which “volume step” is adjustable?

Thank you in advance!

NOTE: I did find another thread,, which references pretty much the same issue, except it seems that answers were directed toward Tumbleweed running KDE.*

To further clarify, I’ve added the following to my Settings Editor (“Customize settings stored by Xfconf”), running “alsactl init” afterwards, with no affect to the volume increment:

XF86AudioLowerVolume       String       amixer set Master 2%-
XF86AudioRaiseVolume       String       amixer set Master 2%+

Okay, it looks like my input did actually resolve the problem: just had to restart the machine for it to take effect (I hadn’t restarted yet as I was at work).

Huzzah for that!

Thats good news. Thanks for sharing your solution.