Added New hard disk and opensuse doesn't boot

I’ve recently added a new hard disk and due to mother board controllers this new hard disk is known as sda.Before that my boot partition was /dev/sda3 and know this changed to sdb3.Whenever grub menu appears and I choose opensuse,it can’t find /dev/sda3 .It seems that I should edit menu.lst or change boot loader parameter.something like root (hd1,2).But I don’t how I can do this with opensuse boot loader.Though I could do this with CentOS easily.

Please guide me.
thank you

Normally, if you never edited menu.lst yourself, it should not contain device names such as sda or sdb. It is possible that sda3 changed to sdb3 but it should not prevent you from booting - although it can be very confusing. But if the new drive you added became the first BIOS drive, then hd0 will become hd1 and it won’t boot. So what do you see exactly when you start your computer? How are the hds plugged in (which sata port)? Are you mixing IDE and SATA hard disks? And what is the boot order in BIOS setup?

I know that hard disk display order in grub is different as we see in fdisk command.
previously it was hd0 and root parameter in menu.lst was hd0,0.
In addition,All hard disks are SATA.and as I mentioned earlier new hard disk become the first hard disk.It means that new hard disk is known as hd0.and previous hard disk became hd1.
When my computer starts,grub menu appears,then I choose Opensuse and hit the enter.Then it shows an error,something like this :
/dev/sda3 doesn’t appear,try again?(yes/no)

You need to look at the entry in /boot/grub

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel
up 1 day 4:56, 4 users, load average: 0.22, 0.16, 0.13
GPU GeForce 8600 GTS Silent - Driver Version: 280.13

No. You just said that your new hard disk is known as sda by Linux - which doesn’t necessarely mean that it is the first BIOS drive, even if that’s the case here. So, do you want this hard disk to be the first one or is it just something you don’t know how to change? If you switch the BIOS order, it will solve your problem. If not, you’ll have to tell us what you intend to do with this hard disk - which is probably going to boot something at the first place(?). If you want openSUSE to be on the second hard disk, you’ll have to edit menu.lst as you suspected and reinstall Grub.

I just want to know how I can boot opensuse without change anything in BIOS or doing any kind of changes in hard disk order.
I know I should edit menu.lst.but how I can do this?

When I used CentOS , I could press “e” and change boot parameters,then OS loaded and I could edit menu.lst,so I didn’t have any problem on next boot.But this is not available since I use openSuSE11.4 .I want to learn it.

Just press the esc key when at the grub menu to edit, else open a terminal as root user and modify /boot/grub/menu.lst

I don’t think that would make it permanent. You would need to do as the others have suggested and modify menu.lst. You could always try the ‘F10’ option at boot (BIOS screen) and select which drive to boot off. Hopefully it will make the drive sda.