Activate Kernel Mode Setting

Hello there,

due to issues with the Intel graphics driver I eventually updated my system as the only way to really cope with the driver issues. I now use the 2.8 driver and a 2.6.29 kernel (that supports the 2.8 driver).

As you might know, in 2.8 UXA remains as the only acceleration mode, and from there it is only a small step toward kernel mode setting, which I’d love to give a try.

Here is where the problem arises though: for the life of me I can’t find any documentation of anyone having tried this with openSUSE.
Kernel mode setting has to be enabled at boot so that the i915 driver is loaded with the option “modeset=1”. Now since I’m not very experienced (I just spent a lot of time researching this in order to get my graphics fixed), I don’t know how that would work.
Through Google I found instructions for other distros:
-Debian-based: you add to /etc/modules

i915 modeset=1



must be set as one of the kernel command line arguments through GRUB on boot or modifying /boot/grub/grub.conf.

Now is this something distro-specific? Or is either way working? And which way is the best?

Btw, I use 11.1, the BuildService X11-Repo, and kernel with an Intel 945 GM chipset.

Any advice is appreciated!

Let me maybe rephrase the question in an easier way.

If I were to add a certain parameter to my graphics driver at startup, how would I have to do that?

Thank you all for your help!

Due to the amazing response I’m used to receiving in this forum, I ended up just trying it out. (The reason I had not done that before was that I was afraid it would break something that I’d have to fix.) Just for documentational reasons I’m posting the outcome here.

Kernel Mode Setting, or Kernel-based Mode Setting, can be activated in openSUSE - if you have at least kernel 2.6.29 - by adding


as a boot parameter to /boot/grub/menu.lst . A sample of where to add this might look like this:

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.1 -
    root (hd0,1)
    kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-WDC_WD1600BEVS-75RST0_WD-WXCY07142285-part2 resume=/dev/disk/by-id/ata-WDC_WD1600BEVS-75RST0_WD-WXCY07142285-part1 splash=silent showopts vga=0x317 i915.modeset=1
    initrd /boot/initrd-

This information, along with a lot of other interesting stuff about the Intel driver, comes from the Gentoo wiki.

The outcome, however, was rather disappointing for me on X-server 1.6.2, Intel graphics driver 2.8 and kernel - pretty much all I noticed was a lower quality of the KDE splash screen full of glitches.
I’m thinking that this was probably due to the fact that 2.6.29 was the first kernel with the KMS feature, and it was still experimental.

I’m glad you posted this. I was trying to do the same thing.

But when I tried to compile the new intel video driver, it gave me an error saying that I was using xorg-server 1.5 and I needed 1.6.

How did you upgrade to 1.6?