ACPI: failed to connect to the ACPI event daemon

I have a fresh install (onto newly formatted drives) of openSUSE 12.3, which went very smoothly, but when I switched over to the nVidia drivers (310.32) the desktop would just be a black screen with the cursor (still movable) after logging in.

The only thing of concern in Xorg.0.log is

     4.589] (II) LoadModule: "glamoregl"
     4.591] (II) Loading /usr/lib64/xorg/modules/
     4.614] (EE) Failed to load /usr/lib64/xorg/modules/ /usr/lib64/xorg/modules/ undefined symbol: _glapi_tls_Context
     4.614] (II) UnloadModule: "glamoregl"
     4.614] (II) Unloading glamoregl
     4.614] (EE) Failed to load module "glamoregl" (loader failed, 7)

Do I even need this if I’m using the nVidia drivers? My main issue is this one:

     5.213] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
     5.213] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
     5.213] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
     5.213] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
     5.213] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
     5.213] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
     5.213] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
     5.213] (II) NVIDIA(0):     Config Options in the README.

When I compare the message time to equivalents in /var/log/messages, I came across this:

2013-03-19T18:21:25.647890+00:00 camsWorkstation kernel:     5.037868] sd 6:0:0:0: [sdc] Attached SCSI removable disk
2013-03-19T18:21:25.779969+00:00 camsWorkstation xdm[763]: Starting service gdm..done
2013-03-19T18:21:25.780258+00:00 camsWorkstation systemd[1]: Started LSB: X Display Manager.
2013-03-19T18:21:25.780475+00:00 camsWorkstation systemd[1]: Starting Graphical Interface.
2013-03-19T18:21:25.793189+00:00 camsWorkstation systemd[1]: Reached target Graphical Interface.
2013-03-19T18:21:25.793310+00:00 camsWorkstation systemd[1]: Starting Update UTMP about System Runlevel Changes...
2013-03-19T18:21:25.793505+00:00 camsWorkstation systemd[1]: Starting Stop Read-Ahead Data Collection 10s After Completed Startup.
2013-03-19T18:21:25.793640+00:00 camsWorkstation systemd[1]: Started Stop Read-Ahead Data Collection 10s After Completed Startup.
2013-03-19T18:21:25.799004+00:00 camsWorkstation systemd[1]: Started Update UTMP about System Runlevel Changes.
2013-03-19T18:21:25.799220+00:00 camsWorkstation systemd[1]: Startup finished in 3s 471ms 629us (kernel) + 1s 604ms 470us (userspace) = 5s 76ms 99us.
2013-03-19T18:21:25.875887+00:00 camsWorkstation kernel:     5.265281] NVRM: GPU at 0000:01:00: GPU-cb1771a9-dff1-1bf7-d48f-e8910dc4f07c
2013-03-19T18:21:26.062988+00:00 camsWorkstation gdm-simple-slave[822]: WARNING: Failed to give slave programs access to the display. Trying to proceed.

I haven’t had any nVidia issues since the 11.x days, but I’ve noticed that a few people have had different issues with 12.3 and nVidia drivers - though I haven’t found anyone with ACPI warnings in their Xorg.0.log. Does anyone have any suggestions?

After seeing this post, I tried logging in myself and it my hardware accelerated desktop appeared. And as noted in the thread, adding myself to the “video” group solved the problem.

So why exactly are users not automatically added to the group that is required to see the desktop!?