ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCIO.SAT0.S

Hi everyone!

I installed Leap 15.2 some weeks ago. It is in dual-boot with Windows 10. Sometimes during boot phase I have a critical issue: I receive a flood in dmesg like these:

ACPI BIOS Error (bug): Could not resolve symbol \_SB.PCIO.SAT0.SPT0._GTF.DSSP], AE_NOT_FOUND (20190703/psparse-330)
ACPI BIOS Error (bug): Could not resolve symbol \_SB.PCIO.SAT0.SPT1._GTF.DSSP], AE_NOT_FOUND (20190703/psparse-330)
ACPI BIOS Error (bug): Could not resolve symbol \_SB.PCIO.SAT0.SPT4._GTF.DSSP], AE_NOT_FOUND (20190703/psparse-330)
ACPI Error: Aborting method \_SB.PCIO.SAT0.SPT0._GTF due to previous error (AE_NOT_FOUND) (20190703/psparse-531)
ACPI Error: Aborting method \_SB.PCIO.SAT0.SPT1._GTF due to previous error (AE_NOT_FOUND) (20190703/psparse-531)
ACPI Error: Aborting method \_SB.PCIO.SAT0.SPT4._GTF due to previous error (AE_NOT_FOUND) (20190703/psparse-531)

In particular, If I turn on the PC directly into Leap, in doesn’t boot, remaining in console with these messages above; if instead I first run Windows 10, then I reboot and choose Leap in GRUB, it doesn’t happen and Leap is loaded.

Any suggestions?

My hardware is: ASUS P8P67, AMD Radeon HD 7950 Sapphire Dual-X, 16GB RAM, HD 1TB Western DIgital Cavial Blue (where I have the partition for Leap), SSD Samsung 830 (where I have Windows 10).

Thanks!

You have provided less than adequate information to work with, e.g. Asus website shows several models of P8P67.

What does “directly into Leap” mean? Leap from a Grub menu? Leap via selecting the HDD from the BBS menu?

How do you choose to boot Windows?

What do “remaining in console with these messages” and “doesn’t boot” mean? Does a login prompt not appear at the end of those messages? From that screen, after it has stopped changing, does Ctrl-Alt-F3 change to another black screen with a login prompt?

Do you have Windows “fast boot” disabled?

Are both HDD and SSD formatted using GPT partitioning? Do you have an ESP partition on each disk?

To answer the motherboard and partitioning questions, and more, please paste here input and output from a successful Leap boot, using code tags, from:

inxi -GSa
inxi -CIMpr

Hi

thank you for your reply! I will try to answer to all your points. This is the situation of my PC:

  • I have 2 hard drives:
  1. /dev/sdb1: it is an SSD dedicated to Windows 10
  2. /dev/sda1: it is an HDwhere I store my files. It has a dedicated partition for Linux (about 30GB)

I installed GRUB on MBR of the /dev/sda. On boot, my PC load MBR from HD and I can choose Leap or Windows.

What I mean with “directly into Leap” is this. Suppose to have the PC turned off. If I turn on it, I arrive to GRUB. Here, if I choose Leap, after a while it remain in blank scrive with just console (see picture). Instead, if I first on GRUB choose Windows 10, then I reboot and choose Leap, it works.

https://paste.opensuse.org/99085222

I think I have Windows fast boot disable, need to double check.

These are the outputs of your commands:

inxi -GSa 
**System:    Host:** localhost **Kernel:** 5.3.18-lp152.60-default x86_64 **bits:** 64 **compiler:** gcc **v:** 7.5.0  
           **parameters:** BOOT_IMAGE=/boot/vmlinuz-5.3.18-lp152.60-default root=UUID=8fc3660d-8350-4a24-8d76-5bdf32bece8b  
           splash=silent quiet mitigations=auto  
           **Desktop:** KDE Plasma 5.18.6 **tk:** Qt 5.12.7 **wm:** kwin_x11 **dm:** SDDM **Distro:** openSUSE Leap 15.2  
**Graphics:  Device-1:** Advanced Micro Devices [AMD/ATI] Tahiti PRO [Radeon HD 7950/8950 OEM / R9 280] **vendor:** PC Partner Limited  
           **driver:** radeon **v:** kernel **bus ID:** 01:00.0 **chip ID:** 1002:679a  
           **Display:** x11 **server:** X.Org 1.20.3 **compositor:** kwin_x11 **driver:** ati,radeon **unloaded:** fbdev,modesetting,vesa  
           **display ID:** :0 **screens:** 1  
           **Screen-1:** 0 **s-res:** 1920x1080 **s-dpi:** 96 **s-size:** 508x285mm (20.0x11.2") **s-diag:** 582mm (22.9")  
           **Monitor-1:** HDMI-0 **res:** 1920x1080 **hz:** 60 **dpi:** 96 **size:** 509x286mm (20.0x11.3") **diag:** 584mm (23")  
           **OpenGL:****renderer:** AMD TAHITI (DRM 2.50.0 5.3.18-lp152.60-default LLVM 9.0.1) **v:** 4.5 Mesa 19.3.4 **direct render:** Yes 
inxi -CIMpr 
**Machine:   Type:** Desktop **Mobo:** ASUSTeK **model:** P8P67 EVO **v:** Rev 1.xx **serial:** <superuser/root required>  
           **BIOS:** American Megatrends **v:** 3207 **date:** 04/13/2012  
**CPU:       Topology:** Quad Core **model:** Intel Core i7-2600K **bits:** 64 **type:** MT MCP **L2 cache:** 8192 KiB  
           **Speed:** 1687 MHz **min/max:** 1600/5900 MHz **Core speeds (MHz):****1:** 1600 **2:** 1696 **3:** 3798 **4:** 3499 **5:** 2861 **6:** 1740 **7:** 2437  
           **8:** 2244  
**Partition: ID-1:** / **size:** 30.26 GiB **used:** 13.05 GiB (43.1%) **fs:** btrfs **dev:** /dev/sda2  
           **ID-2:** /Dati **size:** 901.25 GiB **used:** 473.52 GiB (52.5%) **fs:** ntfs **dev:** /dev/sda1  
           **ID-3:** /Windows **size:** 237.95 GiB **used:** 147.57 GiB (62.0%) **fs:** ntfs **dev:** /dev/sdb1  
           **ID-4:** /boot/grub2/i386-pc **size:** 30.26 GiB **used:** 13.05 GiB (43.1%) **fs:** btrfs **dev:** /dev/sda2  
           **ID-5:** /boot/grub2/x86_64-efi **size:** 30.26 GiB **used:** 13.05 GiB (43.1%) **fs:** btrfs **dev:** /dev/sda2  
           **ID-6:** /home **size:** 30.26 GiB **used:** 13.05 GiB (43.1%) **fs:** btrfs **dev:** /dev/sda2  
           **ID-7:** /opt **size:** 30.26 GiB **used:** 13.05 GiB (43.1%) **fs:** btrfs **dev:** /dev/sda2  
           **ID-8:** /root **size:** 30.26 GiB **used:** 13.05 GiB (43.1%) **fs:** btrfs **dev:** /dev/sda2  
           **ID-9:** /snap/core18/1944 **raw size:** 55.4 MiB **size:** <superuser/root required> **used:** <superuser/root required>  
           **fs:** squashfs **dev:** /dev/loop1  
           **ID-10:** /snap/gnome-3-34-1804/66 **raw size:** 219.0 MiB **size:** <superuser/root required> **used:** <superuser/root required>  
           **fs:** squashfs **dev:** /dev/loop0  
           **ID-11:** /snap/gtk-common-themes/1514 **raw size:** 64.8 MiB **size:** <superuser/root required>  
           **used:** <superuser/root required> **fs:** squashfs **dev:** /dev/loop4  
           **ID-12:** /snap/snap-store/518 **raw size:** 51.0 MiB **size:** <superuser/root required> **used:** <superuser/root required>  
           **fs:** squashfs **dev:** /dev/loop2  
           **ID-13:** /snap/snapd/10707 **raw size:** 31.1 MiB **size:** <superuser/root required> **used:** <superuser/root required>  
           **fs:** squashfs **dev:** /dev/loop3  
           **ID-14:** /srv **size:** 30.26 GiB **used:** 13.05 GiB (43.1%) **fs:** btrfs **dev:** /dev/sda2  
           **ID-15:** /tmp **size:** 30.26 GiB **used:** 13.05 GiB (43.1%) **fs:** btrfs **dev:** /dev/sda2  
           **ID-16:** /usr/local **size:** 30.26 GiB **used:** 13.05 GiB (43.1%) **fs:** btrfs **dev:** /dev/sda2  
           **ID-17:** /var **size:** 30.26 GiB **used:** 13.05 GiB (43.1%) **fs:** btrfs **dev:** /dev/sda2  
**Repos:     Active zypp repos in:** /etc/zypp/repos.d/mozilla.repo  
           **1: **mozilla ~ http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_15.2/ 
           **No active zypp repos in:** /etc/zypp/repos.d/openSUSE-Leap-15.2-1.repo  
           **Active zypp repos in:** /etc/zypp/repos.d/packman.repo  
           **1: **packman ~ https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_$releasever/ 
           **No active zypp repos in:** /etc/zypp/repos.d/repo-debug-non-oss.repo  
           **No active zypp repos in:** /etc/zypp/repos.d/repo-debug-update-non-oss.repo  
           **No active zypp repos in:** /etc/zypp/repos.d/repo-debug-update.repo  
           **No active zypp repos in:** /etc/zypp/repos.d/repo-debug.repo  
           **Active zypp repos in:** /etc/zypp/repos.d/repo-non-oss.repo  
           **1: **repo-non-oss ~ http://download.opensuse.org/distribution/leap/$releasever/repo/non-oss/ 
           **Active zypp repos in:** /etc/zypp/repos.d/repo-oss.repo  
           **1: **repo-oss ~ http://download.opensuse.org/distribution/leap/$releasever/repo/oss/ 
           **No active zypp repos in:** /etc/zypp/repos.d/repo-source-non-oss.repo  
           **No active zypp repos in:** /etc/zypp/repos.d/repo-source.repo  
           **Active zypp repos in:** /etc/zypp/repos.d/repo-update-non-oss.repo  
           **1: **repo-update-non-oss ~ http://download.opensuse.org/update/leap/$releasever/non-oss/ 
           **Active zypp repos in:** /etc/zypp/repos.d/repo-update.repo  
           **1: **repo-update ~ http://download.opensuse.org/update/leap/$releasever/oss 
           **Active zypp repos in:** /etc/zypp/repos.d/snappy.repo  
           **1: **snappy ~ https://download.opensuse.org/repositories/system:/snappy/openSUSE_Leap_15.2 
**Info:      Processes:** 243 **Uptime:** N/A **Memory:** 15.60 GiB **used:** 1.75 GiB (11.2%) **Shell:** bash **inxi:** 3.1.00 

Thanks

Hi
Is the system BIOS the latest? Could try some acpi boot options (YaST -> Bootloader -> Kernel Parameters) and add;


acpi=force apm=power_off

Worth a read here: https://www.kernel.org/doc/Documentation/admin-guide/kernel-parameters.txt

Because you wrote “Sometimes during boot phase”, I am suspicious you do not have Windows fast boot disabled. Please paste here using code tags the content of file /etc/fstab.

I cannot parse this:

in blank scrive
It’s still ambiguous what “doesn’t boot” means.

Where is the “picture”?

You may be able to enjoy better graphics behavior by editing Grub to contain these additional parameters: radeon.si_support=0 amdgpu.si_support=1. To test whether this is, you can strike the E key at the Grub menu and add them to the end of the (probably wrapped) line that begins with linu. If this helps, they can be added to the GRUB_CMDLINE_LINUX_DEFAULT= line in /etc/default/grub. On next kernel update they will become part of /boot/grub2/grub.cfg. You can apply them immediately by running sudo grub2-mkconfig -o /boot/grub2/grub.cfg and rebooting. This should result in X using the amdgpu DDX driver instead of ATI/Radeon. If it doesn’t, check to be sure xf86-video-amdgpu is installed. It is a standard part of most installations to systems with non-ancient AMD graphics.

OT] Your Leap partition on sda2 is formatted BTRFS and only 30GB. To use such a small partition with BTRFS will take considerable care on your part to avoid having the filesystem fill to capacity as time goes on. You’ll need to configure snapshotting to not save an excessive number before discarding older ones, and ensure personal files of any size are kept on your sda1 data filesystem. You would almost certainly be better off repartitioning and reinstalling to give Leap considerably more space than 30GB. Alternatively, it would probably be easier to maintain adequate freespace on the existing 30GB partition by reinstalling Leap using EXT4 instead of BTRFS.

Long term you should consider using UEFI booting and GPT partitioning on your Haswell Asus, for both Windows and Linux. This is the preferred way to use Windows 10. One reason is that it makes less likely that Windows would do something to cause you to be unable to boot Linux at all. UEFI is considerably more sophisticated than legacy MBR/CSM booting. Because of the immediate problem, it might be best to do this now.

Ok thanks, I am going to add that row in kernel parameters, I’ll let you know.

I double checked the WIndows Fast Startup option and actually it was enabled. I unchecked that field.

Here my fstab:


UUID=8fc3660d-8350-4a24-8d76-5bdf32bece8b  /                       btrfs  defaults                      0  0 
UUID=8fc3660d-8350-4a24-8d76-5bdf32bece8b  /var                    btrfs  subvol=/@/var                 0  0 
UUID=8fc3660d-8350-4a24-8d76-5bdf32bece8b  /usr/local              btrfs  subvol=/@/usr/local           0  0 
UUID=8fc3660d-8350-4a24-8d76-5bdf32bece8b  /tmp                    btrfs  subvol=/@/tmp                 0  0 
UUID=8fc3660d-8350-4a24-8d76-5bdf32bece8b  /srv                    btrfs  subvol=/@/srv                 0  0 
UUID=8fc3660d-8350-4a24-8d76-5bdf32bece8b  /root                   btrfs  subvol=/@/root                0  0 
UUID=8fc3660d-8350-4a24-8d76-5bdf32bece8b  /opt                    btrfs  subvol=/@/opt                 0  0 
UUID=8fc3660d-8350-4a24-8d76-5bdf32bece8b  /home                   btrfs  subvol=/@/home                0  0 
UUID=8fc3660d-8350-4a24-8d76-5bdf32bece8b  /boot/grub2/x86_64-efi  btrfs  subvol=/@/boot/grub2/x86_64-efi  0  0 
UUID=8fc3660d-8350-4a24-8d76-5bdf32bece8b  /boot/grub2/i386-pc     btrfs  subvol=/@/boot/grub2/i386-pc  0  0 
/dev/sdb1                                  /Windows                ntfs-3g user,users,gid=users,umask=0002  0 0 
/dev/sda1                                  /Dati                   ntfs-3g user,users,gid=users,umask=0002  0 0

Sorry for the picture, I don’t know why but the IMG tag didn’t work. Here the picture:

https://susepaste.org/26472365

I put the amdgpu parameter - I thought it was already enabled having xf86-video-amdgpu installed.

For the UEFI boot, should I choose UEFI USB PEN in boot priority when I put the USB pen with OpenSUSE for its installation?

Thanks

It’s possible now that you’ve done that that the problem is gone. Check it first before doing what follows.

Change this:

/dev/sdb1	/Windows	ntfs-3g user,users,gid=users,umask=0002	0 0

to this:

/dev/sdb1	/Windows	ntfs-3g user,users,gid=users,umask=0002,nofail	0 0

If it doesn’t help, or only partitially helps, change this:

/dev/sda1	/Dati	ntfs-3g user,users,gid=users,umask=0002	0 0

to this:

/dev/sda1	/Dati	ntfs-3g	user,users,gid=users,umask=0002,nofail	0 0

I put the amdgpu parameter - I thought it was already enabled having xf86-video-amdgpu installed.
For newer AMD GPUs that would be enough. It isn’t for early ones like yours.

For the UEFI boot, should I choose UEFI USB PEN in boot priority when I put the USB pen with OpenSUSE for its installation?
Very likely yes. UEFI BIOS have so much variation it’s hard to be sure without a direct look. Likely it would be easier to, before POST completes, strike the F8 key, then choose from the BBS menu that results when POST completes.

BIOS update is recommended:

The BIOS was updated and that resolved the crazy auto-reboot issue and made the system usable.

Try to set SATA controllers into AHCI mode.
Or disable builtin SATA controllers and use add-in card with those.

https://bugzilla.kernel.org/show_bug.cgi?id=198369#c3

Please confirm the error messages are gone if you boot with kernel parameter libata.noacpi.

http://forums.debian.net/viewtopic.php?p=722235#p722235

The problem is, that Linux kernel devs do know the ACPI specifications, unlike some laptops manufacturers - and unfortunately this is not a joke

Code: Select all
ACPI BIOS Error (bug): Could not resolve _SB.PCI0.SAT0.SPT4._GTF.DSSP], AE_NOT_FOUND (20180810/psargs-330)

The error message is clear: Your laptop has a bug in the ACPI BIOS module.
The kernel code contains a lot of workarounds for ACPI bugs, but apparently not for Your BIOS version.