acer poweroff issue

Hello,

i have installed clean install of OpenSUSE 12.3 on my acer timelineX 4820TG laptop and i can’t turn it off other way then holding power off button. Restart and hibernation is also not working and when i suspend laptop it completely freezes on wake up. Before 12.3 i had 11.1 version of OpenSUSE and everything was working. But my new installation is on SSD, don’t know if that can cause the problem. I tried to use systemctl poweroff command but it worked only once. I don’t know what to do. Where do i have to look into logs to find what causes the problem?

thanks for help

Does ctrl+alt+del trigger a shutdown? Also, have you tried a few command line options for shutdown like “sudo /sbin/shutdown -h now”? You could also try “sudo /sbin/init 6”.

Try the following:

su -c systemctl isolate runlevel6.target

or

su -c halt -p

I tried all of the suggested commands and nothing works, all ends with OK ] Started Update UTMP about System Shutdown. And that’s all. :frowning:

On 2013-08-15 12:16, fada3 wrote:
> Hello,
>
> i have installed clean install of OpenSUSE 12.3 on my acer timelineX
> 4820TG laptop and i can’t turn it off other way then holding power off
> button.

Try this.

Log out of the desktop.

Go to text mode, by typing “ctrl-alt-F1” (any key from F1 to F6 will do).

Log in as root (text mode).

Type:


halt -p

And see what happens. If you get a graphical screen, press ESC to
disable it, quick.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

On 2013-08-27 13:56, fada3 wrote:

> Now i found something interesting. When i log off and switch to console
> mode command do not work, it only shows
> Code:
> --------------------
> OK ] Started Show Plymouth Power Off Screen
> --------------------

I would, at this point, remove plymouth. I don’t know if it is to be
blamed in your case, but I have had several issues with it, so I always
remove it. In my case, it works better.


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

After removing plymouth it has been stucking on

 OK ] Started Update UTMP about System Shutdown

But after two days suddenly everything worked, i was thinking some update fixed it. However now it is not working again :frowning: , it displays console login, but computer is not responding.
I am starting to be desperate…
Thank you guys for helping

On 2013-09-09 18:29, fada3 wrote:

> After removing plymouth it has been stucking on
> Code:
> --------------------
> OK ] Started Update UTMP about System Shutdown
> --------------------

I guess that UTMP is working (because it says “OK”), and getting stuck
on the next one, which is not printed.

> But after two days suddenly everything worked, i was thinking some
> update fixed it. However now it is not working again :frowning: , it displays
> console login, but computer is not responding.
> I am starting to be desperate…
> Thank you guys for helping

Ugh :frowning:

I can only suggest you try the factory version, 13.1, to find out if it
has the same problem. If it has, report in bugzilla and post in factory
mail list.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

Hello,

I have a similiar problem with a new Acer E1-572 laptop.
When I want to switch off the laptop, it seems to shut down correctly. But only powering off seems not to work. This I always have to finish by pressing the power button for more than 5s.

Is it possible that this is the same issue as solved in https://bbs.archlinux.org/viewtopic.php?id=172860 ?

If yes, who would be able to patch the kernel as I am normally using a pre-compiled kernel?

Thanks,
Siegmund

Looks like a patch was submitted to kernel 3.13 rc7 for an Acer Aspire V5-573G with a similar issue.
See https://bugzilla.kernel.org/show_bug.cgi?id=63861

You can try updating the kernel by adding the final 3.13 repository (kernel-desktop-3.13.0-4.1.gd9213ce.x86_64.rpm):

http://download.opensuse.org/repositories/Kernel:/HEAD/standard/

Thanks for your hint. Unfortuately I cannot start the kernel (“invalid signature”) - did I make something wrong?
Siegmund

The repository’s kernel has been updated. When starting up - at the Grub Boot Menu. Select Advanced and select an earlier kernel to boot to your desktop.
Use Yast to remove the older 3.13 rc7 kernel. Then install the newer and final 3.13 kernel. Make sure you refresh the repository before installing the newer kernel.

Reinstall your Radeon drivers.

:slight_smile: The kernel update came automatically by suse updater:
Source Timestamp: 2014-01-30 18:23:45 +0100 GIT Revision: 62e9557f1d156f56f847422c72bede5c198aafb7 GIT Branch: master

:frowning: But same problem…

Siegmund

Hello,
today I received a new kernel update, but again I cannot load. The boot screen shows:

[FONT=courier new]Loading Linux 3.13.1-5.gb4ff6b-desktop…
error: /boot/vmLinuz-3.13-1-5.gb4ff6b-desktop has invalid signature
Loading initial ramdisk…
error: you need to load the kernel first

Press any key to continue
[/FONT]
The original Linux kernel 3.11.6-4-desktop works fine.
The boot mode is UEFI and secure boot is enabled (I cannot switch it off in the BIOS).

Any ideas?

Do you have a setting in the BIOS for Legacy Mode?

I would navigate to the Yast Boot Loader and make sure that you have Grub2-EFI selected.
Click on the OK button and see what happens.

Check /etc/sysconfig editor -->System -->Bootloader -->Secure_Boot → Yes

Tip:
Remember whenever you make changes in the BIOS you must run mkinitrd.

GRUB2-EFI is selected.
BIOS is in UEFI mode -do I have to switch to Legacy mode (in this case my Linux is not found anymore)?

Why is the 3.11 kernel working?

No stay. In UEFI Mode.

All of the new kernels now contain the EFI stub to support UEFI.
Unfortunately, I do not have UEFI on my motherboard. My desktop Asus board is much older and uses BIOS.

What happens when you run the Yast Boot Loader and then restart your laptop? Do you still get an error message?

I checked some notes from openSUSE and they say that you should still see openSUSE. Try it. This is the best way to learn.
Did you create a separate /boot partition when you installed openSUSE?

Just a comment.

I have an Acer Aspire E1-572G with Radeon HD8750M graphics bought around two months ago; neither power off or suspend worked with stock Kernel for OS13.1, and I had screen glitches occurring after having installed the proprietary gpu driver; don’t’ know if these ‘two’ issues are related though. This topic seems fairly common though with some variations in what causes the issues, but the problems I had seemed to be related to this bug: https://bugzilla.kernel.org/show_bug.cgi?id=63861 Shut-down now works, no hibernation freezes, yet at least, and the graphical issue seems also to have disappeared.

Solution for me was to upgrade the stock kernel 3.11.x to version 3.13.1-5 from the kernel:head repo.

PS
The graphical fix just came as bonus and was not what I sought to solve when upgrading the kernel, however, it was very noticeable. I don’t know why!

Olav

Thank you F_Sauce.

That is the exact link that I have provided with another link to the Kernel HEAD repository. It’s good to hear that you’ve got the shutdown working.

The problem with SiegmundS’s Acer set up is that he’s getting an invalid signature after updating his kernel. He is using UEFI. Is your Acer using the legacy BIOS or UEFI?
If you are using UEFI what are the exact steps that you used to update the kernel.

Hello,
today I received a new kernel update, but again I cannot load. The boot screen shows:
Loading Linux 3.13.1-5.gb4ff6b-desktop…
error: /boot/vmLinuz-3.13-1-5.gb4ff6b-desktop has invalid signature
Loading initial ramdisk…
error: you need to load the kernel first
Press any key to continue
The original Linux kernel 3.11.6-4-desktop works fine.
The boot mode is UEFI and secure boot is enabled (I cannot switch it off in the BIOS).

I think the signature is not being passed on to the boot manager.