Accessing smba share


I’m using opensuse 11.2 and have it connected to Active Directory, so I can use KDE/konqueror and Gnome/nautilus for accessing Windows shares without being asked for username/password.

I see that its possible to access and modify files with Gnome/nautilus in applications like openoffice but that is not possible if I use KDE/konqueror.

What I’ve seen is that nautilus uses Gnome-VFS to create a $HOME/.gvfs directory where maps the windows share to a local directory and thus, applicacions uses the .gvfs without being noticed but users.

What I try is use KDE/Konqueror to open files from a Windows share using OpenOffice and other Gnome applicacions.

My questions:

  • Is possible to do that with KDE/Konqueror? I mean: Edit files from openoffice and other non kde applications.
  • Is there a gui application for mounting samba shares using kerberos tiquets? Or a plugin for Konqueror?


I have not tried with 11.2, but previously, I have failed to open files on samba network shares with open office. The workaround is to mount the relevant samba share on the local filesystem and access it that way.

Yes, that’s the way I use.

But I’m looking for an easy way to modify files from KDE without having to open a konsole a mount the filesystem.

Another question is that I’d like to know if is possible to mount samba shares using kerberos tiquet and not having to type username and password.
I’ve tried with
mount.cif share mount_point -o krb5i,guest
and it doesn’t work in OpenSuse.