Aarch64 - Lost my graphic display

When I boot the error message on the black graphic screen (W7) tells me “Cannot display this video mode, change computer display to 1024x768@60hz”. But when I invoke “xrandr” in a text window it reports…

# xrandr
Can't open display 

I looked in /etc/sysconfig but could not find a file that might set the correct display.

Any help will be appreciated.

When X isn’t running, xrandr can’t do anything.

What are the last things you remember happened before the “loss”? When exactly during the boot process does this message appear? Does anything change when you hit the ESC key after the error message appears?

Do cat /var/log/Xorg.0.log | susepaste and provide the resulting URLs here so we might suggest what could be going wrong. If it results in a missing file error message, do instead cat ~/.local/share/xorg/Xorg.0.log | susepaste.

After a “zypper dup” I was getting wavy lines on my screen and I tried to change the refresh speed. The message appears immediately on the black W7 screen. Nothing changes when I hit ESC.

 Pasted as:
Link is also in your clipboard. 

Since I can login in as root and get to a W7 graphic screen, might it be possible to copy the root config files to my user?

Using Yast2 on the command line I went to Boot Loader\ Kernel Parameters\ Graphical Console and selcted 1024x768, and rebooted. Nothing changed. I went back to autodetected by grub2. Nothing changed.

Third attempt. I modified /etc/default/grub to read GRUB_GFXMODE=1024x768, then

grub2-mkconfig -o /boot/grub2/grub.cfg

Nothing changed.

What does W7 mean? If it means Windows 7, you may have a hardware problem: cable, monitor, and/or GPU. The log shows the monitor was made 18 years ago. It might be failing. Wavy lines also suggest a failing monitor. There were a lot of electronic devices made back in that time period that were equipped with poor electrolytic capacitors that fail prematurely, monitors among them. In monitors, these caps are often subject to rather simple replacement by anyone who can manage to use a soldering iron. Visit https://badcaps.net/ for details if you wish to inspect for failures and/or try to repair.

What exactly did you do to try to “change the refresh speed”? That may need to be undone.

According to your Xorg.0.log, you have two HDMI outputs, with #2 being the one connected. Have you tried the other? Are you using some kind of cable converter or converter cable? Are you able to try a different display or cable type, such as DVI to HDMI?

The expedient way to see if a kernel command line parameter helps is to do it as a one time change by striking the E key at the Grub menu and appending the parameter to the (usually wrapped) line that begins with linu. I suggest trying these, based upon your uploaded Xorg.0.log, one at a time:

  • video=1920x1080@60
  • video=1280x720@60
  • video=1024x768@75
    If you find one that helps, then you can migrate it to /etc/default/grub and rebuild grub.cfg.

Thanks for the help.

The monitor works just fine when running Raspberry Pi OS (64bit), Twister 32bit, and Manjaro 64 and I have other monitors if it fails. Yes I use an HDMI to VGA converter, and yes only one output provudes a signal. I have swapped cables, but that makes little sense as the other OS’es display just fine. As for changing the refresh speed, that was several days ago and I can’t remember except that I was offered a choice (number) and I thing I punched the wrong key.

I will try the various video formats and report back.

I used video=1024x768@75 as it works with all three of the other distros. Nothing changed.

My brain finally clicked in. I connected my biggest monitor. It was capable of displaying the incorrect setting. I then set 1024X768 and now everything works with the old monitor.