A simple hardware question for the grub menu.

I bought a new Windows 8 computer (after an untimely demise of my previous companion) but I’m lucky the assembler provided me with a Non-EFI and Non-GPT model so that a dual-boot was easy to make.

My keyboard is attached with USB and the seller says that is active from the first moment - only that’s not the case and during boot I simply have to wait till time-out. (no response from the keyboard)

This system also has a legacy PS/2 keyboard plug and I’m reasonably certain that is it recognized since I used a keyboard from another computer in order to get to BIOS (for the boot-order).

Buying another PS/2 keyboard seems a waste of money. But I find it difficult to believe I’m the only one with this problem. Could it be bios related? Once the OS kicks in, be it Windows or Linux, all works as it should.

Thanks for any advice.

Yes, it can. Check if your BIOS has something like “Legacy USB support” setting that activates USB drivers (at least for input devices) early.

GRUB2 has own USB drivers that may work, although I’d check BIOS first.

Thanks for the reply.
But no, I checked and all USB settings are on (driver, legacy and mass storage).
Now, meanwhile I found that a cheap usb to ps/2 adapter works for some people. (Google is great) I’m going to buy that tomorrow.
Moral of this story: don’t blame the software.

Is this a desktop computer or a laptop? Which usb port are you trying to use, I have at least one pc here that only activates the first two usb ports on boot. So if I have anything plugged into the usb2 or front usb ports it will not work till the OS is up.

Though I’m ashamed to admit it, simply plugging the keyboard in the upper usb in the back solved my issue. Ok, I didn’t use the front but simply a cluster that was easier to reach. Thanks, that solved it. By the way it’s a desktop and I have 10 usb ports on it.