A couple problems...

I just spent about 3 hours trying to get amarok2 to play music… and I somehow managed to get it playing after having tried a million different things… not even sure which one of them fixed it.

Now the problem I am having is that the sound quality is just awful. It seemed to play just fine in Amarok 1.4 but in this version it just doesn’t sound right. Any suggestions?

Also… How can I get amarok 2 to play .m4a files?

I am using 11.1

Help would be greatly appreciated… thank you

Which sound engine are you using in Amarok? I prefer using the xine sound engine, where I have replaced the Novell/SuSE-GmbH packaged libxine1 with the Packman packaged libxine1, and also installed the packman packaged amarok, amarok-xine and amarok-packman.

Note if you have not done so, you should setup your repositories for your software package manager with 4 repositories: OSS, Non-OSS, Update and packman. Just those 4. No others. Guidance is here: Repositories/11.1 - openSUSE-Community

I had problems with the beta version of amarak2 that comes with 11.1 but the more recent versions from:-

Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.1

worked without any problem.