8BitDo Ultimate 2.4G works*

Hi there!

I bought the controller this week because I saw some people were having problems and was curious how bad it was and if it could be fixed to have it as my main wireless controller. I have to say that the first thing I did was connect it to a Windows partition I have to see if it worked properly there, then updated the firmware and started trying in Tumbleweed.

It didn’t work out of the box, Steam Big Picture detects it but that’s about it. However, I followed these steps:

The following may help some of y’all with this issue:

Create a new file /etc/udev/rules.d/99-8bitdo-xinput.rules (will require superuser privileges, probably).

Paste this udev rule in there, then save and exit the file: ACTION=="add", ATTRS{idVendor}=="2dc8", ATTRS{idProduct}=="3106", RUN+="/sbin/modprobe xpad", RUN+="/bin/sh -c 'echo 2dc8 3106 > /sys/bus/usb/drivers/xpad/new_id'"

Run the following command in a terminal: sudo udevadm control --reload

Unplug your controller if it is already plugged in, then make sure it is in X-Input mode, then plug it back in, then wait a second if you have the Bluetooth version of the controller (it ■■■■■ around trying to figure out if it is in a switch or not, I think), and it should now work in Steam (should appear in the controller config tool).

Let me know if this helps (or doesn’t help) somebody! It worked for me, at least.

From this reddit thread: Reddit - Dive into anything

And now it works in most of my games! I tried with some games I have in Lutris and Steam, and it worked in:
+Hades, Hollow Knight and TMNT: Shredders Revenge in Steam
+Kingdom: Two Crowns and Skatebird in Lutris

It didn’t work in:
-Spiritfarer in Steam
-Towerfall in Lutris

When researching I was looking for the name of the controller and Tumbleweed to see if anybody had tried, but I didn’t find anything, so I hope this information is useful to someone.

If you have some ideas that I could try to see if we can get it working fully in Tumbleweed, or there is some game you’d like to know if it works in, don’t hesitate to respond (I don’t own many AAA games, tho).