60°C Idle Temperature on freshly installed Leap-15.4 KDE on a Lenovo Thinkpad W530 Notebook

Good evening,

investigating this for more than a month now. This is the story …

I own several Lenovo Thinkpad W530 Laptops in good condition, all with i7-3740QM, 32GB RAM, 512 GB SSD, all with Leap 15.2 KDE, one even with Leap 15.0 KDE, so urgent need for upgrade, thought of Leap 15.4 KDE. Having > 6 years experience with openSUSE Leap and TW systems and like to stick with openSUSE.

After booting, idle temperatures typically are around 45°C, fan is at 0 rpm, using Thinkfan with my customized configuration. The idle temperature around 45°C is valid for Leap 15.0 - 15.3 on all my Thinkpad W530 machines. However, if I install Leap 15.4 or TW, I am getting an idle temperature around 60°C after a fresh install, with BIOS fan or Thinkfan, with Wifi on or off, no matter what.

I have tried all these Leap 15 systems, with several configurations (Fan software, Wifi on/off, even with several desktops like XFCE, openbox etc.) however the difference did not go away. Even CPU load would be around 1 % with the freshly installed Leap 15.4 or TW systems, in comparison with the sesasoned Leap 15.0 - 15.3 systems, where CPU load is around 3 - 5 %.
So, even with less CPU idle load the idle temperatures would be higher.

Maybe one more info, watching YouTube videos. On my seasoned Leap 15.0 - 15.4 systems, “video” temperature typically is 60°C, sometimes 70°C up to 80°C depending on quality, however with Leap 15.4 or TW installed (and packman codecs, too), I am getting 80°C up to 100°C, with the same video, Firefox web browser, video quality, no matter what.

I tried to find out the reason for the high(er) temperatures with Leap 15.4 in comparison to 15.3, but was not able to pin down the culprit. I have described my problem in quite general terms and did not provide detailed information about the diagnosis software and methods I have tried, nor did I provide log files and other results of my investigations.

Thank you for your consideration, I am looking forward to hear from you, what I might have overlooked. Regards, M.

See https://forums.opensuse.org/showthread.php/568642-Laptop-temperature-in-idle-state

and

https://bugzilla.opensuse.org/show_bug.cgi?id=1201013

@hui thank you for posting the above links.

Certainly learned something new, however, the high-idle-temp issue is still not solved.

Let me explain.

As described, I had that 60°C idle temp issue, could not slolve it, posted about it in this forum. Meanwhile Kernel Updates came in: 20220827 -> 20220828, then 28220828 -> 20220829. After the first update, the 60°C issue was gone, just like that. Yesterday, I tried to install Tumbleweed’s Media Codecs using the famous 1-Click Install (using Firefox). Did as told, all went well (except gstreamer ugly, you know), also went to YaST Repositories -> Packman -> Move packages to this repository (i.e., vendor change). After that, my 60^C idle temp issue was in place, again. Rolled back via snapper (so no codecs now). 60°C idle temp was gone.

Therefore, again, I am out of ideas. However, isn’t there a deeper reason behind this fragile idle temperature thing? What could it be?

Thanks for reading, Regards, M.

Are you willing to tell what you tried?

@ karlmistelberger thank you for your request, which makes very much sense.

Because of the contradictions I tried to explain above, I am unable to offer a clear path of investigation, rather did I “each and every” CPU “performance diagnose-and-optimize” tutorial I would find on the internet, but I could not draw any sensible conclusions out of the hundred log files I produced on the way.

However, I respect this forum and its participants very much, so I definitely will come forward with answers, and your time reading about my issues shall not be wasted. Maybe give me some days …

Until then, regards, M.

Working together the whole weekend, @karlmistelberger and me, after hours and hours of work, we found out that openSUSE Leap-15.4 KDE Live one one USB 3.0 flash drive as well as openSUSE Tumbleweed (TW) on a different USB 3.0 flash drive both did not show the above desvcribedn 60°C idle temperature issue, if both Systems were updated / upgraded to their latest possible versions, respectively.

Therefore, we preliminarily concluded, that recent Updates might have solved deeper issues which hitherto might have contributed to the 60°C idle temperature issue. Encouraged by our “findings”, we decided to finish conducting experimental installation, undating, upgrading back and forth using removable flash drives. Rather I will try out a complete re-install of my openSUSE Leap-15.4 KDE system, that led me to come forward with my unresolved 60°C idle temperature issue in this forum.

I promised to come up with answers so that the consideration of you all shall not be a waste of your time, therefore I will come back to report to you all how it was going, maybe next week, I hope.

Regards, M.

As promised, here I’d like to get back to you to explain to you how things were evolving during the week.

Yes, finally, I filed a Bug Report https://bugzilla.opensuse.org/show_bug.cgi?id=1203404, where, again, @karlmistelberger helped me a lot investigating the 60° idle temperatures issue.

Soon we decided that probably we should move away from trying out openSUSE Tumbleweed and Leap-15.4 on USB 3.0 Drives, rather trying them out “on disk” (Samsung 960 Pro 512 GB). With Tumbleweed, Leap-15.4 and Manjaro 21.3.7 as well (all KDE Plasma), then installing Multimedia Codecs and later on even installing openSUSE kernel_vanilla, we concluded that the 60°C idle temperatures issue is always lingering around the next corner, waiting to bite us after the next install or update or upgrade - if the 60°C idle tempersatures issue is not already there in the first place. And if it’s there, sometimes it could vanish for an update or two, but it always came back.

On the other hand, neither openSUSE Leap-15.0 - 15.3, nor a Manjaro 21.3.7 KDE Plasma Systems ever showed this 60°C idle temperatures issue. And don’t forget, watch YouTube and you’ll have a 90°C temperatures issue.

That’s it for today. Thank you for reading, Regards, M.

Sure it is not a file indexing problem???

Check top see what is eating the CPU

You may consider attaching the sensors output of the systems investigated to 1203404 – 60°C Idle Temperature on freshly installed openSUSE Tumbleweed AND Leap-15.4 as well

**erlangen:~ #** sensors 
k10temp-pci-00c3 
Adapter: PCI adapter 
Tctl:         +39.5°C   
Tccd1:        +37.8°C   

nvme-pci-0100 
Adapter: PCI adapter 
Composite:    +46.9°C  (low  = -273.1°C, high = +84.8°C) 
                       (crit = +84.8°C) 
Sensor 1:     +46.9°C  (low  = -273.1°C, high = +65261.8°C) 
Sensor 2:     +45.9°C  (low  = -273.1°C, high = +65261.8°C) 

nct6687-isa-0a20 
Adapter: ISA adapter 
VIN0:               1.01 V  (min =  +0.00 V, max =  +0.00 V) 
VIN1:             992.00 mV (min =  +0.00 V, max =  +0.00 V) 
VIN2:             992.00 mV (min =  +0.00 V, max =  +0.00 V) 
VIN3:             672.00 mV (min =  +0.00 V, max =  +0.00 V) 
VIN4:             992.00 mV (min =  +0.00 V, max =  +0.00 V) 
VIN5:             768.00 mV (min =  +0.00 V, max =  +0.00 V) 
VIN6:             672.00 mV (min =  +0.00 V, max =  +0.00 V) 
VIN7:               1.54 V  (min =  +0.00 V, max =  +0.00 V) 
VCC:                3.34 V  (min =  +0.00 V, max =  +0.00 V) 
VTT:                1.82 V  (min =  +0.00 V, max =  +0.00 V) 
fan1:              630 RPM  (min =    0 RPM) 
fan2:                0 RPM  (min =    0 RPM) 
fan3:                0 RPM  (min =    0 RPM) 
fan4:                0 RPM  (min =    0 RPM) 
fan5:                0 RPM  (min =    0 RPM) 
fan6:                0 RPM  (min =    0 RPM) 
fan7:                0 RPM  (min =    0 RPM) 
fan8:                0 RPM  (min =    0 RPM) 
fan9:                0 RPM  (min =    0 RPM) 
fan10:               0 RPM  (min =    0 RPM) 
AMD TSI Addr 98h:  +38.0°C  (low  =  +0.0°C) 
                            (high =  +0.0°C, hyst =  +0.0°C) 
                            (crit =  +0.0°C)  sensor = AMD AMDSI 
Diode 0 (curr):    +42.5°C  (low  =  +0.0°C) 
                            (high =  +0.0°C, hyst =  +0.0°C) 
                            (crit =  +0.0°C)  sensor = thermal diode 
Thermistor 15:     +45.5°C  (low  =  +0.0°C) 
                            (high =  +0.0°C, hyst =  +0.0°C) 
                            (crit =  +0.0°C)  sensor = thermistor 
Thermistor 1:      +44.5°C  (low  =  +0.0°C) 
                            (high =  +0.0°C, hyst =  +0.0°C) 
                            (crit =  +0.0°C)  sensor = thermistor 
Thermistor 16:     +38.0°C  (low  =  +0.0°C) 
                            (high =  +0.0°C, hyst =  +0.0°C) 
                            (crit =  +0.0°C)  sensor = thermistor 
Thermistor 0:      +38.5°C  (low  =  +0.0°C) 
                            (high =  +0.0°C, hyst =  +0.0°C) 
                            (crit =  +0.0°C)  sensor = thermistor 
Thermistor 15:     +45.5°C  (low  =  +0.0°C) 
                            (high = +126.0°C, hyst = +30.0°C) 
                            (crit =  +0.0°C)  sensor = thermistor 
intrusion0:       ALARM 
beep_enable:      disabled 

amdgpu-pci-2b00 
Adapter: PCI adapter 
vddgfx:      762.00 mV  
fan1:         976 RPM  (min =    0 RPM, max = 3500 RPM) 
edge:         +54.0°C  (crit = +97.0°C, hyst = -273.1°C) 
PPT:           3.02 W  (cap =  36.00 W) 

**erlangen:~ #**


The ThinkPad W530 is a No Nonsense Appliance, but compatibility with openSUSE is poor: https://bugzilla.opensuse.org/show_bug.cgi?id=1203404#c5