550 Rename/move failure issue

Not sure I posted this to the right thread or not…

I just performed a fresh installation of openSUSE 11.3 and ISPConfig 3 on my server. I read through the article “The Perfect Server - openSUSE 11.3 x86_64 [ISPConfig 3]” and followed the instructions closely. Everything went smoothly.

I went into ISPConfig 3 and set up a DNS zone, email mailbox, FTP client, and website all for a client I created, hoping to use the client as the main account for a web site I want to host on my server. After I finished with this, I logged onto the server through FileZilla using my newly created client’s information. It took me to the “main directory” with the folders cgi-bin, log, ssl, tmp, and web. When I open “web” I see an html file named “index.html.”

I tried loading a mock website into the folder, also with an index.html file, and the files transferred over properly except the mock index.html file. The program changed the name to index.html.1. I tried to delete the original index.html file but was not allowed to. I then tried to rename it to something other than index.html and kept receiving a 550 Rename/move failure message. Can anyone point me in the right direction or help me resolve this issue?

I’m thinking perhaps I don’t have the right permissions with the client to rename files, but since that’s the account I want as the “owner” of this web site, I need to change the permissions so I can. I tried changing the ISPConfig 3 “Limits” for the account to SSH-Chroot Options “NONE” thinking that might be the issue, but it didn’t solve anything. Now I’m just lost.

The reason why I think it might be an openSUSE issue (from my actions, not the software) is because of the permission problem. I think maybe one of my files aren’t set properly to allow my client to rename or move files (obviously), but I don’t know which file or how to change it for the client I created in ISPConfig 3.

Okay, I think I figured it out for anybody who runs into this issue. It wasn’t covered in the “The Perfect Server” guide for openSUSE 11.3 and ISPConfig 3, but after you finish following the guide, in order to be able to rename or move files using FTP, you have to edit your pure-ftpd.conf file.

vi /etc/pure-ftpd/pure-ftpd.conf

Then you need to make the following changes:

AutoRename no
NoRename no

Then you have to restart pure-ftpd. I rebooted the server. Afterwards, I was able to rename my files using FileZilla.

On 01/30/2011 11:06 PM, m6zero wrote:
>
> It wasn’t covered in the “The Perfect Server” guide for openSUSE 11.3 and ISPConfig 3

happy you sorted it out!

please inform the source of that guide (i didn’t find it in our wiki,
or forum–did i overlook it) the necessary actions that should be
added in…


DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 11.3, KDE4.5.5
“release 1”, Thunderbird3.0.11,]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11