15.6 GA to be released soon - a couple of questions

According to the Roadmap page for 15.6 Beta, it is due out in a couple of days:

Quoted
"Wed, Jun 12, 2024 Public Availability of the Release

o openSUSE Leap 15.6 will be released to the public at 12:00 UTC"

It’s my understanding that after the GA announcement is made, we need to switch from running “zypper dup” to then use “zypper up” … correct?

And I assume there will to be changes to the repos ?.

Or is the recommendation to install using a 15.6 GA .iso ?? (seems like overkill)

@myswtest no panic, you have 6 months or so to look at upgrading… and it’s dup to move to 15.6, then up from then on…

https://en.opensuse.org/SDB:System_upgrade#Migration_to_a_new_Leap_release

2 Likes

Departing from what?

  • If you are r unning a pre-release 15.6 now, then a simple zypper dup will be OK.
  • If you are running 15.5, then there is more to do (and descriptions are, or will be, available).

But it looks as if you think you should be in a hurry.
Personally I always wait until e.g. one or two months before the end of the end-of-life of the previous (in this case 15.5) level. Thus when you do not need 15.6 for e.g. new hardware, why the hurry? Just wait until the first fuss on the forums peters out :wink:

1 Like

You are now on Leap 15.6Beta and use
zypper dup
for updating this Beta?

After Release use the normal commands or GUI-Tools as in Leap 15.5.

1 Like

I re-read my orig post, and it is slightly confusing. I’m currently only running 15.6 Beta on a laptop and desktop. (no 15.5 installed).

According to the Roadmap page, it states 15.6 GA will be released June 12 (in 2 days).

So it seems some folks would rather wait for GA bugs to be fixed, before they move from running the Beta to installing the GA. Seems reasonable enough.

I used to be a long-time TW user but decided to switch to Leap for a couple reasons, one being to get to away from the daily dups and bugs :slight_smile:

Thanks for all the replies!

One zypper dup is required following GA release availability to ensure being fully 15.6, after which zypper up as updates become available.

1 Like

Is there a way to do an in place upgrade graphically? Basically everything a normal user could want to do is in YaST2, except upgrades from what I can tell

If there are bugs in GA that weren’t in the Beta, it wasn’t a very good beta. Beta to GA should fix things, not the other way around. At the very least, Beta to GA should have no functional differences, with the exception that GA gets updates and Beta releases are abandoned.

Is there some reason you think that the 15.6 Beta was not a good test?

2 Likes

Actually, 15.6 Beta has been flawless for me … no “dup” issues at all, no conflicts, etc.

I was simply asking, when the GA is released in 2 days, is there anything special to consider or switch ( -->as in repos<-- )

I will probably enable the “libdvdcss” repo. When I last checked, it still wasn’t ready for use. But it usually becomes available at around the time of the official release.

I’m not expecting to change anything else.

No, not really. YaST cannot handle a disribution upgrade. It was never designed to do that. Yet, one can open a terminal, do

sudo zypper --releasever=15.6 dup

and look at the terminal window from the running desktop.

As you are NOT the OP here, it is again not clear to me what your starting position is.

But in general, the answer is NO. Because in both cases you have to do a zypper dup somewhere in the process and that can not be done using YaST.

Well, it appears the upgrade to the GA might be happening tonight.

I’m curious what this means (it’s going to be re-installed ???):

The following product is going to be reinstalled:
  openSUSE Leap 15.6  15.6-1  x86_64  Main Repository  openSUSE

Overall, I see this, when I run a “zypper dup”:

The following product is going to be reinstalled:
  openSUSE Leap 15.6  15.6-1  x86_64  Main Repository  openSUSE

The following 4 NEW packages are going to be installed:
  gutenprint               5.2.14-150000.3.2.2  x86_64  Main Repository  SUSE LLC <https://www.suse.com/>
  kernel-default           6.4.0-150600.21.2    x86_64  Main Repository  SUSE LLC <https://www.suse.com/>
  kernel-default-extra     6.4.0-150600.21.2    x86_64  Main Repository  SUSE LLC <https://www.suse.com/>
  kernel-default-optional  6.4.0-150600.21.2    x86_64  Main Repository  SUSE LLC <https://www.suse.com/>

The following 3 packages are going to be REMOVED:
  kernel-default           6.4.0-150600.21.1  x86_64  SUSE LLC <https://www.suse.com/>
  kernel-default-extra     6.4.0-150600.21.1  x86_64  SUSE LLC <https://www.suse.com/>
  kernel-default-optional  6.4.0-150600.21.1  x86_64  SUSE LLC <https://www.suse.com/>

The following package requires a system reboot:
  kernel-default  6.4.0-150600.21.2  x86_64  Main Repository  SUSE LLC <https://www.suse.com/>

194 packages to upgrade, 4 new, 3 to remove.
Overall download size: 587.6 MiB. Already cached: 0 B. After the operation, additional 84.4 MiB will be used.

    Note: System reboot required.

Backend:  classic_rpmtrans
Continue? [y/n/v/...? shows all options] (y): 

Yea, I’m back again … and a bit confused.

I just fired up my laptop and did a “zypper dup” ( it also runs 15.6 Beta) and the results are ONLY 8 package updates, two of them are Chrome and Brave browsers.

Why the discrepancy from my desktop? (see my previous post about 194 package updates including kernel upgrade)

Wait until the repos are synced to the mirrors.

When was your previous update.

Checking from here, I get 79 packages updated. My previous update was on June 6th. (I normally update once per week).

Thanks for the response!

I checked it just before my original post, so a day ago.

When I ran the “dup” on the desktop, I answered “no” to not update because I was a bit concerned, and then posted my previous reply.

And today ran the dup on the laptop.

I see there’s a 15.6 GA “party” invitation that’s been posted in here.

I don’t see any need for concern.

I tried “zypper dup -D” and then “zypper up -D”.

Both gave 79 updates. So I think we are past the point where you need to do “zypper dup”. We are now in regular update cycles for 15.6.