15.2 Nvidia : X Error of failed request: BadValue (GLXCreateNewContext)

After today’s Online Update, I get
name of display: :0.0
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 151 (GLX)
Minor opcode of failed request: 24 (X_GLXCreateNewContext)
Value in failed request: 0x0
Serial number of failed request: 92
Current serial number in output stream: 93

Current Nvidia driver set is 450.80.02_k5.3.18 and obviously has triggered the failure.

How to get back to the previous version?
Thanks in advance.

Tried rebooting? Tried a forced reinstall of the driver? Neither may work, but that’s what I’d try first.

Yes, I rebooted and reinstalled the driver set. The drivers are properly loaded as before, the problem is in the nvidia OpenGL libraries.

I could of course remove proprietary nvidia drivers altogether, and resort to nouveau and mesa-gl libraries which would result in missing openGL features and much weaker graphics performance.

But all worked fine before this update. My question is whether I can revert to the previous version of the nvidia driver set.

If you’re prepared to install via the “hard way” (https://en.opensuse.org/SDB:NVIDIA_the_hard_way), the install “run” files for older versions appear to be available at https://http.download.nvidia.com/XFree86/

Since the advent of btrfs snapshots you may just be able to boot from a previous snapshot prior to the driver update. Or if using ext4 for root, then restoring a backup might be the easiest way to go.

Thanks for the informations. I “solved” the problem by starting an upgrade of 15.2 to 15.2 :O, resulting in removal of all non Suse repos and needing a complete online update to recent, After that, I added the repos again, and OpenGL library nvidia-glG05 450.80.02-lp152.35.1 works fine. Rendering is even faster than before. Still I have no idea what triggered the condition.
Sorry for the hazzle, and thanks again.

I think I’ve also encountered similar issues which had involved a force reinstall of the proprietary driver. If I look in Yast → Software Management I can see that xf86-video-nouveau is locked as Taboo – Never Instal. If that taboo lock somehow gets cleared, I suspect that could cause your issue.