13.2 cursor theme

so I have jumped in and done a full fresh install of 13.2 (much earlier than I ordinarily would).
Having a few minor issues - specifically this one is annoying me the most.

I have always disliked the oxygen cursor them (default) so usually install the aero cursor theme.
I have done this and it is working fine . . . .
but every time I reboot, plasma workspaces reverts to using the oxygen cursor theme while all applications (including native KDE apps, gtk and qt apps) continue to use the aero theme.

I have tried installing various other cursor themes and they all exhibit the same issue.


any suggestions / ideas?

Many thanks

wow - it’s actualy even more random than I thought.
e.g. open Thunderbird and aero cursor is used but then open Thunderbird preferences window and it switches to oxygen cursor.
Can’t reproduce the same behaviour in firefox which sticks to the aero cursor in the app window and preferences window.

That’s a known problem in KDE, and it’s not a new one either:

Don’t expect a fix in KDE4, I’d say…

hmmm . . . that’s interesting.
I’ve never seen it before until openSUSE 13.2
I wonder what has made it rear its head on me now.

It’s annoying enough that I’m considering a revert to 13.1 - or another DE if it can’t be fixed. :open_mouth:

broke my installation before so reinstalled.
so far the cursor issue hasn’t presented itself again.

fingers crossed . . .

Don’t know either. I did notice it in 12.3 and 13.1 as well already.
But I don’t really change my cursor theme much or at all. The one I’m using I set up 10 years ago in /etc/sysconfig/windowmanager.
Maybe try to set it there as well?

It’s annoying enough that I’m considering a revert to 13.1 - or another DE if it can’t be fixed. :open_mouth:

AFAIUI, there’s some cache on the hard disk that’s stale, but I’m not sure which one.
Maybe try to remove plasma’s caches in /var/tmp/kdecache-$USER:

sudo rm /var/tmp/kdecache-$USER/plasma* /var/tmp/kdecache-$USER/icon*

, preferably when not logged in to KDE.
Perhaps this would “fix” it?

Could be a configuration file issue. If it happens again try a different user

No, it rather seems to be a caching issue.

A new user would help of course as the cache is user specific (at least if it is indeed the plasma cache that’s at fault, Xorg’s caches would be system-wide I suppose), but the same problem might occur there as well if you change the cursor theme.

yes, indeed . . . tried as a different user but the issue was still present. Even when working as a super user (yast etc) there were still cursor inconsistencies.

As mentioned previously - it hasn’t yet reappeared since a reinstall.
Thanks for the tip on clearing the cache - if it shows up again I’ll give it a go.
funny how such a small issue can be so jarring - like you I’ve been using the same cursor theme for almost ten years now. Using the fat oxygen cursors make me feel like I’m DUI. lol!

Have to say that I’m quite liking 13.2 -seems the longer release cycle makes a bit of a difference in the os evolution.