13.1 x64 Audio Stuttering if volume increased over 50 - 60%

Hello all,

I’ve been looking around, and haven’t been able to find a solution to this problem. It started in 12.3 and has now continued into 13.1. I am using KDE, I have tried some of the old work arounds for Pulse, have configured the sound in Phonon to default to the analog (not HDMI) and it seems no matter what I do the problem persists.

Here’s the issue. When the volume of an application gets above a certain level, the audio stutters. It isn’t breaking up (over driving). If I open the volume control while this is happening, I can see the sliders bounce up and down as it stutters. When running Amarok, the volume (i.e. volume 60%) displays on the screen when this happens. When I open phonon and run the test for the selected analog output (under audio hardware setup tab), the “Connector” option will jump between “Line Out” and “Headphone” when it stutters, like it can’t decide on the output.

I have shut off the HDMI adapter so I don’t think it is a device conflict. In YaST2, under sound my analog card is set as the default device (0). The device is listed as a SBx00 Azalia (Intel HDA).

I have tried this link:

SDB:Audio troubleshooting - openSUSE

and found no love for my audio. I listen to lots of music while I am on the computer, and this is terribly annoying. I don’t need it to be loud, I just need it t work. The issue exists in music, test mode for Phonon, games and every where else I have tried it.

One final bit of information, my speakers are an old set of Panasonic powered speakers with a headphone jack integrated in to them and currently I have no other speakers to test the computer with.

Thanks in advance.


Well, 66% volume in KMix actually are 100%. So if you increase it over 66%, it’s in fact more than 100% which could explain problems.
Background: PulseAudio supports volumes up to 153%. KMix has an experimental feature to support this, which is turned on by default in 13.1. But it still shows a volume range of 0-100%. So 100% in KMix are actually the maximum 153% of PulseAudio.
You can disable the feature if you want to, see here: http://forums.opensuse.org/english/get-technical-help-here/hardware/492000-incorrect-volume-range-audio-devices.html#post2597691

But PulseAudio apparently has some problems ATM, f.e. it seems to keep switching to headphones for some people.
You can try to disable PulseAudio in YaST->Hardware->Sound->Other->PulseAudio Configuration.