13.1 and VB 4.3.4 RDP problem?

I have a problem connect to VMs trow RDP running on my local server using 13.1 on both client and server. Using VB 4.3.4. The server was upgraded to 13.1 from 12.3.

I have tried 2 different Pc’s with 13.1 and get the same message:

""Autoselected keyboard map en-us
Failed to negotiate protocol, retrying with plain RDP.
WARNING: Remote desktop changed from 1280x1024 to 1024x768.
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  18 (X_ChangeProperty)
  Resource id in failed request:  0x0
  Serial number of failed request:  38
  Current serial number in output stream:  43.""

I connected to the server trow VNC an run a WM VB win8.1 and that work excellent to connect to other WM on the same server. I have run zypper up and zypper dup on client/server. Latest VB 4.3.4 Oracle VM VirtualBox Extension Pack installed.
The latest (4.3.4) VB guest additions where installed on WM VB.

It is reported as a bug https://bugzilla.novell.com/show_bug.cgi?id=849740

Anyone else have this problem?


Based on the bug’s OP, it looks to me like VBox may be limiting the amount of data that can be transmitted.
Recommend setting the display to combinations (or one of) the following

  • lower display resolution, eg 800x600
  • lower color resolution (eg 16bit)

My guess is that it may not have been a problem with 12.3 because the default display was smaller than it is in 13.1


Hi tsu2
-tested lowered resolution (800x600)
-tested…16 bit and still got fault message.

A question, -do yoy have it working on 13.1 client and 13.1 server and VB4.3.4?


I’m not set up exactly like you to be able to test…
I run KVM on my openSUSE hosts and
Virtualbox on my Windows hosts.

I also have never preferred the RDP protocol for non-Windows clients (I assume you’re using RDP), but that might be just a prejudice nowadays. Years ago, it was promising but apps were inferior to other technologies (could have been app and not necessarily protocol issues).

BTW - It looks like VBox 4.3.6 was just released within the past 24 hrs. Don’t know how long it’ll be until it’s available on openSUSE (likely soon).


Thanks for you reply tsu2. Why I preferred RDP is because in the family there is need for a drivers license application (only win) and sound is necessary. It was a quick solution to use VirtualBox on my server. Anyway see below what i filled in on the bugreport some minuts ago.


“”"Tested to run a zypper dup on both server and client (13.1) today. Further on I was updated VB (VirtualBox) to 4.3.6 with the updated additions and also installed the updated guest-additions on VB machines.

No luck.Still the same problem.

I then installed Remmina remote client from the opensuse repos. Worked out but I don’t see it as a replacement for KDE Terminal Server Client.

Anyhow I have found out that it is not on the server side things are messed up.


In the future if you submit a bug it’s better to post the bug’s link address instead. That’s so that if anyone wants to contribute to this topic they should append to the bug report instead of this Forum thread because anyone who reviews and possibly works on the bug won’t likely see what might be in these Forums.


I did it in my first post. But you are right :shame:.

The bug (849740) link is here .