13.1 after an update: "Want me to fall back to....?(Y/n) & splash screen. Unresponsive. No boot.

Thank you all for your input. I am learning a lot from this! (I am new to linux, so be gentle :smiley: )

I installed some updates on the 8th / 9th.
When I turn on the laptop it just stalls at the green chameleon screen. If press ESC I see this:

RAID set "isw_chfijbfgbc_HDD0" was activated
The dynamic shared library "libdmraid-events-isw.so" could not be loaded:
    libdmraid-events-isw.so: cannot open shared object file: No such file or directory

usb 2-2: (I can type all of these out if necessary!)
usb 2-5: 
isb 2-6:  
usb 2-7:   

.....................Could not find /dev/mapper/isw_chfijbfgbc_HDD0_part7.
Want me to fall back to /dev/disk/by-id/raid-isw_chfijbfgbc_HDD0_part7? (Y/n)

No matter what I press it just goes to the splash screen, and when I press ESC, it’s back to the (Y/n)? part.

Because I have dual boot set up with windows 8, I can access the logs with LinuxReader.
I also have the RESCUE option available at boot.

I thought maybe my problem is similar to this post “boot problem after lvm2 update” but my lvm.conf says use_lvmetad = 0

What are my options?

Try selecting different kernel versions (go to Advanced menu). Does anyone work?

Do you have /boot as separate filesystem? How large is it?

Thanks for your reply.

On the advanced menu of grub2 I have the following options:

openSuse 13.1 with Linux 3.11.6-4-desktop
openSuse 13.1 with Linux 3.11.6-4-desktop (recovery mode)

I cannot tell where /boot lives or how to check it’s size.

try
openSuse 13.1 with Linux 3.11.6-4-desktop **(recovery mode) **

On 2014-02-14 04:26, helaughsatfear wrote:

>
> I cannot tell where /boot lives or how to check it’s size.

Well, you can boot a Linux live CD, and run in a terminal “parted -l” of
“fdisk -l”, then post the output here.

/boot is a directory where the files needed for booting are. And in some
cases, like when using LVM or raid, it is also a partition. As the
message you posted is about raid, it is possible you have a separate
/boot partition.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Major breakthrough lol!

At the prompt where the system was stuck, I pressed Ctrl + Alt + F1 (I think) and it brought me to another terminal it seems.

This is the last of the output there:

[1.200039] ACPI: Power Button [PWRF]
[1.204793] [drm] Initialized drm 1.1.0 20060810
[1.2.....] [drm:drm_pci_agp_init] *ERROR* Cannot initialize the agpgart module.
[1.2.....] DRM: Fill_in_dev failed.
[1.2.....] microcode: CPU0 sig=0x40651, pf=0x40, revision=0x10
[1.2.....] microcode: CPU0 updated to revision 0x16, date = 2013-08-08
[1.2.....] microcode: CPU1 sig=0x40651, pf=0x40, revision=0x10
[1.2.....] microcode: CPU1 updated to revision 0x16, date = 2013-08-08
[1.2.....] microcode: CPU2 sig=0x40651, pf=0x40, revision=0x10
[1.2.....] microcode: CPU2 updated to revision 0x16, date = 2013-08-08
[1.2.....] microcode: CPU3 sig=0x40651, pf=0x40, revision=0x10
[1.2.....] microcode: CPU3 updated to revision 0x16, date = 2013-08-08

I pressed enter, and the desktop GUI magically loaded. It didn’t ask me to login though, which it usually does.

Thank you for the suggestion, but this option results in the same error / prompt.

Thank you for the response.

When the desktop loaded, I got the following for “parted -l”

lazarev@linux-c7hs:~> su -
Password: 
linux-c7hs:~ # parted -l
Error: Invalid argument during seek for read on /dev/sda                  
Retry/Ignore/Cancel? I                                                    
Error: The backup GPT table is corrupt, but the primary appears OK, so that will be used.
OK/Cancel? OK                                                             
Backtrace has 8 calls on stack:
  8: /usr/lib64/libparted.so.0(ped_assert+0x31) [0x7f4790b00d71]
  7: /usr/lib64/libparted.so.0(+0x42e05) [0x7f4790b2fe05]
  6: /usr/lib64/libparted.so.0(ped_disk_new+0x49) [0x7f4790b06a39]
  5: parted() [0x407d79]
  4: parted() [0x4087aa]
  3: parted(main+0x149b) [0x406eeb]
  2: /lib64/libc.so.6(__libc_start_main+0xf5) [0x7f47902edbe5]
  1: parted() [0x406f39]

…along with “You found a bug in GNU Parted!” among other things"
full output http://paste.opensuse.org/55070488

On 2014-02-14 20:56, helaughsatfear wrote:

> I pressed enter, and the desktop GUI magically loaded. It didn’t ask me
> to login though, which it usually does.

Mmm…

> robin_listas;2624720 Wrote:
>> On 2014-02-14 04:26, helaughsatfear wrote:
>>
>>>
>>> I cannot tell where /boot lives or how to check it’s size.
>>
>> Well, you can boot a Linux live CD, and run in a terminal “parted -l” of
>> “fdisk -l”, then post the output here.

> When the desktop loaded, I got the following for “parted -l”

At this point, with your system booted, it could be interesting to see
the output of “df -h”.

But you have some other (big?) problem below…

> Code:
> --------------------
> lazarev@linux-c7hs:~> su -
> Password:
> linux-c7hs:~ # parted -l
> Error: Invalid argument during seek for read on /dev/sda

What??? :-o

> --------------------
>
>
> …along with “You found a bug in GNU Parted!” among other things"
> full output http://paste.opensuse.org/55070488

Well, you could send that to openSUSE bugzilla.

But at this point I don’t know if there is some big problem with your
hard disk. It could be defective.

You could try with “smartctl -a /dev/sda”, maybe it says something useful.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Thank you for your time!
Just so you know, I have RAID0 configuration with 2 SSDs. Windows works like it should.

“df -h” yeilds:

lazarev@linux-c7hs:~> df -h
Filesystem                             Size  Used Avail Use% Mounted on
/dev/mapper/isw_chfijbfgbc_HDD0-part7   20G  5.1G   14G  28% /
devtmpfs                               3.8G  8.0K  3.8G   1% /dev
tmpfs                                  3.8G   80K  3.8G   1% /dev/shm
tmpfs                                  3.8G  4.3M  3.8G   1% /run
tmpfs                                  3.8G     0  3.8G   0% /sys/fs/cgroup
tmpfs                                  3.8G  4.3M  3.8G   1% /var/lock
tmpfs                                  3.8G  4.3M  3.8G   1% /var/run
/dev/mapper/isw_chfijbfgbc_HDD0-part2  296M   48M  249M  17% /boot/efi
/dev/mapper/isw_chfijbfgbc_HDD0-part8   75G  293M   74G   1% /home
lazarev@linux-c7hs:~> 

“smartctl -a /dev/sda”
http://paste.opensuse.org/6d27d137

After the computer goes to sleep, on “wake up,” nothing can be accessed or seen, just black screen and i have to Ctrl + Alt + Shift + PrtScrn + r + e + i + s + u + b

Almost forgot:
When I press Enter on that one paused terminal that I described in the beginning, the very next line that it prints out is 'Out of Memory". Then other stuff is displayed, and then the desktop is loaded.

Thank you again for your help!

Just in case, here is the output of “lsblk -o NAME,SIZE,TYPE,FSTYPE,MOUNTPOINT,PARTLABEL,LABEL,HCTL”:

http://paste.opensuse.org/17d26543

On 2014-02-14 22:36, helaughsatfear wrote:
>
> Thank you for your time!
> Just so you know, I have RAID0 configuration with 2 SSDs. Windows works
> like it should.

I’m guessing that is one of those fake-raid setups. Needs a driver in
Windows and Linux, so that the raid can be seen in both.

Maybe there is a problem with the Linux driver, whatever that is. I’m
not experienced with that setup (I do not want to use them (fake
raids)). dmraid.

And I see it is a UEFI setup.

> “df -h” yeilds:

Thanks. It looks fine. The problem is not there.

> “smartctl -a /dev/sda”
> http://paste.opensuse.org/6d27d137


> Device is:        Not in smartctl database [for details use: -P showall]

I think it means that we don't know what all of the parameters are. Bad
for us.

> SMART overall-health self-assessment test result: PASSED

> ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE

There are many labeled "Unknown_Attribute". :-(


I don’t know how to interpret this output, it is not a rotating plate
disk, but flash. Too many unknowns. It doesn’t seem likely that there
are bad sectors, though, which is what I was expecting to find.

> Almost forgot:
> When I press Enter on that one paused terminal that I described in the
> beginning, the very next line that it prints out is 'Out of Memory".
> Then other stuff is displayed, and then the desktop is loaded.

Out of memory? What could it be?

How much RAM do you have?

The swap partition looks small to me.

On 2014-02-14 22:46, helaughsatfear wrote:

> Just in case, here is the output of “lsblk -o
> NAME,SIZE,TYPE,FSTYPE,MOUNTPOINT,PARTLABEL,LABEL,HCTL”:
>
> http://paste.opensuse.org/17d26543

Well, thanks. Nice to see.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

8G of ram on the laptop.

Just installed all needed updates in Yast2. That included kernel 3.11.10-7 update.
Nothing changed.

This is just a note. RAID 0 is the most dangerous RAID configuration. It is called striping. If anything goes wrong with either of your drives all data is lost very very small chance to recover anything. I don’t think that is the problem here but just a word to the wise .

Since you had a kernel upgrade al ot could have changed LOL

Try booting to the previous kernel and see if there is still a problem. Select advanced at the boot screen and then the older (lower number) kernel

Please let us know your findings

Thank you gogalthorp! I am not a fan of RAID0 at all, it was a default set up which also included OEM windows. I doubt i could have kept windows if I disabled RAID0.

I tried the older kernel, and it was the same thing.
It froze on the chameleon. I pressed ESC. Other terminal displayed the following:

RAID set "isw_chfijbfgbc_HDD0" was activated
The dynamic shared library "libdmraid-events-isw.so" could not be loaded:
    libdmraid-events-isw.so: cannot open shared object file: No such file or directory

Trying manual resume from /dev/disk/by-id/raid-isw_chfijbfgbc_HDD0-part6
Invoking userspace resume from /dev/disk/by-id/raid-isw_chfijbfgbc_HDD0-part6
resume: libgcrypt version 1.5.3
Trying manual resume from /dev/disk/by-id/raid-isw_chfijbfgbc_HDD0-part6
Invoking userspace resume from /dev/disk/by-id/raid-isw_chfijbfgbc_HDD0-part6
Waiting  for device /dev/mapper/raid-isw_chfijbfgbc_HDD0_part7 to  appear:.....................Could not find  /dev/mapper/isw_chfijbfgbc_HDD0_part7.
Want me to fall back to /dev/disk/by-id/raid-isw_chfijbfgbc_HDD0_part7? (Y/n)

I pressed Ctrl + Alt + F1
Maybe I will just have to get used to this new set up?

On 2014-02-15 00:16, helaughsatfear wrote:
>
> 8G of ram on the laptop.

So, with 2 GB swap, you can not hibernate the machine. Just sleep, if it
works (and some machines can not sleep, only hibernate).

> Just installed all needed updates in Yast2. That included kernel
> 3.11.10-7 update.
> Nothing changed.

What repos are you using?
You get that from the output of “zypper lr --details”.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

On 2014-02-15 00:36, gogalthorp wrote:
>
> This is just a note. RAID 0 is the most dangerous RAID configuration. It
> is called striping. If anything goes wrong with either of your drives
> all data is lost very very small chance to recover anything. I don’t
> think that is the problem here but just a word to the wise .

I agree that raid 0 is dangerous, but… how do you know it is raid 0? I
thought he was using raid 1, with dmraid. Did I miss something :-?


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

After loading the older kernel, it loaded into the CLI login. Specifically:
When I pressed Ctrl + ALt + F1 and then Enter, it gave the following message before loading to the CLI login prompt:

[951.640269] systemd-gpt-auto-generator[1565]: Out of memory
[951.643768] systemd[1]: /usr/lib/systemd/system-generators/systemd-gpt-auto-generator exited with exit status 1.

then it displayed some “OK’s”
OK ]
OK ]
OK ]
OK ]
and then:
“Welcome to openSUSE 13.1 “Bottle” - Kernel 3.11.6-4-desktop (tty1)”
linux-c7hs login:

And I login.

This looks like a bug in mkinitrd and really deserves bug report so it can be properly investigated.

On 2014-02-15 00:44, Carlos E. R. wrote:
> On 2014-02-15 00:36, gogalthorp wrote:
>>
>> This is just a note. RAID 0 is the most dangerous RAID configuration. It
>> is called striping. If anything goes wrong with either of your drives
>> all data is lost very very small chance to recover anything. I don’t
>> think that is the problem here but just a word to the wise .
>
> I agree that raid 0 is dangerous, but… how do you know it is raid 0? I
> thought he was using raid 1, with dmraid. Did I miss something :-?

Finally, I found it.

> Just so you know, I have RAID0 configuration with 2 SSDs. Windows works

(2014-02-14 22:36)


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Sorry for the delay.
Whats the best way to resize the SWAP partition, and what size do you recommend?
The reason I ask, is because when I started Yast2 partitioner it says “Never partition disks that may, in any way, be in use (mounted, swap, etc.) unless you know exactly what you are doing.” I certainly dont know exactly what I am doing. :\

lazarev@linux-c7hs:~> zypper lr --details
#  | Alias                     | Name                               | Enabled | Refresh | Priority | Type   | URI                                                             | Service
---+---------------------------+------------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
 1 | Packman Repository        | Packman Repository                 | Yes     | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.1/        |        
 2 | SuSE                      | SuSE                               | Yes     | Yes     |   99     | rpm-md | http://download.videolan.org/SuSE/13.1/                         |        
 3 | libdvdcss repository      | libdvdcss repository               | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.1/                            |        
 4 | openSUSE-13.1-1.10        | openSUSE-13.1-1.10                 | No      | Yes     |   99     | yast2  | hd:///?device=/dev/sdc2                                         |        
 5 | repo-debug                | openSUSE-13.1-Debug                | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/13.1/repo/oss/  |        
 6 | repo-debug-update         | openSUSE-13.1-Update-Debug         | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.1/                 |        
 7 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.1-non-oss/         |        
 8 | repo-non-oss              | openSUSE-13.1-Non-Oss              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/non-oss/    |        
 9 | repo-oss                  | openSUSE-13.1-Oss                  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/        |        
10 | repo-source               | openSUSE-13.1-Source               | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/13.1/repo/oss/ |        
11 | repo-update               | openSUSE-13.1-Update               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1/                       |        
12 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1-non-oss/               |        
 
 

Well the good thing is that I am learning a LOT from all of this.

By the way, If I use the advanced menu and go to recovery mode, and then press Ctrl + Alt + F1 and then Enter it loads into the desktop, but if i just let it load regularly and I press Ctrl + Alt + F1 and then Enter, it loads into the CLI login prompt :stuck_out_tongue:

I might need to start thinking about a reinstall.

You need to do it off line ie from a live CD/DVD or other operating system. You also need to have the space to expand since partition must be a continues set of blocks. That may require resizing and moving of other partition. Note any time you play with partitions your data is at risk if there is a power failure or other interruption of the processes So back up is highly recommended

You can have more then one swap mounted at one time so you can have two or more swap partitions. But I’m not sure they can be used for suspend to disk if they are not a single continuous partition. Suspend uses compression so you need at minimum 60% the amount of RAM but it is normal to use at least the amount of RAM + a bit more.