12.2 - freeze on boot

I have a problem and have no idea what’s wrong. I experienced plasma crash so I restarted and since then, I can’t boot into X, it just freezes and shows no error. Even if I boot with ‘debug initcall_debug’, it just loads as usual, shows all the output with OK and then it freezes without any error.
In recovery mode, I can boot into terminal, but if I try to launch X, it freezes again, no error.

I have 12.2 x86, kernel 3.4, KDE 3.7

Thanks for any help!

Most probably your video drivers are corrupted. Provide some details of your /var/log/messages and /var/log/Xorg.log. Maybe by adding the command nomodeset at the boot screen you’ll be able to get into a graphic console. Can you try it?

nomodest didn’t work.

So I tried to boot regularly, after it froze I booted to rescue mode and the logs look like this: /var/log/messages and Xorg.0.log.

I might add that I run on an Optimus laptop (integrated graphics + dedicated nvidia).

What I would try would be to create a new user via YAST, login and see if that is working. That would confirm that your kde profile for the original user is corrupted.

found this in another thread, try to see if it exists and then remove it as it seems that it helped someone else:

su -c 'rm /home/YOURUSERNAMEHERE/.kde4/share/config/plasm* '

I’m sorry I didn’t write sooner, I was busy and forgot about this thread.
It was not a problem in KDE config, because it behaved the same for more users. I could not find any solution, so I decided to upgrade to 12.3 (I know, very clever with broken system :slight_smile: ), which actually worked and I am now able to boot OK with nomodeset. Everything seems to be alright except openGL doesn’t work, but I guess I’ll be able to fix that…