12.1 ralink rt3090 can't activate device

hello there,

I can’t get my wireless to work. the device is a ralink rt3090 in a netbook.
the kernel driver is rt2800pci with the newest kernel from the stable 12.1 repo.
the wired connection works fine.

everything seems to be fine, in /var/log/boot.msg are no entries.

when I try to activate the wireless device in the kde network manager, the device instantly deactives itself.

edit: terminal output

/usr/sbin/hwinfo --wlan
24: PCI 300.0: 0282 WLAN controller
[Created at pci.319]
Unique ID: y9sn.dgDxtmXrasA
Parent ID: AKhP.FZg9Z3lH594
SysFS ID: /devices/pci0000:00/0000:00:15.2/0000:03:00.0
SysFS BusID: 0000:03:00.0
Hardware Class: network
Model: “RaLink RT3090 Wireless 802.11n 1T/1R PCIe”
Vendor: pci 0x1814 “RaLink”
Device: pci 0x3090 “RT3090 Wireless 802.11n 1T/1R PCIe”
SubVendor: pci 0x17aa “Lenovo”
SubDevice: pci 0xf101
Driver: “rt2800pci”
Driver Modules: “rt2800pci”
Device File: wlan0
Features: WLAN
Memory Range: 0xf0100000-0xf010ffff (rw,non-prefetchable)
IRQ: 18 (no events)
HW Address: e4:d5:3d:7e:91:fb
WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484
WLAN encryption modes: WEP40 WEP104 TKIP CCMP
WLAN authentication modes: open sharedkey wpa-psk wpa-eap
Module Alias: “pci:v00001814d00003090sv000017AAsd0000F101bc02sc80i00”
Driver Info #0:
Driver Status: rt2800pci is active
Driver Activation Cmd: “modprobe rt2800pci”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #14 (PCI bridge)

On 04/05/2012 05:16 AM, sonomabob wrote:
>
> hello there,
>
> I can’t get my wireless to work. the device is a ralink rt3090 in a
> netbook.
> the kernel driver is rt2800pci with the newest kernel from the stable
> 12.1 repo.
> the wired connection works fine.
>
> everything seems to be fine, in /var/log/boot.msg are no entries.
>
> when I try to activate the wireless device in the kde network manager,
> the device instantly deactives itself.
>
> edit: terminal output
>
> /usr/sbin/hwinfo --wlan
> 24: PCI 300.0: 0282 WLAN controller
> [Created at pci.319]
> Unique ID: y9sn.dgDxtmXrasA
> Parent ID: AKhP.FZg9Z3lH594
> SysFS ID: /devices/pci0000:00/0000:00:15.2/0000:03:00.0
> SysFS BusID: 0000:03:00.0
> Hardware Class: network
> Model: “RaLink RT3090 Wireless 802.11n 1T/1R PCIe”
> Vendor: pci 0x1814 “RaLink”
> Device: pci 0x3090 “RT3090 Wireless 802.11n 1T/1R PCIe”
> SubVendor: pci 0x17aa “Lenovo”
> SubDevice: pci 0xf101
> Driver: “rt2800pci”
> Driver Modules: “rt2800pci”
> Device File: wlan0
> Features: WLAN
> Memory Range: 0xf0100000-0xf010ffff (rw,non-prefetchable)
> IRQ: 18 (no events)
> HW Address: e4:d5:3d:7e:91:fb
> WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
> WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447
> 2.452 2.457 2.462 2.467 2.472 2.484
> WLAN encryption modes: WEP40 WEP104 TKIP CCMP
> WLAN authentication modes: open sharedkey wpa-psk wpa-eap
> Module Alias: “pci:v00001814d00003090sv000017AAsd0000F101bc02sc80i00”
> Driver Info #0:
> Driver Status: rt2800pci is active
> Driver Activation Cmd: “modprobe rt2800pci”
> Config Status: cfg=no, avail=yes, need=no, active=unknown
> Attached to: #14 (PCI bridge)

Are there any pertinent messages in the output of the ‘dmesg’ command? That is
not the same as boot.msg. In addition, if you use systemd, boot.msg is empty.

Are there any pertinent messages in the output of the ‘dmesg’ command? That is
not the same as boot.msg. In addition, if you use systemd, boot.msg is empty.

doesn’t seem so. heres the output: dmesg output for diagnostic - Pastebin.com

interesting seems the last line, it appeared after i tried to aktivate the card.

On 04/05/2012 12:36 PM, sonomabob wrote:
>
>> Are there any pertinent messages in the output of the ‘dmesg’ command?
>> That is
>> not the same as boot.msg. In addition, if you use systemd, boot.msg is
>> empty.
>
> doesn’t seem so. heres the output: ‘dmesg output for diagnostic -
> Pastebin.com’ (http://pastebin.com/QWeW0DzF)
>
> interesting seems the last line, it appeared after i tried to aktivate
> the card.

From the dmesg output, suspend/resume is clearly not working. It would be
better if you do not suspend or hibernate until the device is working.

The section of the output prior to suspending shows no errors.

okay, then i will avoid suspending.

but that still does not help with my actual problem. could the kde networkmanager be the problem? i read something like that in another forum.

I just tried to set the network settings in yast with ifup. didn’t change anything - wired works, wireless not.

On 04/05/2012 01:56 PM, sonomabob wrote:
>
> I just tried to set the network settings in yast with ifup. didn’t
> change anything - wired works, wireless not.

OK, it doesn’t work. We still need some additional diagnostic information.

Please go back to NM, and try the connection. Please report what happens, then
post the output from the following:


/usr/sbin/iwconfig
sudo /usr/sbin/iwlist scan
/usr/sbin/rfkill list

If rfkill is not a valid command, then hook up your network and ‘sudo zypper
install rfkill’ and then repeat.

ok, thank you, here you go:

/usr/sbin/iwconfig 
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on

sudo /usr/sbin/iwlist scan
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wlan0     Interface doesn't support scanning : Network is down
/usr/sbin/rfkill list
0: ideapad_wlan: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
1: ideapad_bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no
2: acer-wireless: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
3: phy0: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
4: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

now after trying to activate it.

/usr/sbin/iwconfig 
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on

second one is mine

sudo /usr/sbin/iwlist scan
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: 30:39:F2:37:BE:26
                    Channel:3
                    Frequency:2.422 GHz (Channel 3)
                    Quality=41/70  Signal level=-69 dBm  
                    Encryption key:on
                    ESSID:"Animes:9000"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=000000009a8f318c
                    Extra: Last beacon: 460ms ago
                    IE: Unknown: 000B416E696D65733A39303030
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030103
                    IE: Unknown: 2A0100
                    IE: Unknown: 2F0100
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 32040C121860
                    IE: Unknown: 2D1A6C181BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D1603080000000000000000000000000000000000000000
                    IE: Unknown: DD720050F204104A00011010440001021041000100103B000103104700104D083613628876911F8C86428BA4343110210007506972656C6C69102300064469736375731024000630303030303110420004303030311054000800060050F204000110110009506972656C6C694150100800020080
                    IE: Unknown: DD090010180200F0050000
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
                    IE: Unknown: DD1E00904C336C181BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: DD1A00904C3403080000000000000000000000000000000000000000
          Cell 02 - Address: 00:26:44:1D:A7:A5
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=41/70  Signal level=-69 dBm  
                    Encryption key:on
                    ESSID:"PRLINK_Buchner"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000000b8bbcc185
                    Extra: Last beacon: 1151ms ago
                    IE: Unknown: 000E50524C494E4B5F427563686E6572
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030101
                    IE: Unknown: 050402030000
                    IE: Unknown: 2A0100
                    IE: Unknown: 2F0100
                    IE: Unknown: 32040C121860
                    IE: Unknown: DD060010180200F0
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK

/usr/sbin/rfkill list
0: ideapad_wlan: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: ideapad_bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no
2: acer-wireless: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
3: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
4: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

btw, I use the networkmanager popup in the taskbar, if that makes any difference. another btw, suspending seems no more to cause errors, yast automatically installed ndiswrapper as fix.

“ideapad” and “acer-wireless”?

I guess that you have a mild version of the problem that
the kernel module for acer laptops and wireless devices is loaded on laptops of other brands
including Lenovo devices.
Compare:
Threads tagged with [i]acer-wmi

You may check if acer-wmi is loaded by

lsmod | grep acer*

.

Regards
Martin

okay. next problem: I blacklisted the acer_wmi in

sudo nano /etc/modprobe.d/50-blacklist.conf
blacklist acer_wmi

then I rebooted and now I cant even try to activate the wlan device. In the popup menu it’s now grayd out.
now rfkill says

/usr/sbin/rfkill list
0: ideapad_wlan: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: ideapad_bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no
3: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes
5: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

how to solve that one?

I found this thread: https://bbs.archlinux.org/viewtopic.php?id=122601

are there any workarounds?

btw this machine is a small lenovo ideapad s205 bought a few weeks ago.

On 06.04.2012 13:46, sonomabob wrote:
>
> okay. next problem: I blacklisted the acer_wmi in
>
>
> Code:
> --------------------
> sudo nano /etc/modprobe.d/50-blacklist.conf
> --------------------
>
>
> Code:
> --------------------
> blacklist acer_wmi
> --------------------
>
>
> then I rebooted and now I cant even try to activate the wlan device. In
> the popup menu it’s now grayd out.
> now rfkill says
>
> Code:
> --------------------
> /usr/sbin/rfkill list
> 0: ideapad_wlan: Wireless LAN
> Soft blocked: no
> Hard blocked: no
> 1: ideapad_bluetooth: Bluetooth
> Soft blocked: no
> Hard blocked: no
> 3: phy0:
> Soft blocked: no
> Hard blocked: yes
> 5: hci0: Bluetooth
> Soft blocked: no
> Hard blocked: no
> --------------------
>
>
>
> how to solve that one?
>
>
“Wireless LAN …] Hard blocked: yes” → Please look for a hardware
switch anywhere on your lenovo ideapad s205 (on the right side between
the mic out and HDMI) and try to turn your wlan switch on…

On 06.04.2012 13:56, sonomabob wrote:
>
> I found this thread: https://bbs.archlinux.org/viewtopic.php?id=122601
>
> are there any workarounds?
>
>
> btw this machine is a small lenovo ideapad s205 bought a few weeks ago.
>
>
If there is no (real) hardware switch working with linux you might try
to boot in the operating system that was installed by the
seller/manufactor (e. g. Microsoft W7), activate the WLAN there and boot
into openSUSE after that.

Good luck!
Martin

yes, the hardware switch is on, I have never touched it and checked the position.
the trick with windows is worth a try, but if I remember correctly, the last time I booted windows the wireless was on. Unfortunately windows doesn’t boot any more (grub says something like disk read error) at the moment and I currently have no recovery disk at hand. I will try/check if it is activated in windows, as soon as I get my recovery disk.

If that doesn’t work, I will have to uninstall linux and use windows again. I bought that netbook for my studies and wanted to use linux for a change. If the hardware switch doesn’t work on linux, linux is not usable on that machine :frowning: I doubt that another distro makes a change.

thank you for your help everybody, the original problem was solved :slight_smile: (wierd thing, acer drivers loaded on non acer laptops)

I will report back if it worked with windows.

wireless is working now! just got it a few minutes ago to work. this did the trick: (first post, point 3.) Be aware if you are thinking of buying a Lenovo Ideapad S205 netbook! - PCMech Forums

I am not sure, but I seem to suffer from the random disconnects that some other users already have reported. I will have to test longer to be sure about that.

thanks again!

So you went in the BIOS, disabled and enabled the wireless LAN.
Thanks for reporting.
Martin

In my case I simply blacklisted acer_wmi.

  1. create a file
    /etc/modprobe.d/blacklist.conf (you can use any other name)
  2. add a line
    blacklist acer_wmi

Tip: If you don’t want to blacklist anything just remove manually acer_wmi module (rmmod acer_wmi) your wireless will immediately appear in Network Manager.