11.4 resume problems from s2ram Thinkpad R51


I do have problems getting my R51 back from suspend. I have tried all hints from Suspend to RAM
HCL:IBM Lenovo laptops - openSUSE and
Problem with display remaining black after resume - ThinkWiki

… without luck. Disabling frame-buffer did not work but see below.

Basically after resume my screen is messy. There are areas which show scatter others work well. Rest of the computer reacts “normal”. Restart of X doesn’t help, but reload radeon module does the trick, so I found the following:

After init 3 and rmmod radeon he tells me:

linux-wjf9:~ # init 3
linux-wjf9:~ # rmmod radeon
ERROR: Module radeon is in use

so I did :

linux-wjf9:~ # rmmod -f radeon; sleep1 ; modprobe radeon

and voila - init 5 or gmd or X restart → everything works fine until the next suspend.


I think the problem is the radeon module: “reinit after the s2ram” and the frame-buffer on the console does prevent me - and maybe s2ram - to “refresh” properly. Correct?

Ok so next I tried is to disable Frame Buffer, but that does not work at all.

Kernel parameter vga=0 or vga=normal does not work as expected - First it works as expected text mode resolution is 80x25, but after some seconds the initramdisk does switch resolution of console again! I hate to say but it looks like OpenSuSe (again) thinks it is more clever than the user …

Since rmmod says “ERROR: Module radeon is in use” again, like before, I do think that somehow SuSe ignores my vga=0 …

Any ideas on this?

some Info from the radeon module:

linux-wjf9:~ # dmesg|grep -i "radeon"
    2.121714] [drm] radeon defaulting to kernel modesetting.
    2.121719] [drm] radeon kernel modesetting enabled.
    2.126712] radeon 0000:01:00.0: power state changed by ACPI to D0
    2.126911] radeon 0000:01:00.0: power state changed by ACPI to D0
    2.126925] radeon 0000:01:00.0: PCI INT A -> Link[LNKA] -> GSI 11 (level, low) -> IRQ 11
    2.139330] radeon 0000:01:00.0: putting AGP V2 device into 4x mode
    2.139355] radeon 0000:01:00.0: GTT: 256M 0xD0000000 - 0xDFFFFFFF
    2.139365] radeon 0000:01:00.0: VRAM: 128M 0x00000000E0000000 - 0x00000000E7FFFFFF (32M used)
    2.139393] [drm] radeon: irq initialized.
    2.140678] [drm] radeon: 32M of VRAM memory ready
    2.140682] [drm] radeon: 256M of GTT memory ready.
    2.141631] radeon 0000:01:00.0: WB disabled
    2.144069] [drm] radeon: ring at 0x00000000D0001000
    2.144306] [drm] radeon: ib pool ready.
    2.144755] [drm] Radeon Display Connectors
    2.153037] [drm] radeon: power management initialized
    2.237814] fb0: radeondrmfb frame buffer device
    2.237824] [drm] Initialized radeon 2.7.0 20080528 for 0000:01:00.0 on minor 0 

s2ram diag:

linux-wjf9:~ # s2ram -n
Machine matched entry 563:
    sys_vendor   = 'IBM'
    sys_product  = ''
    sys_version  = 'ThinkPad R51'
    bios_version = ''
Fixes: 0x0  
This machine can be identified by:
    sys_vendor   = "IBM"
    sys_product  = "1829L7G"
    sys_version  = "ThinkPad R51"
    bios_version = "1RETCDWW (3.06f)"

pci info:

linux-wjf9:~ # lspci
00:00.0 Host bridge: Intel Corporation 82855PM Processor to I/O Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 82855PM Processor to AGP Controller (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV250 [Mobility FireGL 9000] (rev 02)
02:00.0 CardBus bridge: Texas Instruments PCI4520 PC card Cardbus Controller (rev 01)
02:00.2 FireWire (IEEE 1394): Texas Instruments Device 802a (rev 01)
02:01.0 Ethernet controller: Intel Corporation 82540EP Gigabit Ethernet Controller (Mobile) (rev 03)
02:02.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)

Any Help? thanks in advance!

Modesetting via the kernel (the problem I related to the Framebuffer stuff) can be disabled via another boot parameter: nomodeset.

This disables vesa modes in vt1-6 but solves my problem with s2ram.

Does anyone has a solution for both?