11.4 KDE 4.6 - All images print inverted (white on black)

Just updated to OpenSuSE 11.4 with KDE 4.6

Platform Version 4.6.00 (4.6.0) "release 6"

and found a weird printing issue.

When I print to my HP LaserJet 1020 - which has worked fine since OpenSuSe 10.x to OpenSuse 11.3, any images print inverted.

For example, what is white in the image is printed black, and what is black in the image is printed white. When printing a document from LibreOffice, text on the same page as the image prints correctly.

I’ve checked that this is happening when printing images from LibreOffice, Okular, and Gimp, and tried it with PNG, TIF, and GIF image formats.

However, when I open HPLIP and send a test print through, it prints correctly - text and images all normal.

I have no idea where to go looking to fix this :\


I want to know your driver about HP maybe it needs to change it.

Not too sure what you mean, but here are the versions of the software:
HPLIP 3.11.1

  • Device Manager 15.0 (QT4)
    HPCUPS 3.10.2.rc1.9

Does that help?

Could you send me a picture to see?

Also read that HowTo Install a HP LaserJet 1020 printer in Suse 10.x, 11.x

I had a similar problem trying to print to my HP Photosmart Premium C410, which is an inkjet All-In-One.
BTW, it has a built-in duplexer, and printing even test pages came out “wrong” with the bottom inch or so
of the page reprinted several times down the back side of the sheet.

I was able to resolve some of my problems by using YaST2 to change the driver from the CUPS HP driver to the “real” HP driver,
i.e. similar name and version number, but without the “CUPS” designation. No, I don’t know why/how that did the trick, but it did.

Ironically, I’d had some problems with printing late in the 11.3 lifetime and the newest hplip stuff hadn’t been packaged into an RPM
for 11.3, so I downloaded and installed that same driver (3.11.1) directly from the hplip project by using their “.run” file. BUT, I don’t
recall having had a problem with that installation’s “CUPS” driver per se. I ended up doing a ‘zypper dup’ to upgrade to 11.4, and that
failed miserably, so I had to do a fresh install of 11.4, and it came with the hplip 3.11.1 bits in an rpm. Getting all of the settings to
work properly with the duplexer is still a headache (seems us Yanks have to use special “Letter Duplex” paper size), but it does work.

I thing it is drivers’ fault. Wishlist Drivers - openSUSE

Still no progress on this.
Here is what I get when I print a graphic image (png)
When I look at this image in LibreOffice, Gimp or Okular (or anything else) it looks like this:

Text only pages print fine. Pages with text and graphics print the graphics like above and the text fine.

I’ve tried change drivers between hpcups and hpijs and hplip. All produce identical results.

The information on printing under OpenSuse 10.x and 11.x was not helpful, as I mentioned earlier the printer has worked fine on all suse versions since 10.1 and up to and including 11.3.

Anyone have any other ideas?

I found this reported:


Anyway, the suggestion I’ve seen is to use the hpijs driver instead, although you claim that this doesn’t work for you.

Maybe report it here:




Thanks for that info.

I went back and tried the hpijs driver again, and now its printing correctly. Maybe I didn’t select it properly last time or something. Anyway its fixed now.

Thanks for the update. It might help others too. :slight_smile:

Same problem here. Selected alternative driver in YaST and problem fixed.

One other observation is that a fresh install of 11.4 loaded HPLIPS version 3.11.1. Could not complete driver installation due to error message. Managed to fix this error by searching for a newer version of HPLIPS, 3.11.3.

Hello GransRemedy,
I have the same problem with my HP printer (HP Laser Jet P2015 dn) after updating to SUSE 11.4. Can you tell more detailed how to try hpijs driver? Thank you.

Hi YeboElectronics,
I search HPLIP and HPLIP-HPIJS in Software Manageer - YaST (as superuser) and it only shows version of 3.11.1-6.1. How to get the newer version such as 3.11.3 as you say? Thanks.

Search for HPLIP in yast (software management). It should return these two packages: hplip and hplip-hpijs. Install them both. Then in Yast’s printer config, select the hpijs driver from the list of drivers.

You can do it by CUPS too
in browser
->choose printer
->change printer
->continue (or change description and lociation)
->from model choose hpijs drv from the list and perss change printer