11.3 KDE can't mount anything

Hi everyone, this is a fresh install of openSUSE 11.3 KDE 64 bit. I can’t mount any drives at all. They work fine in the gnome version. The drives are NTFS, some EXT4, and all CD/DVD drives. The drives show up in Dolphin but when I go to access them I get this error message;

“an error occurred while accessing ‘drive name’, the system responded: org.freedesktop.Hal.Device PermissioinDeniedByPolicy: org.freedesktop.hal.storage.mount-fixed auth_admin_keep_always”

Help!

Could you post some information about your system using these commands? Open a Terminal session and enter the following commands, then copy and past the information into a message here:

cat /etc/fstab
su -
password:
fdisk -l

Here is an example of what you get:

james@linux-ew60:~> cat /etc/fstab
/dev/disk/by-id/ata-WDC_WD6000HLHX-01JJPV0_WD-WXA1C20K0415-part1 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-WDC_WD6000HLHX-01JJPV0_WD-WXA1C20K0415-part2 /                    ext4       acl,user_xattr        1 1
/dev/disk/by-id/ata-ST32000641AS_9WM0BWE8-part1 /Windows             ntfs-3g    defaults 0 0
/dev/disk/by-id/ata-WDC_WD6000HLHX-01JJPV0_WD-WXA1C20K0415-part3 /home                ext4       defaults              1 2
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
/dev/disk/by-id/usb-ST315005_41AS_0123456789ABCDEF-0:0-part1 /Software            ntfs-3g    defaults 0 0
james@linux-ew60:~> su -
Password: 
linux-ew60:~ # fdisk -l

Disk /dev/sda: 2000.4 GB, 2000397852160 bytes
255 heads, 63 sectors/track, 243201 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x4cbc9c09

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1      243202  1953512448    7  HPFS/NTFS

Disk /dev/sdb: 600.1 GB, 600127266816 bytes
255 heads, 63 sectors/track, 72961 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x46f71f1a

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1         262     2104483+  82  Linux swap / Solaris
/dev/sdb2   *         263       19092   151251975   83  Linux
/dev/sdb3           19093       72962   432705294   83  Linux

Disk /dev/sdc: 1500.3 GB, 1500301910016 bytes
255 heads, 63 sectors/track, 182401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes                                                                                                         
I/O size (minimum/optimal): 512 bytes / 512 bytes                                                                                                             
Disk identifier: 0x0009698d                                                                                                                                   
                                                                                                                                                              
   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1               1      182402  1465136128    7  HPFS/NTFS

Notice how I put each item inside a code block? Just select each portion for the code block while in the advanced message editor, then press the code button “#”. This then tells what you are or could be doing in openSUSE.

Thank You,

I should mention that I just tried running Dolphin as admin and I can access the drives. From regular user, no love. I could even live with that if I didn’t have to change permissions for everything I copy over. Here’s what you asked for. Much thanks, I don’t want to go back to gnome, but I will if I have to. BTW, the system is fully updated.

cat /etc/fstab
/dev/disk/by-id/ata-ST330630A_3CK0BHQK-part2 swap swap defaults 0 0
/dev/disk/by-id/ata-ST330630A_3CK0BHQK-part1 / ext4 acl,user_xattr 1 1
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0


fdisk -l

Disk /dev/sdb: 30.6 GB, 30606151680 bytes
255 heads, 63 sectors/track, 3720 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x69205244

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 3452 27728158+ 83 Linux
/dev/sdb2 3453 3720 2152710 82 Linux swap / Solaris

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xfd415c99

Device Boot Start End Blocks Id System
/dev/sda1 * 1 9487 76195840 83 Linux
/dev/sda2 9487 9730 1951745 5 Extended
/dev/sda5 9487 9730 1951744 82 Linux swap / Solaris

Check the removable media configuration in System Settings > Advanced >… (It is not hard to navigate). Make sure that ‘Enable automatic mounting of removable media’ is checked.

Well, that fixed the removable drive issue. I still get the same error trying to mount internal drives from Dolphin as ordinary user.

Internal (more correctly SATA) disk partition mounting is handled during the boot scripts according to entries contained in /etc/fstab

The easiest way to configure or adjust partition access permissions is via Yast > System > Partitioner

Some reading for you:

SDB:Basics of partitions, filesystems, mount points - openSUSE

http://www.linuxtopia.org/online_books/opensuse_guides/opensuse11.1_reference_guide/sec_yast2_i_y2_part_expert.html

http://opensuse.swerdna.org/susentfs.html

Take care when making any system changes, as you don’t want to edit a partition so that the data is destroyed or inaccessable.

OK, thanks for the reply. I’m familiar with fstab but I thought that the automounting of drives no longer required fstab entries. Or is that only valid in gnome? I can access the drives as administrator in Dolphin but get the permission denied message as ordinary user. And the drives operate normally in opensuse 11.3 gnome.

OK, thanks for the reply. I’m familiar with fstab but I thought that the automounting of drives no longer required fstab entries.

The automounting really applies to removable media devices. SATA hard disks will still be mounted by the system at boot via entries in /etc/fstab. You can edit this file directly if necessary (or use the yast partitioner tool to tweak settings).

Can it be done in the kde4 personal settings- system administration-actions policy?

Here’s a new wrinkle. If I open Dolphin as admin and access the drives then I can go to my regular user account and the drives will mount. So, what is going on in that process that I can create without the extra step?

Well, it seems to be a permissions problem. I can’t edit fstab except as root, but root can already mount the drives so that doesn’t help. So how do I go about adding myself so I can access the drives? I looked at the policy settings but those can’t be changed either. Kinda reminds my why I used to run everything as root.

Actually, conram you may be correct. Buried deep, I have

System Settings > Advanced > System Policies > Actions Policy > org.freedsktop > The udisk Project

Here you can set the authorisation for ‘Mount a device’, ‘Mount a system-internal device’ etc

Maybe that has something to do with it.

I can’t edit fstab except as root

Thats normal. System files require root privileges to edit. I think you would benefit from reading this

Concepts security - openSUSE

Kinda reminds my why I used to run everything as root.

Not good practice. You need to get yourself in the habit of distinguishing admin tsaks from using the dekstop for user tasks.

If you really need to do something (like editing a system file) within a graphical desktop environment, then use the kdesu command.

Well, uh yes, I realize all that. It was joke. These minor things can get frustrating. I found a solution however, thanks for the help. Here is what I did; polkit-auth --grant org.freedesktop.hal.storage.mount-fixed --user your_user_name. Worked like a charm. I couldn’t change the settings you discussed above but this I think did the same thing. Removable drives were already set up this way.

The easy way!

Go on “Personal Settings/Removable Devicens” select “Enable automatic…” choose what device to automount.

Reboot!rotfl!

Hello.

I seem to have similar problem, but I’m using openSUSE 11.4. As I remember, in openSUSE 11.3 mounting worked well. But not in current version. The problem is when trying to mount a flash with NTFS. I have set up environment so I can easily mount such flash in the konsole. However when I try to mount flash using graphic interface (applet or dolphin) I get the following error

org.freedesktop.UDisks.Error.Failed: Error mounting: mount exited with exit code 1: helper failed with: Error opening ‘/dev/sdb1’: Permission denied Failed to mount ‘/dev/sdb1’: Permission denied Please check ‘/dev/sdb1’ and the ntfs-3g binary permissions, and the mounting user ID. More explanation is provided at NTFS-3G Questions at Tuxera

I think it’s necessary to adjust actions policy, but what exactly should I change?

Hello.

I seem to have similar problem, but I’m using openSUSE 11.4. As I remember, in openSUSE 11.3 mounting worked well. But not in current version. The problem is when trying to mount a flash with NTFS. I have set up environment so I can easily mount such flash in the konsole. However when I try to mount flash using graphic interface (applet or dolphin) I get the following error

org.freedesktop.UDisks.Error.Failed: Error mounting: mount exited with exit code 1: helper failed with: Error opening ‘/dev/sdb1’: Permission denied Failed to mount ‘/dev/sdb1’: Permission denied Please check ‘/dev/sdb1’ and the ntfs-3g binary permissions, and the mounting user ID. More explanation is provided at NTFS-3G Questions at Tuxera

I think it’s necessary to adjust actions policy, but what exactly should I change?
Can you provide us wit the exact mount command you are using and if you are trying this as a normal user or as a root user? Is this in a script file or just how are you doing this command in a graphic session?

Thank You,

Hello.

I seem to have similar problem, but I’m using openSUSE 11.4. As I remember, in openSUSE 11.3 mounting worked well. But not in current version. The problem is when trying to mount a flash with NTFS. I have set up environment so I can easily mount such flash in the konsole. However when I try to mount flash using graphic interface (applet or dolphin) I get the following error

org.freedesktop.UDisks.Error.Failed: Error mounting: mount exited with exit code 1: helper failed with: Error opening ‘/dev/sdb1’: Permission denied Failed to mount ‘/dev/sdb1’: Permission denied Please check ‘/dev/sdb1’ and the ntfs-3g binary permissions, and the mounting user ID. More explanation is provided at NTFS-3G Questions at Tuxera

I think it’s necessary to adjust actions policy, but what exactly should I change?

Hello.

I seem to have similar problem, but I’m using openSUSE 11.4. As I remember, in openSUSE 11.3 mounting worked well. But not in current version. The problem is when trying to mount a flash with NTFS. I have set up environment so I can easily mount such flash in the konsole. However when I try to mount flash using graphic interface (applet or dolphin) I get the following error

org.freedesktop.UDisks.Error.Failed: Error mounting: mount exited with exit code 1: helper failed with: Error opening ‘/dev/sdb1’: Permission denied Failed to mount ‘/dev/sdb1’: Permission denied Please check ‘/dev/sdb1’ and the ntfs-3g binary permissions, and the mounting user ID. More explanation is provided at NTFS-3G Questions at Tuxera

I think it’s necessary to adjust actions policy, but what exactly should I change?
So you must forgive me but the statement “mount a flash with NTFS” does not make any sense to me. Flash, normally a way to display media content in a browser such as Firefox does not seem to connect to NTFS, a type of disk partition normally created by Microsoft Windows. I can confirm that when you mount a NTFS partition in your fstab file, something that may have been done automatically for you during an openSUSE installation, the default setup there may not provide proper access to file content due to a problem in how Linux permissions work on an NTFS hard drive. Normally I just edit the fstab file and change the parameters to just **defaults **which can make an incredible differences in the usability of files on a NTFS partition. In KDE, to edit your fstab file enter the menu Run Command:


kdesu kwrite /etc/fstab

Here is an example of what I mean for my NTFS partition. Look at the defaults setting and compare it to what you might have there:

/dev/disk/by-id/ata-Hitachi_HDS721010CLA332_JP9921HD2SSJLH-part1  /Windows             ntfs-3g    defaults                              0 0

You must restart openSUSE for changes made here to take effect.

Thank You,

I’ll try to describe my problem in other words.
I have the right fstab file and I also have the right permissions for /usr/bin/ntfs-3g. I can mount removable media device with NTFS as a user from konsole typing “mount /media/flash”. But when I try to mount the same device from dolphin I get error described above. I got this error in konsole before I set proper permissions for /usr/bin/ntfs-3g.