[11.2] Keyboard not working after resume from Suspend to RAM

Hi all,

When I resume my system after choosing the “Suspend to RAM” option, the login prompt appears but the keyboard doesn’t work at all. (Caps/Num/Scroll don’t light up either)

The mouse, however, works fine and I’m able to click on the on-screen elements. Since I’m not able to login, I’m forced to reboot and abort the session.

Note that this does NOT happen with the “Suspend to Disk” feature. (ie, it works fine).

Would be grateful if someone could offer assistance in resolving this issue.

System Specs:
openSUSE 11.2 KDE4.3 x86_64 (updated)
Sony VAIO VGN-CS17G

Have a look here
Suspend to RAM - openSUSE

and
Pm-utils - openSUSE

Anyone find a fix?
i got the same problem with an asus eee pc 100HE.
I read all the docs and tried some commands and nothing worked.

I had the same problem with an Asus eeepc 1001HA. I use the Gnome version of openSUSE 11.2. I changed the setting for keyboard in the controlcenter -> keyboard -> layouts from “evdev controlled” to “asus” and “asus laptop” and after that the keyboard works perfectly after resume from suspend to ram.

I had the same (or similar) problem:

After resume from s2ram no keyboard function but mouse and touchpad would work. I could start a new session using the mouse and eveythng would be fine in the new session - but the original session would still have no keyboard. Strangely I could s2ram the new session and resume with no problems?

Since KDE 4.3.5 doesn’t have the option to change the keyboard setting like the Gnome version the fix I ended up with was this: I created the following script:

/etc/pm/sleep.d/40-i8042-input.sh

I think you can call it anything but this name was a remnant from a similar fix I found.


#!/bin/sh

# Unbind the AT keyboard interface.
if  -f /sys/bus/platform/drivers/i8042/unbind ]; then
  echo -n "i8042" > /sys/bus/platform/drivers/i8042/unbind
fi

sleep 1

# Rebind the AT keyboard interface.
if  -f /sys/bus/platform/drivers/i8042/bind ]; then
  echo -n "i8042" > /sys/bus/platform/drivers/i8042/bind
fi

I made it executable with:

chmod +x /etc/pm/sleep.d/40-i8042-input.sh

That fixed the problem :slight_smile: . It just does an unbind/bind of the keyboard upon resume. Hope that help some of you others!

Good luck!

HP DV9000
Opensuse 11.2 (KDE 4.3.5)
2.6.31.12-0.2-desktop

Hi,

Same stuff here - HP DV5 system. Upon wakeup not able to use the keyboard and touchpad, but external mouse works. I’ve been able to simulate it with the first part of the script you posted, but the second part of it doesn’t do anything… And it seems that re-logging in doesn’t help either… :o:| Any ideas?

Cheers Matt

Posting here to let everyone know that I’ve submitted a bug report - Bug 625779. Everyone facing this problem should try to submit their test results as well, if we want to see this problem fixed sometime in this century.

Please follow the troubleshooting instructions over here: SDB:Suspend to RAM - openSUSE