11.2 is ****! Wifi vs NetworkManager-My two schekles worth

I don’t mean to go off on a rant but… What in the name of Sam Hill were the Suse folks thinking? THEY BROKE IT BIG TIME!!! I’m just not PO’d, I’M SERIOUSLY PO’d. >:( I just upgraded from 11.1 to the long awaited 11.2 distro on my Sony Vaio laptop. I have done simple upgrades from the version 10.2 (originally installed on my VAIO) to 10.3 to 11.0 to 11.1 everything worked flawlessly including wired and wifi networks with Knetworkmanager. After doing what I thought would be a simple upgrade to 11.2 and then working through a mountain of issues not the least of which were blank screens, locked keyboards and a non-functional mouse, I still am unable to get network manager to hook up to either wired or wifi networks. The only way I have been able to get on the internet at all is with ifup and still the wireless adapter will not work even when set up with the exact same driver (ath5k) as in 11.1. In fact, except for the networkmanager icon in the system tray I have NO way of knowing if it is even running. I would expect this type of thing from Bill and and the Microshaft folks, they have a track record of this type of built in obsolescence and incompatibility but NOT from the Linux folks who are supposedly working to be better than all of that. The reason I was drawn to the Linux opsys in the first place was because unlike Windows, Linux allowed me to regain control over the hardware and didn’t log a bunch of “secret” data to report back to Bill about my hardware configurations and internet sites I visit regularly etc.,etc.,etc… I should NOT have to back up all my data, (all 8 Gigs of it) wipe the disk and do a clean install just to have a simple version upgrade- which from what I’m reading in other threads in the forum isn’t getting networkmanager to work either. At this point aside from a bunch of headaches and aggravation and some fancy new icons I see no reason for anyone to go to 11.2. If I don’t get networkmanager up soon I’m going to back up my home directory, wipe the drive and go back to 11.1.
If anyone has any suggestions for getting network manager to work I haven’t tried, I will graciously try them and report back. If anyone else would like to chine in with their two cents, I would also graciously like to hear it…