11.1 unable to shutdown and restart

i did an upgrade yesterday and now when i press shutdown or reboot i get a status bar as usual.it reached the end and just hangs there and i get a message " init : there is nothing to do in this runleve " (or words to that effect)
i only thing i can do was to cut the power switch.any ideas how to fix this

Have you tried shutting down from a terminal?
(/sbin/shutdown -r now)
I found upgrading left a few funnies on my system so did a fresh install and had no problems with 11.1.

yes mate…did that…tried it in a su terminal with the same effect.
and BTW the message i am getting is :
" INIT : no more processes left in this runlevel "
and before this all the processes are shut down.it just hangs there an all can do is pull the plug.
a fresh install …boy you got some patience.i have configured nd installed some applications and i am too lazy to do it again ( and ya i did a fresh install a couple of weeks back and was trying to i just couldn’t keep my hands off the updates and finally ended up with this )