11.1 RC1 - No compiz, window effects, and broken plasma dash

I am having trouble with 11.1 RC1 window decorations and any of the effects provided in both Gnome and KDE4. KDE4 tells me that the X extentions (xDamage and xComposite) are not available. In version 11.0 I had no such problem, in fact, I could run CCSM with almost every plugin possible (hollywood’s got nothing on this setting) beautifully.

Also, in Gnome, I always used the Molecule screensaver which I understand is opengl. On 11.1, it looks different (maybe more crisp?) and is slow as molasses.

I have a Dell precision T3400 with a quad core processor, 4 gigs of ram and an Nvidia Quadro NVS 290. I was hoping that everythign was a problem with my driver but there are no Nvidia repos to update from and I am trying to avoid manual driver installation because it seems like a major pain.

Anyone have a clue what may be going on here?

Well, without the Nvidia drivers your hardware can’t provide openGL, so openGL uses software emulation. That is really slow.
I installed the Nvidia drivers from the Nvidia website and felt no pain at all. Installation runs via a simple script file. All you need ist gcc, make and your kernel sources (Did I forget anything?). Unfortunately I can’t recompile the driver after a kernel update to because there are no kernel-sources provided yet.
So, if you can live without openGL until the final release or until the Nvidia repo is up and you don’t want to install from the script, just wait.

Thank you, that makes me feel better. I am fairly new to suse and I’m not very confident in my troubleshooting skills yet and I am glad to know that my suspitions about opengl were accurate.

Ok, so that didn’t work. I downloaded the most recent driver from NVidia “NVIDIA-Linux-x86-177.82-pkg1.run” to no avail. Everything that was broken, still is and it seems like everything is running a little bit more slowly. Anyone have troubleshooting tips?

Hmm, strange, for me it worked. After you did the Nvidia config thing at the end of the installation the driver should be properly configured and run the next time you start your X-server. Have a look at the “Device” section of /etc/X11/xorg.conf. There should be something like Driver “nvidia”. If it reads “nv” or “fbdev” or whatever the nvidia driver is not in your X config. You can configure X to use the nvidia driver by typing sax2 -r -m 0=“nvidia” in that case. You can also run glxgears, it’s an openGL test programm.

sorry, there is an error in my previous post. It should be sax2 -r -m 0=nvidia

Looks like we might be having fun with this one…

The Device section looks good

Section “Device”
BoardName “Quadro NVS 290”
Driver “nvidia”
Identifier “Device[0]”
VendorName “NVidia”

I also saw the gears so opengl must be working, I wonder why I can’t get desktop effects or my plasma dashboard.

Whats your frame rate it should be pretty high if it only runs at around 34 fps then you don’t have any acceleration.

303 frames in 5.0 seconds = 60.451 FPS
299 frames in 5.0 seconds = 59.760 FPS
300 frames in 5.0 seconds = 59.960 FPS

Nope it should be much higher
I have the new ati driver and to build that I neede the kernel source code which must match
youre running kernel in order to build the module the pae kernel won’t work you hve to use the default. If you know where your nvidia install log is look at that.
anybody that has installed the new nvidia driver HALP!

Cool, we are getting somewhere, but since we are going so far into the rabbit hole, I would like to describe what I did to install the drivers so nobody has to cover the same thing twice.

Let me start off by saying that I looked up this information from the opensuse nvidia page.

  1. Install kernel sources (already had gcc and make, duh)
  2. Downloaded the drivers from Nvidia
  3. Went to runlevel 3 by opening a terminal and typing “init 3”
  4. Logged in as root
  5. sh <nvidia installer file>.run -q
    The Nvidia software did its thing and compiled with the linux sources. After the installer was done:
  6. Typed “sax2 -r -m 0=nvidia”
  7. reboot

I didn’t have any errors and I couldn’t imagine why the driver wouldn’t load with opengl acceleration. Also, if it means anything (which I don’t think it does) in the sax2 screeen at the bottom “Activate 3d acceleration” is selected and grayed out.

Finally, I noticed that my monitor is, and always has been “LCD 1680x1050@60HZ” even when compiz was functioning, but when I look at the Nvidia config program that is loaded separately from sax, it knows I have an Acer AL2016W. I think that is the extent of my knowledge…

Hallo, welcomed to the club, the same here,
today I updated the kernel with the new provided kernel-source (up today we are missing the -8.1 source >:().
The NVIDIA driver (NVIDIA-Linux-x86_64-180.06-pkg2 works perfect).

glxgears shows 25153 frames in 5.0 seconds = 5030.556 FPS.
But compiz don’t work.
Enabling Desktop effects, disappears the windows taskbars (or better is transparent), or the mouse pointer.
For me it’s more likly a problem with compiz, than a NVIDIA driver issue.

if 3d is enabled try as root :

nvidia-xconfig --composite --allow-glx-with-composite --add-argb-glx-visuals

then restart X

source :Kwin Effects. - openSUSE Forums

rotfl! I have my cube …yeah.
I will explain what I have done.
I have reinstalled compiz and all what has to do with it. Nothing … every thing like before.

So I have played a little with compiz-configuration-manager(CCM).
I have tried to activate the cube, and CCM asked me to install the missing glx-plugin. I confirmed with yes, but no effect.
So I have went to Preferences, unmarked the auto plugin loading and added manualy glx to the right panel.
From this moment I have all desktop effects, I want.
The only problem … I have to resolve …desktop effects with every session has to be activated again.

Weird…that’s one of the problems the open-source radeonhd driver had in beta 5.2 (RC1 fixed it) during that nasty regression.

Now, with RC1, I can set a custom monitor selection using SaX (I have a Micron 19" CRT, which is actually an OEM version of the Panny Panasync/PanaPro P70) and have the 1600x1200@75Hz NI refresh rate (which the monitor supports, but I have to set as a custom rate thanks to EDID of the monitor itself being wonky) actually hold up! (This is something that Ubuntu falls flat on; so does Fedora, unfortunately.)

Ok, so I am back and tried re-compiling with the new sources and I automagically had compiz working! YEAH!

Now, the effects look like crap because my GL frame rate is still 59.612.

I noticed that I have kernel-source version 2.6.27-4.4 but the current version is 2.6.27-4.1, could this be an issue?

So I tried the NVIDIA drivers 180.11 and 180.06(currently running) both of which gave me the same GL frame rate of 59-60. PLEASE HELP!!!

You can thank me later guys. :wink:
Found a solution
Head over to
CyberOrg » Compiz on openSUSE 11.1

and follow instructions.
P.S. It’s a compiz problem apparently and not NVIDIA as i also tried every driver, now i got everything with no problems whatsoever
P.S.2 Glxgears works fine again having about 4.5k frames per second.
P.S.3 As i said You can thank me later :wink:

yes upgrade to kernel version 2.6.27-4.4 or downgrade your source
then runyour installation. I have the new ati and am assuming the nvdia is similar check your xorg.conf file to see if the driver is installed if not run the
nvidia command that would mimic aticonfig --initial reboot

Kernel higher than 4.1 at the end is no more available? Read announcement about GM edition. They had to rebuild everything thus there are no fresher sources or kernels :slight_smile: