11.1 Live USB

I’m trying to make a Live USB stick so I can install on my Eee, and I couldn’t figure out the instructions for using Kiwi from my 11.0 install.

So I followed the instructions at openSUSE Lizards » Making openSUSE 11.0 LiveUSB : The Easiest (and Fastest) Way with an 11.1 LiveCD ISO, and without doing the initrdud replacement. So now when I boot up I get past the GRUB menu, the kernel boots up, but stops and shows this message:

Waiting for CD/DVD device(s) to appears…
Waiting for USB devices to settle…
Failed to detect CD/DVD or USB drive!
rebootException: error consoles at Alt-F3/F4
rebootException: reboot in 120 sec…

Is there something extra I need to do so that it can find the CD?


Here’s the fix, just take the iso, unpack onto the the usb drive, after installing syslinux onto the drive, copy config.(gnome or kde(4?) depending on kind of livecd).isoclient to config.isoclient

That’ll fix it :slight_smile:

That did it, thanks!

I have similliar error…

Waiting for cd/dvd dribe to appear
Mounting Live boot device…
Couldn’t find Live image configuration file…

Could anyone help me? I tried 6 times already…
could you show me your config.isoclient?

I fixed the problem by modifying initrd (see this post :How to Make openSUSE 11.1 LiveUSB | Spirit of Change regarding modified initrd)

I figured it out few hours before you posted but thank you for helping!

Hi Jdarklin,

Did you success with default initrd or should you used modified initrd ?

It seems that default initrd working successfully for some guys but I always get the error message :

Mounting Live boot device……
Couldn’t find Live image configuration file…

If I used default initrd

Did anyone managed to make a USB Live disk with iPOD, is it possible at all?

I have no IPOD yet :wink:

But AFAIK, You may used FAT32 and Ext3 partition if you wish to try.

FAT 32 by using above link or using KIWI for generate persistent liveUSB : Live USB stick - openSUSE

Since this is my first post here - Hello to everybody :slight_smile:
Very good forum, already found plenty of interesting topics.

And now to the problem :slight_smile:
My laptop doesn’t have a cd drive and I’m trying to make a live usb.

Already did everything posted above - downloaded syslinux and made the usb bootable. Copied the KDE4 live cd to the usb with all the movement of files to the root folder of the usb, downloaded intrdud and so on.
And it is still not working - here’s the error message:

cddev /dev/sda1:/dev/sdb1
mounting live boot drive…
failed to mount RW root filesystem
shellException: providing shell…

any suggestions? thanks in advance.
I really first want to try the live distro and see if all the hardware is ok before i install it…

EeeUser ASUS Eee PC Forum / openSUSE onto SDHC without CD drive -> STUCK!

This worked for me, and I think might on a USB as well. And if you aren’t installing onto SDHC or USB, but an internal drive, you can ignore most of it, as I understand it. Just follow pindar’s first post.

Good luck.

I’m having the same problem as well; I’m making a multi-boot DVD and I cannot open the initrd file. It is gzipped, but it is not labeled with the .gz extension. I tried via command line and with file roller so I can take a look at the syslinux.cfg file to no avail. I basically copied the entire ISO right to my isolinux directory of my live disk and the error message is about not being able to find the config.isoclient data. It’s there, it’s accurate, but I think syslinux.cfg is looking in the wrong directory and I have no clue how to open/gzip/edit the file. Any ideas or advice? By the way, I’m using the openSUSE 11.1 Live KDE4 version.

It’s the linuxrc file that needs adjusted. I am not sure which type of compression openSUSE used on the initrd, but I did finally extract the directory and recompressed it, but now openSUSE won’t boot normally. All I get is a black screen - no errors, just a black screen. Still working on a solution… all I have to do now is insert the custom linuxrc file into the appropriately compressed initrd file and all should be well.

I figured it out! The initrd image is cpio’d, I had to gzip it, extract it and then extract it and all it’s directories with the cpio syntax. What a pain in the rear, but then again, most things worth doing in life are not easy. :slight_smile: Now I have a multiboot distro that boots PCLOS 2009.1 Gnome, openSUSE 11.1 KDE4, Fedora 10 KDE4 and Arch Linux (Chakra).

Can you be more specific at what you did with the initrd and linuxrc files? Not sure I understand quite well what you did.

I am using Grub to make bootable usb Drive for OpenSuse 11.1 KDE 4.0. I have three partitions on USB key. Two are DOS partitions of 60 MBs and can boot up perfectly fine with Grub.

1.First partition-syslinux configured for Offline Windows NT 2K XP password Administration
2.Second Partition- Windwos 98 DOS systems for Ghost, Partition magic, DOS network boot
3.Third Partition - the GRUB boot partition.

I have copied OpenSuse11.1 to the third partition and followed all changes including initrdud. I get the following error:

cddev /dev/sda1: /dev/sdb1
—> Mounting live boot drive …
—> Couldn’t find Live image configuration file
—> ShellException: providing shell …

The Grub menu.lst contains

title OpenSuse 11.1 Live
root (hd0,2)
kernel /boot/i386/loader/kernel root=/dev/sdb3 kiwidebug=1 ramdisk_size=512000 ramdisk_blocksize=4096 splash=silent showopts
initrd /boot/i386/loader/initrdud

Any suggestion will be highly appreciated.


First of all you shouldn’t be using KDE 4.0. Use at least KDE 4.1 or better yet 4.2. If it’s not finding the live image then there’s something wrong with the version of initrdud you’re using. Are you sure you have the right one?

Good Luck,


I have the same problem with this version openSUSE-11.3-KDE4-LiveCD-i686, but i can’t find kde config, can somebody help me please?