11.1 install video problem


I have a server with a NVidei Riva TNT graphics card. I have been using this one sinse suse 7.1, and had no problems.

When 11.0 came out I decided to upgrade and faild. So now when 11.1 is out I tried again, first with the network install “mini cd” and later with the Live CD, md5 ok on all.

When I boot the graphic is nice and I get the choice of repair, install etc. But when I select install, the problem starts. I get the progress bar “loading kerne …” and it all looks nice. But then I get a screen filled with blocks in all coulors, the size of the block are like semi graphics on a VT100 terminal.

Please help, my 10.2 is as you know discontinued for updates.

// Hans

Are you updating from 7.1 to 11.1 ? or updating from 10.2?

What are the hardware spec’s of your PC? If it ran 7.1 it may be rather old and limited in hardware. ie CPU ? amount of RAM ?

Did you try a text install (press F3 at installation menu to get option) or a safe setting install (press F5 at installation menu to get option).

I was installing 11.1 on a new partition, currently I am running 10.2.

I downloaded the 10.3 network install iso and that one worked out of the box.

So 11.0 & 11.1 network install iso and 11.1 LiveCD iso give a garbled coulorfull screen.

I then tried the text version of 11.1, but the screen size was wrong so the text got messed up.

Finally I tried the VESA option under F3, and it works :slight_smile:

Thanks for the hint of F3, I had tried different resolutions but never VESA.

Case closed, but I must say that 10.2 & 10.3 handled this in a smoother way.

Se La Vie

Did you install the nvidia graphics driver?

Sometimes this boot option helps with the newer kernel:


The graphics works during the installation because it is using framebuffer. Later when the video card is configured the X server is run, and the install will use what it thinks is the best driver; it switches from framebuffer. With an nvidia card, that is typically the open source “nv” driver. You probably will be all fixed up after installing the proprietary nvidia driver (called “nvidia”).

Sometime during the 10.x to 11.x evolution, SuSE-GmbH switched from using the VESA graphic driver as a default, to using the openGL (opensource) graphic driver as a default. You initial failed efforts could have been a side effect of that.

No, I only selected VESA by using F3 before the installation. System up and running now :slight_smile: