11.1: clicking HDD


this morning I upgraded 11.0 to 11.1 on my Lenovo 3000 N200. Now I keep hearing a click-like noise from my hard disk at least every few minutes, sometimes even more frequently.

I think this noise comes from the read/write heads getting parked. I heard it in 11.0 too, but not that often. It concerns me a bit because I heard it was bad for the drive if the heads are constantly parked.

Is there any way to adjust the time after that happens?


Sounds to me like your drive is dieing had clicking sounds on a drive that died.
I ould back up my data asap. And replace the drive.

You can do some testing with SMART


Seems to me, it is the old known problem of Linux with SATA HDD drives. Try to tune the “power saving” via Laptop Mode Tool (see /etc/laptop-mode/laptop-mode.conf).
Also, check the /etc/sysconfig/powersave.


see Problem with hard drive clicking - ThinkWiki

Thanks for your replies - I think the thinkwiki article nails my problem.
I will try and work through that a soon as I find the time.

Same tick-tick clicking sound with
HP Compaq 2710p (Toshiba 1.8" HDD).

sudo hdparm -B 254 /dev/hda

helped, but it is temporary solution, as I understand.

Will read ThinkWiki later.
Thanks for the link!

I see that the correct power management setting for my HDDs are set only if I login via the kdm.
If I login on a text console only the second hdd is correctly set (the one on which the root partition is). The first one is ignored.

Any idea on what I could do?

I’d like to bump this…

I have the same problem, however in my case the disk is clicking after each and every operation, in that it parks the head. Using smartd I tracked the number of load cycles and sure enough, these increase after each click.

I’ve written a script that sets hdparm -B 254 /dev/sda upon boot, and as hooks to thawing and waking up from hibernation and suspend, respectively.

However, something else in the system changes the hdparm settings! After a while, I guess after the screen saver, the values return to defaults and it starts clicking again. Also, the wake and thaw hooks do not seem to work always.

Can anyone say what other parts of the system could be touching hdparm settings?

The simplest way to find out, which programs
are supposed to change hdparm settings:

  1. open Yast -> Software Manager
  2. Search in: tick all fields (Name, Summary, Description, etc)
  3. Search for hdparm

The programs, that seemed relevant to me:

storage-fixup (script, which is supposed to fix the clicking HDD bug)
hdparm (hdparm program itself)

So make the same search in your system, and see, what is installed.

I kind of ‘fixed’ the bug using laptop-mode-tools.
I don’t know, what this program (script) does, but HDD doesn’t click with it if:

  1. I’m logged into KDE session (in KDM HDD continues to click once in a few minutes)
  2. The notebook is on AC-mode (if I run on battery HDD clicks once in a few minutes)

Very sad that this quite a serious problem is still not fixed with a ‘official’ patch.
And as long as I know other distributions are also affected.