10.3 Bad Superblocks and everything

Hello smart and helpful people,

I might have wrecked my system by failed online update, in the middle of updating the connection failed, attempting to get on the net wasn’t fruitful after that, then I had 11.0 in the boot menu, but still KDE 3 as a desktop, which
looks faulty (or can that be?).
No problems, though, until out of the blue, Suse crashed and I couldn’t get back in.

I have WinXP and OpenSuSe 10.3 (or partially 11.0?) on one physical drive, when I try to boot SuSe, the status bar hangs pretty shortly after, failsafe booting produces interesting lines avalanching.
When I try to boot XP, it quickly restarts, failsafe or boot via installation CD doesn’t change the experience.
When I try to use SuSe installation media (10.3 on DVD or 11 on live CD), I’m told the drive I want to install to is corrupt.

I’ve come across “TestDisk”, which I ran from Knoppix 6 live CD (sorry for the potential heresy), it told me about bad superblocks and how to fix them:
/sbin/fsck.ext3 -b XXXX -B YYYY /dev/hda1 ; where the X had to be replaced by the found bad SuperBlocks and Y had to be replaced by the blocksize, 4096 in my case. The /dev/… part would be my partitions.
So I’ve tried all found Bad Superblocks and all partitions from hda1 to hda7 and hdc1 to hdc7 (I’m still unsure whether hda or hdc are the right partitions, I’m pretty thick and new to all this), “unreadable or no valid ext2 data, etc…try another Superblock” (sorry if this looks a bit fishy, I’m trying to translate the german version), then, taa-daa:
Right SuperBlock, right device (hdc6), prompt:

ext3 Recovery-Flag clean, but the journal contains data.
Recovery features in Backup Superblock aren’t set, journal will be launched anyway
/dev/hdc6: rebuilding the journal

And now it hangs and looks like it will keep hanging til power outage.

Again: I am completely new to this “merrily weedwhacking through commands that look pleasant to me”, just getting a glimpse about which command does what and which parameters, bla…

fdisk -l /dev/hdc

shows all partitions, looking clean, just: “Partition table entries are not in disk order”

I’ve also tried other commands, but …hmm, how about finding a helping hand here and then pasting all the sad things my prompt shows me?

Greetings and thanks in advance,
Lubomir (^^)v

Mmm weedwhacking lol sorry…

Well I’ve been here and my experience wasn’t good. What I learnt was don’t go weed whacking with commands you’re unsure of…

I’m really unsure if you can go back from this, the bit about
Recovery features in Backup Superblock aren’t set, journal will be launched anyway
Sounds a little scary…

Now if you can just run a fsck from the live distro but on the drive you know is faulty. I think this maybe partially your problem. You don’t use a hedge trimmer to take the weeds out of your flower bed :wink: (hehe Sorry)

If I was you I would try to rescue as much as you can before you destroy anything more.

Now I actually think what you should of done was tried a repair off the install media or getting to command line yast and trying to fix it from there. I personally think you had packages in a mixed state.

But if you really had a fsck problem I suspect this would of shown up else where. But presuming it is then perhaps the drive is really broke, can you format it with the knoppix disc? If you can’t then it would seem you went about it the correct way but the drive died really quickly. I found Suse was flagging it as dying, when windows wouldn’t boot. If the drive is old I would suspect it has finally given up the ghost.

Hello FeatherMonkey (…sent by Ming?),

thanks for your quick reply!

My attitude about the weedwhacking with commands is like: When I use some “VeryMegaSuperFixEverything-Tool” on Windows, I click on some potentially hazardous button; when I execute some command under SuSe instead, it’s potentially hazardous, just involves typing instead. There is no saftey, there is only, “OMFG backups, why didn’t I!”
I can access my windows partition and backup files to a USB-stick, which I’m at meanwhile.

The not-so-good-looking “journal all the way, no matter what” looked sort of safe to me, according to


, no warning there. Maybe my system failure is peculiar enough not to be mentioned there (of course there’s the famous “use at own risk” thingy when you run testdisk, but that’s present everywhere and to me the alarm bell is worn out, part of my charming thickness :shame: ).
Before weedwhacking I’ve tried repair-install, yes, but to no avail.
The Bad Superblocks are located in 2 SuSe partitions, the drive is a not very old Hitachi 60GB drive, and I don’t want it physically to be broken. And if it mustn’t be, it can’t be, of course!
So, my n00bish questions go:

  1. Is my attempt of understanding correct:
    SuperBlocks are sort of indexes, telling the filesystem about the size and location of data packages, it can well be that only these tiny indexes get fixed and everything will be safe and sound, partition tables etc?

  2. Which (not “desperate”, naaah!) ways to check and fix the entire disk content are there? I would prefer you to say, “type this and that command, then paste the log, then we will see, AAH! No Biggy!; then another command, then HappyHappyJoyJoy”.

  3. Since my windows data are more important to me (the SuSe thing is an experiment triggered by that M$ campaign which went: “Here’s our humpty rip-off of MacOS, better jump ship!”)- if I format all to ext3 there’ll be no more windows, if I format to NTFS there’ll be no more SuSe, if I format to FAT32…hmm, naaah…correct?

Greetings and thanks in advance,
Lubomir (^^)v

  1. Is my attempt of understanding correct:
    SuperBlocks are sort of indexes, telling the filesystem about the size and location of data packages, it can well be that only these tiny indexes get fixed and everything will be safe and sound, partition tables etc?

Sort of my understanding and seems to agree with this page…
Linux Tips - Superblocks

  1. Which (not “desperate”, naaah!) ways to check and fix the entire disk content are there? I would prefer you to say, “type this and that command, then paste the log, then we will see, AAH! No Biggy!; then another command, then HappyHappyJoyJoy”.

As far as I know you where going the correct way but why did you have incorrect superblocks afaik these are caused by corruption. i.e when I did it moving partitions and rebooting moral of the story don’t! Wait for it to finish moving partitions. But iirc I saw a false warning once when I had an error in my fstab.
I did that testdisk thingy wasn’t to impressed I did recover the data but in over a million files when it should of been 20000(18hrs later on 200GB)… I gave up trying to fix that, they end up in lost+found with nonsense names(yep that backup thing we preach about).

  1. Since my windows data are more important to me (the SuSe thing is an experiment triggered by that M$ campaign which went: “Here’s our humpty rip-off of MacOS, better jump ship!”)- if I format all to ext3 there’ll be no more windows, if I format to NTFS there’ll be no more SuSe, if I format to FAT32…hmm, naaah…correct?

At the moment I’m not sure it really matters what FS as long as it is one :wink: but yes I agree, you’ll have to mix as far as I know linux can’t be installed on fat32.

failsafe booting produces interesting lines avalanching
These might of helped you can do a lot from cli, though tbh you’ll see a few recommend not to upgrade. Mileage varies but I guess you’ll be one of the few also recommending not to now. If we take the example that you had got it half in but fstab was trying to use swap then iirc you get the superblock error. But it isn’t what it says if this is a valid ext3 partition, but its not, I’m sure I borked an install along these lines.

As for ming went over my head so no, just trying to think of a moniker have 2 parrots that do more climbing than flying :wink:

Ahoj again

first things first: “Feathered Monkey” made me think of Emperor Ming’s helpers in “Flash Gordon”, hence the slight confusion. Of course, climbing dinosaurs are far better!

So- the avalanching prompt lines when desperately trying to run failsafe might have a hint in them- but how do I pause it? [Pause] or <–] or [whatHaven’tITried]?

We agree on the problem might only be the very Bad SuperBlocks and the rest of the data is fine, just inaccessible. (yet , of course!)

If we don’t, let’s at least, please, agree on the possibility to delete all the SuSe partitions without messing with hda1 (where Cubase and Reaktor are waiting for me to let out some steam… heated up by Novell who seem to have really, technically spoken, “Fok Top” with their mislabeled alpha versions…).

So could you please walk me through the steps, which stuff to paste for verification, starting with the least brutal operations? I’ve spent over a week with different attempts and solutions now (this forum, a shedload of stuff google came up with), but always got stuck at the point where
a) Bad Superblocks oughta get fixed with fsck
b) fdisk -l should check the partitions.

I guess it might have been smarter to maybe join an existing thread that got solved by a) or b) and resume, but those threads look so suspiciously easy! Must be yuppies or something- scienos? Illuminati? Faith healers?

Best greetings and thanks in advance,

From the sounds of things what you’re interested in is booting windows try Swerdna’s tut at the bottom should get rid of grub and get you back to windows…
Boot Multiboot openSUSE Windows (2000, XP, Vista - any mix) with Windows bootloader.

So presuming you have done that I would try the live disk and just a plain fsck see what info it gives you. And perhaps it’s not hanging but I would expect it to be more verbose than nothing. As I said it took 18hrs for me to get it off, and a lot of y’s. Yet you’ve mentioned no auto prompt flag so I suspect you never even got to that.

The problem I see is
Recovery features in Backup Superblock aren’t set, journal will be launched anyway
Why not? my limited understanding is you replaced it with a duplicate superblock so should be the same.

Even ignoring that, you have
When I try to boot XP, it quickly restarts, failsafe or boot via installation CD doesn’t change the experience.
Which may mean fixmbr is impossible, do a smart test with knoppix, see what that says?

But the more I think and trying to untangle the knot is difficult, you have 2 HDD’s misbehaving and even I don’t believe any one could be that unlucky. Now if fixmbr doesn’t get you any where and it really is restarting, it has to be Hardware. Now if grub and mbr it wouldn’t be spewing rubbish on the other drive. As for catching what is the last thing it freezes at or are you saying it doesn’t?

What does the repair from the install media tell you?

First we need to investigate what the cause is, I’m inclined to think maybe hardware, as 2 HDD’s don’t work not one. Grub beyond 1st part residing on maybe the windows HDD mbr and chain loading I wouldn’t of thought will cause a restart. We can test that fixmbr, but you imply the Windows installation CD doesn’t work to.

But it still doesn’t explain both disks, 2 distro’s in one hit so I struggle to believe unlucky but we don’t know if something you’ve tried killed the other one.

The only thing confirmed is ram works and the optical drive, via the knoppix disk.

Try fixing the windows install with fixmbr…
So I would run some smart tests confirm the disks…
Try a fsck with no flags see what it suggests…
Check the disk structure isn’t strange like partitions overlapping…
But I don’t think it is the disks unless you killed one that was OK. Which leaves hardware as for flashing by at reboot I know Oldcpu has been known to record it with a digital camera and pause it. Being so early on and if it isn’t freezing won’t help as getting to logs won’t be easy.

First identify the cause, and make sure before trying to fix fsck is quite low level stuff. I would guess any one serious about the data would be making a backup before even trying to run a fsck(I’m lucky my data is transient couldn’t care less).

Yippie, now we’re fixin’!

First: Sorry for the misunderstanding I might have caused,
all the beautiful things happen on one physical drive-

linux@linux:~> su
linux:/home/linux # fdisk -l

Platte /dev/sda: 60.0 GByte, 60011642880 Byte
255 Köpfe, 63 Sektoren/Spuren, 7296 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes
Disk identifier: 0x1b1c1b1b

   Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/sda1   *        1277        7296    48355618+   7  HPFS/NTFS
/dev/sda2               1        1276    10249438+   f  W95 Erw. (LBA)
/dev/sda5               1         194     1558242   82  Linux Swap / Solaris
/dev/sda6             195         847     5245191   83  Linux
/dev/sda7             848        1276     3445911   83  Linux

Partitionstabelleneinträge sind nicht in Platten-Reihenfolge

last message translates: partition entries are not in disk (/partition?) order

Then I tried fsck (all this from SuSe 11.0 Live CD:

linux:/home/linux # fsck -N /dev/sda1
fsck 1.40.8 (13-Mar-2008)
fsck: fsck.ntfs: nicht gefunden
fsck: Fehler 2 bei Ausführung von fsck.ntfs für /dev/sda1

linux:/home/linux # fsck -N /dev/sda7
fsck 1.40.8 (13-Mar-2008)
[/sbin/fsck.ext3 (1) -- /dev/sda7] fsck.ext3 /dev/sda7

linux:/home/linux # /sbin/fsck -N /dev/sda2
fsck 1.40.8 (13-Mar-2008)
[/sbin/fsck.ext2 (1) -- /dev/sda2] fsck.ext2 /dev/sda2

So: fsck without parameters (but the -N which should make it run safely) does nothing,
with the devices added it does nothing (I’ve tried sda 1,2,5,6 and 7, just stripped down here),
with /sbin/… in front of it does nothing,
with full /sbin/fsck.ext3 it suggests to continue with the SuperBlock thing … shall we? Or have I Fok Top something already?

I have the suspicion that trying to fix mbr or grub might not be where it’s at, since booting looks fine to me:
SuSe shows the graphical boot menu with 11.0 and 11.0 failsafe and windows, just all SuSe loading hangs after that; windows boot seems fine, too, until the windows logo is shown and then poof.

Best greetings and thanks in advance,

Right OK well the repair mmm, let me guess you only have the 11.1 livecd and and 10.3 complete.

I don’t think you have repair of the livecd, and I don’t think it is a good idea to run it from the 10.3 version. At this point what does the data look like can you mount it read only.

Seriously if this is you’re only option then all I got to say is /lost+found note they mention some maybe recoverable and look at the names of them…

If your windows is coming back clean I really would try to fix this as it seems this is what you want. Then think of it as a lesson learnt. Otherwise yes you can try it, as I mentioned earlier I had twenty thousand files turn into a million with nonsense names. If we’re talking the root directory then it will be far easier to re-install and your highly unlikely to have much that is user configured or personal data stored there. If you have well… From the looks of things home is clean and safe.

I can only guess the menu.lst or/and 2nd part of grub or/and fstab is corrupt, and is why it won’t boot. But as mentioned earlier you can test this, try non destructive things before destructive things.

Emotional confession of the day:
I guess I have a crush on that slightly demented penguin of KDEtoys…
but I will try to get over it and kill all the fok top ext2 or ext3 stuff, nothing too severe. And anyways: the /lost+found thing you linked to, plus your experience with it… I’m too mentally unstable for that.
So- how delete everything but sda1 (or hda1, I guess that was its name under Knoppix)?
I’ve now looked closer at the “How To Boot”-thing and:

From Live CD 11.0 into Yast → System → Bootloader → “Because of the partitioning, bootloader cannot be loaded” (click “okay”)
→ tab “Bootloder-Installation”, check “boot from root-partition” → “Finish”
Bootloader window collapses, into the bash, doing step 3,
step 4 got me lost… where’s my root partition? sda6? So just:

dd if=/dev/sda6 of=/mnt/windows/suse.bin bs=512 count=1

and that’s it?


Hold the horses no do the fixmbr as the windows fix right at the bottom of the page. This should rewrite the mbr and make Windows reboot, save this one.

You can’t do the other way as if I am surmising / is corrupt that means kernel and god knows what else lots of early apps that you probably never use but need to boot.

If knoppix is calling it hda the that it will be. Just look at the fdisk output or open gparted I’m sure knoppix has it. As long as you leave the one with HPFS/NTFS windows should be fine.

Now when in knoppix check sda7/hda7 I suspect this /home if it is then when you re-install switch to custom and tell it not to format home. I would perhaps format sda6 before getting to the install procedure as you said earlier you tried.(I’m still not convinced the superblock corruption doesn’t have a reason)But lets be optimistic and say it was just a fluke of the crash whilst installing combined with a 2 version jump upgrade from 10.3 to 11.1

Just fix windows the windows way first once you have that working then you can move onto re-installing 11.1 keeping /home.

Pardon my thickness:
“do the fixmbr as the windows fix right at the bottom of the page” refers to Step 5 then? Because the very last procedure on that site says, “Boot from the XP/2000 installation disk and proceed to the final screen where you have the option to Repair Your Computer. Press “R” for Repair and log onto the Windows installation”, which obviously doesn’t work.

kwrite /mnt/windows/boot.ini 

doesn’t work… if that’s the one…

the puzzlization never ends…

Lower down still

However if it doesn’t because Grub code has lodged in the MBR you can easily replace it with Windows boot code and get back on track as follows:

Sorry, I hadn’t thought I’d get this far…
But it’s worth the short way,
“New MBR could not be written. The drive might potentially be damaged.”

He’s wrong there, right?


I suspect not, I maintained all along it has a reason for corrupt blocks.

Back to the suggestion of smart disk check and perhaps even manufacturers disk check utils.

Disk Check Utilities- stuff that needs to be installed? Sounds miraculous to me, so “smart disk check” might be easier (BIOS messages say, self-monitoring is fine, if it’s only for the very S.M.A.R.T. part, which fires my hopes I needn’t abandon that precious little hitachi), I’m pretty curious about things that work… hehe.

BTW: No matter what horrible things we might come across trying to rescue the disk (I mean computer stuff, not my thickness): Thanks a thousand for your patience and expertise already! I’m close to sending a big bag of millet spray for your friends.


You should have the tools on one of the live disks this was the first page I found no recommendation just a quick google.
Linux Harddisk Monitoring with SmartMonTools (smartctl)

I have heard of smart being wrong in rare circumstances, where as the manufacturer tools report it as fine. I don’t see why the mbr is broke so I’m inclined to think it maybe.

But not really been in this territory much, only time I caught it Suse flagged it before I noticed it on windows then it all gave up but it was expected.

As for expertise more experience than expertise :wink: I just came to the conclusion if auto fixing on boot or via rescue cd then it seems pointless and the only true rescue is a good backup policy(Something I’m not concerned with).

By the way I have to say I suspect English isn’t your native language. I have to say you embarrass me for the lack of another language and my sometimes lazy English.

I’ll keep my fingers crossed for you and hope that the smart tools come back good. I just hope you managed to retrieve what you needed, in case not.

Ahoy again,

smartctl should be on Knoppix Live-CD, on every cd ever burnt, just not on mine. Haven’t found out yet if it was on the previous version and got ditched, but version 5 refuses to run on my “system” anyway, so I’m still trying to find a simple list of content or something on
knoppix.net . Looks like they aren’t in for such exotic demands… yet, sure.
So before downloading any more funny repair-gizmos (which is a joy even via torrent, when you’re on isdn)… looking some closer at knoppix.net.

Oh, and looking at the screen next to the one I’m typing this into- I cannot get over this knoppix thing running and showing me the entire windows partition content, all ready for transfer, just looking sound enough to not make a backup (of the entire disk, registration of some Native Instruments stuff) necessary…
(Great movie btw, “I shizz on your drive”…)

The language thing: If I were great, you wouldn’t have suspected me of not being a native speaker, so I’ll have to live with a “good”. (Akkchooully ziss iss yor Onkel Fritz from Krautland, Guten Abend!) If I had the convenience of being raised with the most international language, I might not have learned any other stuff, more grey matter to fill with speed sudoku or thelike, nothing to be embarrassed about I suppose :wink: .
I’m still sooo much in for the idea of killing the evil parts: Accessing the evil parts (everything but hdc1 or hda1, whatever the current linux prefers to call it) and deleting them. Doing some Takeshi Miike stuff on them before deleting them!

Best Greetings,

Is it not on the Suse livecd? Even if not should be able to just enable a repo and install(Unsure about knoppix been a while since I tried). Should be able to just won’t be persistent but shouldn’t need a reboot. Should be able to use it straight away.

As for language being good that is an understatement :wink: your name gave it away not anything else.

As for looking sound mmm maybe at this moment, but a few runs of the disks whilst writing and it might not be.

But if I were skilled with languages, how could I call myself “the peacelike” and enjoy Takeshi Miike movies? Oh, what mysteries between my cute earlobes!
Back on the beef, my dear Watson: Knoppix 6 is a “micro-version”, not a CD with compressed 2GB, just some stuff that doesn’t contain smartctl. But! Knoppix 5 is close to running when I tell it to drop the drive by

Knoppix noswap

in the boot prompt. So now it does:
“Scanning for Harddisk partitions and creating /etc/fstab…Done.
Ignoring swap partition /dev/hdc5 as requested.”
And then watch him dangle and rot. I don’t get the fstab thing- is he doing something to/with/on the drive and then says “done”, like it were a living, breathing drive? And what other boot option from these


shall I use to get him running (and run smartclt and all will be roses, freedomofspeechreminder!)… “nodma” looks like something involving drives?


OK that makes sense … But honestly this is shouting a dead hard drive…

Knoppix just told you now swap isn’t working and it is struggling to get the info to create a temporary fstab for mounts. Please say you took what you needed off.

OK looking at cheat codes use nofstab as well, if you’re saying that this is your aim so you can rescue data. Then you’ll just need to do command line mount. Just make sure it is in ro and to be honest I would perhaps consider a dd to a good hdd then recover it from that.

It sounds like it is starting to die quickly so you need to do as little to it as possible and get it off as quickly as possible.