Environment

Laptop
Distributor ID: openSUSE
Description: openSUSE Tumbleweed
Release: 20191231

Server
Windows 2016 Std
Fully patched

LAN
Both Device on same lan
/etc/resolv.conf using
domain paedave.local
search lan
nameserver <ip of Windows 2016 Server>


What Am I trying to do?

I am trying to set my laptop up so I can use my domain login, to login to the laptop both when connected to the LAN and when offline (away from the lan) I have been trying to do this using Yast


Process Followed


  1. Open yast2 and navigate to Network Services -> User Logon Management

yast

  1. Open “Change Settings”
  2. Now, enable “Allow Domain User Logon”, Enable domain data source -> “Users”; “Groups”
  3. Open Join Domain
    1. Insert Domain Name “like domainname.site.org”
    2. ID-Provider is Active Directory
    3. Auth-Provider is Active Directory
    4. Enable Domain

  4. In the next panel, activate “Read all entities from backend database”
  5. Then, type in your Active Directory Domain controller like “adserver.domainname.site.org”.
  6. On the next panel, authenticate with a superuser like “Administrator” who is able to execute a domain join.
  7. Finish the domain join



Problem


When I get to the last auth-client screen there is no Workgroup listed

So after clicking on OK, I a message telling me that the domain join failed because the Workgroup name is blank and should be PAEDAVE


Question


On the auth client screen how do I get the WORKGROUP set, as when i load up the SAMBA screen on the Laptop it does say PAEDAVE.


Troubleshooting Attempted

When I run from the command linedavid@linux-7u1e:~> sudo net ads join -U Administrator
Enter Administrator's password:
Using short domain name -- PAEDAVE
Joined 'LINUX-7U1E' to dns domain 'paedave.local'


This works as when i run

sudo wbinfo -g

I see my domain groups


Questions


How do I do this using yast?
Am I better doing this from the command line? (If so could someone point me to some instructions)